net-analyzer/nagios-plugin-check_lm_sensors: bump to 4.1.1_p20191028
authorLouis Sautier <sbraz@gentoo.org>
Sun, 3 Nov 2019 20:02:20 +0000 (21:02 +0100)
committerLouis Sautier <sbraz@gentoo.org>
Sun, 3 Nov 2019 20:03:55 +0000 (21:03 +0100)
This version uses sensors's JSON output and works properly with
sys-apps/lm-sensors-3.6.0.

Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
net-analyzer/nagios-plugin-check_lm_sensors/Manifest
net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild [new file with mode: 0644]

index 1dcf0ec3498eb1ea9dd8d7a1e97600e0aee21440..563a41bf8eebd60366f336c7fdd21383c90d274e 100644 (file)
@@ -1 +1,2 @@
 DIST nagios-plugin-check_lm_sensors-4.1.1_p20170912.tar.gz 21681 BLAKE2B 7144c9b9fc4a2b2ccd964ce356809e8ea393b05f86015e5efe5b0ef70fccb585d520fdbba486fd1637c0ef9d2853d270cfb069f6bed22a105b5d80977a8481d7 SHA512 7870e29f58179bd71c917c2bcfe7ff0ee9f28be8b41b19b8f4f3e623fc3ca12395d6dbd55eef3f4084b3fedf2b1c4dc745357d045d19e1f00a3fe2e24a236e77
+DIST nagios-plugin-check_lm_sensors-4.1.1_p20191028.tar.gz 21775 BLAKE2B d1b9946f45ea30e66baa87825c29aa64f18927ec5c07641d05789f189bc3aacb9764b3790eaa699d83c11860027bc36af9b85ba95b2845afa7533d03fd9d153d SHA512 4473719e5631edbebb8d8ee79578243a97c46cf70a14a2c780560df811f9d4d63081788b2059a9636f26d19a68ac0a44d6b68a4b386b1145d3f3fad8d60439fe
diff --git a/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild b/net-analyzer/nagios-plugin-check_lm_sensors/nagios-plugin-check_lm_sensors-4.1.1_p20191028.ebuild
new file mode 100644 (file)
index 0000000..cd457b7
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit perl-module vcs-snapshot
+
+MY_PN="${PN/nagios-plugin-/}"
+MY_COMMIT="80db8aa58be8f5d7800564d62305281be1ec8e6b"
+
+DESCRIPTION="Nagios plugin to monitor the values of onboard sensors and disk temperatures"
+HOMEPAGE="https://github.com/matteocorti/check_lm_sensors"
+SRC_URI="https://github.com/matteocorti/${MY_PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-perl/Module-Install"
+RDEPEND="
+       dev-perl/JSON-MaybeXS
+       dev-perl/Monitoring-Plugin
+       virtual/perl-Getopt-Long
+"
+
+src_compile() {
+       default
+       pod2man ${MY_PN}.pod > ${MY_PN}.1 || die
+}
+
+src_install() {
+       perl-module_src_install
+       doman ${MY_PN}.1
+       local plugindir="/usr/$(get_libdir)/nagios/plugins"
+       dodir "${plugindir}"
+       mv "${ED}/usr/bin/${MY_PN}" "${ED}/${plugindir}" || die
+}