games-fps/gzdoom: Always build with fluidsynth and openal support
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>
Wed, 12 Jun 2019 23:13:06 +0000 (08:13 +0900)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 18 Jun 2019 20:55:38 +0000 (21:55 +0100)
FluidSynth is a dependency of GZDoom and cannot be disabled. Similarly,
OpenAL is a dependency of GZDoom on Linux and cannot be disabled.

Closes: https://bugs.gentoo.org/687922
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/12248
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/gzdoom/gzdoom-4.1.3.ebuild
games-fps/gzdoom/metadata.xml

index d3d5f880537b203b29e92587043711ffcfda5138..48957b791acb447983e6af9aca7d19a53b4cf1d8 100644 (file)
@@ -12,24 +12,21 @@ SRC_URI="https://github.com/coelckers/${PN}/archive/g${PV}.tar.gz -> ${P}.tar.gz
 LICENSE="BSD BZIP2 DUMB-0.9.3 GPL-3 LGPL-3 MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="fluidsynth gtk gtk2 +openal openmp"
+IUSE="gtk gtk2 openmp"
 
 DEPEND="
        media-libs/libsdl2[opengl]
+       media-libs/libsndfile
+       media-libs/openal
+       media-sound/fluidsynth:=
+       media-sound/mpg123
        sys-libs/zlib
        virtual/jpeg:0
        gtk? (
                gtk2? ( x11-libs/gtk+:2 )
                !gtk2? ( x11-libs/gtk+:3 )
        )"
-RDEPEND="
-       ${DEPEND}
-       fluidsynth? ( media-sound/fluidsynth:= )
-       openal? (
-               media-libs/libsndfile
-               media-libs/openal
-               media-sound/mpg123
-       )"
+RDEPEND="${DEPEND}"
 
 S="${WORKDIR}/${PN}-g${PV}"
 PATCHES="${FILESDIR}/${P}-fluidsynth2.patch"
@@ -48,7 +45,7 @@ src_configure() {
                -DDYN_SNDFILE=OFF
                -DDYN_MPG123=OFF
                -DNO_GTK="$(usex !gtk)"
-               -DNO_OPENAL="$(usex !openal)"
+               -DNO_OPENAL=OFF
                -DNO_OPENMP="$(usex !openmp)"
        )
        cmake-utils_src_configure
index 95f6ed619edf9bc3210e9f8e4551e329a8b02d98..cfd1b5ffe5604349e19a1d244fadaf30a1e6b273 100644 (file)
@@ -17,7 +17,6 @@
                <name>Gentoo Games Project</name>
        </maintainer>
        <use>
-               <flag name="fluidsynth">Use <pkg>media-sound/fluidsynth</pkg> for MIDI support</flag>
                <flag name="gtk2">Enable support for GTK+2 instead of GTK+3</flag>
        </use>
        <upstream>