Undo blas crap
authorJeroen Roovers <jer@gentoo.org>
Tue, 29 Sep 2015 18:03:00 +0000 (20:03 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 29 Sep 2015 18:03:00 +0000 (20:03 +0200)
Package-Manager: portage-2.2.20.1

dev-libs/liblinear/liblinear-210-r1.ebuild [deleted file]

diff --git a/dev-libs/liblinear/liblinear-210-r1.ebuild b/dev-libs/liblinear/liblinear-210-r1.ebuild
deleted file mode 100644 (file)
index 1e7b089..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit multilib toolchain-funcs
-
-DESCRIPTION="A Library for Large Linear Classification"
-HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/liblinear/ https://github.com/cjlin1/liblinear"
-SRC_URI="https://github.com/cjlin1/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-RDEPEND="virtual/blas"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig"
-
-src_prepare() {
-       sed -i \
-               -e '/^AR/s|=|?=|g' \
-               -e '/^RANLIB/s|=|?=|g' \
-               -e '/^CFLAGS/d;/^CXXFLAGS/d' \
-               blas/Makefile || die
-       sed -i \
-               -e 's|make|$(MAKE)|g' \
-               -e '/$(LIBS)/s|$(CFLAGS)|& $(LDFLAGS)|g' \
-               -e '/^CFLAGS/d;/^CXXFLAGS/d' \
-               -e 's|$${SHARED_LIB_FLAG}|& $(LDFLAGS)|g' \
-               -e 's:blas/blas.a::g' \
-               Makefile || die
-}
-
-src_compile() {
-       emake \
-               CC="$(tc-getCC)" \
-               CXX="$(tc-getCXX)" \
-               CFLAGS="${CFLAGS} -fPIC" \
-               CXXFLAGS="${CXXFLAGS} -fPIC" \
-               AR="$(tc-getAR) rcv" \
-               RANLIB="$(tc-getRANLIB)" \
-               LIBS="$($(tc-getPKG_CONFIG) --libs blas)" \
-               lib all
-}
-
-src_install() {
-       dolib ${PN}.so.3
-       dosym ${PN}.so.3 /usr/$(get_libdir)/${PN}.so
-
-       newbin predict ${PN}-predict
-       newbin train ${PN}-train
-
-       doheader linear.h
-
-       dodoc README
-}