www-client/firefox: allow CLANG/LLVM slot 10
authorThomas Deutschmann <whissi@gentoo.org>
Tue, 10 Mar 2020 16:44:37 +0000 (17:44 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Tue, 10 Mar 2020 16:45:27 +0000 (17:45 +0100)
Package-Manager: Portage-2.3.91, Repoman-2.3.20
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
www-client/firefox/firefox-68.6.0.ebuild
www-client/firefox/firefox-74.0.ebuild

index 55cb0402f54e58f8226d1cebfb990d6e40d5278d..3b50e7317723514d38b9af58f4d510ebb6a4fdba 100644 (file)
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
        MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
 fi
 
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
 
 inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
                gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -130,6 +130,15 @@ DEPEND="${CDEPEND}
        >=sys-devel/binutils-2.30
        sys-apps/findutils
        || (
+               (
+                       sys-devel/clang:10
+                       !clang? ( sys-devel/llvm:10 )
+                       clang? (
+                               =sys-devel/lld-10*
+                               sys-devel/llvm:10[gold]
+                               pgo? ( =sys-libs/compiler-rt-sanitizers-10*[profile] )
+                       )
+               )
                (
                        sys-devel/clang:9
                        !clang? ( sys-devel/llvm:9 )
@@ -157,15 +166,6 @@ DEPEND="${CDEPEND}
                                pgo? ( =sys-libs/compiler-rt-sanitizers-7*[profile] )
                        )
                )
-               (
-                       sys-devel/clang:6
-                       !clang? ( sys-devel/llvm:6 )
-                       clang? (
-                               =sys-devel/lld-6*
-                               sys-devel/llvm:6[gold]
-                               pgo? ( =sys-libs/compiler-rt-sanitizers-6*[profile] )
-                       )
-               )
        )
        pulseaudio? ( media-sound/pulseaudio )
        >=virtual/rust-1.34.0
index 3f9a0983c941637eba3794e15e0679de61cc060f..30bb87c2dd0b04dc67e3d471130685ecbfb35536 100644 (file)
@@ -38,7 +38,7 @@ if [[ "${PV}" == *_rc* ]]; then
        MOZ_SRC_URI="${MOZ_HTTP_URI}/source/${PN}-${MOZ_PV}.source.tar.xz -> $P.tar.xz"
 fi
 
-LLVM_MAX_SLOT=9
+LLVM_MAX_SLOT=10
 
 inherit check-reqs eapi7-ver flag-o-matic toolchain-funcs eutils \
                gnome2-utils llvm mozcoreconf-v6 pax-utils xdg-utils \
@@ -131,6 +131,15 @@ DEPEND="${CDEPEND}
        >=sys-devel/binutils-2.30
        sys-apps/findutils
        || (
+               (
+                       sys-devel/clang:10
+                       !clang? ( sys-devel/llvm:10 )
+                       clang? (
+                               =sys-devel/lld-10*
+                               sys-devel/llvm:10[gold]
+                               pgo? ( =sys-libs/compiler-rt-sanitizers-10*[profile] )
+                       )
+               )
                (
                        sys-devel/clang:9
                        !clang? ( sys-devel/llvm:9 )