media-libs/libglvnd: Version bump to 1.3.0
authorMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 21:48:42 +0000 (16:48 -0500)
committerMatt Turner <mattst88@gentoo.org>
Thu, 5 Dec 2019 22:29:33 +0000 (17:29 -0500)
Closes: https://bugs.gentoo.org/698932
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/libglvnd/Manifest
media-libs/libglvnd/libglvnd-1.3.0.ebuild [new file with mode: 0644]

index 111dfb6a2d9bd48e2827dfa61f4cf596399afafe..c3ac0c352b135946bcddd34638ef443404cba0c2 100644 (file)
@@ -1 +1,2 @@
 DIST libglvnd-1.2.0.tar.gz 2030275 BLAKE2B b6b147f431ba9a177be9eada7af0e4ffc05c412e29f3a257746d74ff99078ecf87f7e66a97f7c1ce2779b3224bf3e7d1c4ab57c437074ae754e646c9275dae7f SHA512 f09a3ab3f1ba7397616cf2b0baf4385bd2127abb06817f8b383549cb21f36802be24a29598d7bfdd4c410b9ea95335b4ffc52529824dc88a719af52432c6b74c
+DIST libglvnd-1.3.0.tar.bz2 713781 BLAKE2B 15014038e8a0f14fc29892354b282535735af0f29e244e4826b945071deec151783fc042f3588add24c31f35a5c72c53bfb1090c109117466f8b8c805cc67356 SHA512 d573fc4a1114be9468afd6e035b3815111f9a7e7453bc2b127c93a1b8a01c7f20440ff8872fbae8fc93aab98862dac3224ceca7f28d02e93f3b9a641d1a248e3
diff --git a/media-libs/libglvnd/libglvnd-1.3.0.ebuild b/media-libs/libglvnd/libglvnd-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..1905bb3
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/glvnd/libglvnd.git"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+VIRTUALX_REQUIRED=manual
+
+inherit ${GIT_ECLASS} meson multilib-minimal python-any-r1 virtualx
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://gitlab.freedesktop.org/glvnd/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+       SRC_URI="https://gitlab.freedesktop.org/glvnd/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+       S=${WORKDIR}/${PN}-v${PV}
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test X"
+
+BDEPEND="${PYTHON_DEPS}
+       test? ( X? ( ${VIRTUALX_DEPEND} ) )"
+RDEPEND="
+       !media-libs/mesa[-libglvnd(-)]
+       !<media-libs/mesa-19.2.2
+       X? (
+               x11-libs/libX11[${MULTILIB_USEDEP}]
+               x11-libs/libXext[${MULTILIB_USEDEP}]
+       )"
+DEPEND="${RDEPEND}
+       X? ( x11-base/xorg-proto )"
+
+multilib_src_configure() {
+       local emesonargs=(
+               $(meson_feature X x11)
+               $(meson_feature X glx)
+       )
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       if use X; then
+               virtx meson_src_test
+       else
+               meson_src_test
+       fi
+}
+
+multilib_src_install() {
+       meson_src_install
+}