www-servers/automx2: Added DOCS and HTML_DOCS
authorRalph Seichter <github@seichter.de>
Tue, 24 Dec 2019 23:57:31 +0000 (00:57 +0100)
committerAaron Bauman <bman@gentoo.org>
Fri, 27 Dec 2019 17:33:33 +0000 (12:33 -0500)
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Ralph Seichter <gentoo@seichter.de>
Closes: https://github.com/gentoo/gentoo/pull/14118
Signed-off-by: Aaron Bauman <bman@gentoo.org>
www-servers/automx2/automx2-2019.0.ebuild

index 1ae32210a3a257dddd717299a628225b5e41052d..bc55e2b7b7ec6fb97863ecce27dc01e01cd5091d 100644 (file)
@@ -14,6 +14,7 @@ SRC_URI="https://gitlab.com/automx/automx2/-/archive/${PV}/${P}.tar.bz2"
 LICENSE="GPL-3+"
 SLOT="0"
 KEYWORDS="~amd64"
+IUSE="doc"
 
 BDEPEND="acct-user/automx2
        $(python_gen_cond_dep \
@@ -32,6 +33,10 @@ python_test() {
 }
 
 python_install_all() {
+       if use doc; then
+               DOCS="*.adoc doc/*.adoc contrib/*sample.conf"
+               HTML_DOCS="doc/*.html doc/*.svg"
+       fi
        sed -e "s/@EPYTHON@/${EPYTHON}/" "${FILESDIR}/init" | newinitd - "${PN}"
        newconfd "${FILESDIR}/confd" "${PN}"
        insinto /etc