games-puzzle/swell-foop: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 13:06:51 +0000 (15:06 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 5 Sep 2015 13:06:51 +0000 (15:06 +0200)
Package-Manager: portage-2.2.20.1

games-puzzle/swell-foop/Manifest
games-puzzle/swell-foop/swell-foop-3.16.2.ebuild [new file with mode: 0644]

index 80a317f56435cab9161998986deca3540fce6796..474c8cf127015fbf28ada9c01afa650f1a901020 100644 (file)
@@ -1,2 +1,3 @@
 DIST swell-foop-3.14.0.tar.xz 2336392 SHA256 c52e5c03da5136e47eb04ed58982e93659c7c88411c282b143fc347350ec6dca SHA512 80b9546dfe10d637ca087f912c86c82100099505f7b216c710208bdd91d4a41744147548bb92f90cade103e182cb0da86ef9edd0eef624184024550ac5024d53 WHIRLPOOL fb082bb6233d22812244bd8099fb5c7f66d91b03e11a22e3ca39debac71f9001cdab371a2294cdda9a8c8a048f7c4ec219688279981c1d8e3666a50294e1ae4d
 DIST swell-foop-3.16.1.tar.xz 2372956 SHA256 8e7f09f8c28e3232a5b6726568d1a463c1a2af89cf030d7542ab612d99ac122e SHA512 3e2e024ca302273ba8d6aac7aa1bef0679388b3c67712ed34f0b120ad8bee7670c164098ec2f2ee88a248abfb95957a4a04bb9731be0fcb628da65ebf71a3b59 WHIRLPOOL 3dc1c1c334377881729f0532bf452f0ce538c279230ba2699a42ab6d0a20b80a914766b66fd2644f7439cab3dddac953eefdcd65fe3b935fd994479c3ba412c2
+DIST swell-foop-3.16.2.tar.xz 2394508 SHA256 0f37a55c29e15678ba0fb04bebca9ddf02ad85fdf8e87a169ba2eb5d073bb790 SHA512 62036032ab938088656d14f40a8e80e3881e17ea25c93ee2dd5cb744865b7cc7e88f191226a71dd4f65b2971d25b125b948cb1b4128cce15c66ec47f764aad3d WHIRLPOOL af961982db3396b91b564bd40385c3ff6b667c3b2072c74106dd94710bce3d3ec04cee1599de3c1824a4cd6dfe454a611c8a082620e209ec8b225cb945d154c6
diff --git a/games-puzzle/swell-foop/swell-foop-3.16.2.ebuild b/games-puzzle/swell-foop/swell-foop-3.16.2.ebuild
new file mode 100644 (file)
index 0000000..ed3670d
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome-games vala
+
+DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
+HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/glib-2.36:2
+       >=media-libs/clutter-1.14:1.0
+       >=media-libs/clutter-gtk-1.5:1.0
+       >=x11-libs/gtk+-3.12:3
+"
+DEPEND="${RDEPEND}
+       $(vala_depend)
+       app-text/yelp-tools
+       dev-libs/appstream-glib
+       >=dev-util/intltool-0.50
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+
+src_prepare() {
+       gnome-games_src_prepare
+       vala_src_prepare
+}