dev-python/dbus-python: Replace obsolete prune_libtool_files
authorMichał Górny <mgorny@gentoo.org>
Tue, 24 Jul 2018 10:39:18 +0000 (12:39 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 24 Jul 2018 12:19:52 +0000 (14:19 +0200)
dev-python/dbus-python/dbus-python-1.2.6-r2.ebuild

index 099c2e54856af69f07dbfdbebff9802d268f163c..7e79f79b6ff9c6942797a4b669edfb7d84d1e8a5 100644 (file)
@@ -6,7 +6,7 @@ EAPI=6
 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 PYTHON_REQ_USE="threads(+)"
 
-inherit autotools eutils python-r1
+inherit autotools python-r1
 
 DESCRIPTION="Python bindings for the D-Bus messagebus"
 HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings https://dbus.freedesktop.org/doc/dbus-python/"
@@ -77,7 +77,7 @@ src_install() {
                [[ ${EPYTHON/.*} = "python2" ]] && use doc && dohtml -r api/*
        }
        python_foreach_impl run_in_build_dir installing
-       prune_libtool_files --modules
+       find "${D}" -name "*.la" -delete || die
 
        if use examples; then
                insinto /usr/share/doc/${PF}