sys-apps/cpuid: bump to version 20200203
authorConrad Kostecki <conikost@gentoo.org>
Tue, 4 Feb 2020 17:15:15 +0000 (18:15 +0100)
committerConrad Kostecki <conikost@gentoo.org>
Tue, 4 Feb 2020 17:48:27 +0000 (18:48 +0100)
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-apps/cpuid/Manifest
sys-apps/cpuid/cpuid-20200203.ebuild [new file with mode: 0644]
sys-apps/cpuid/files/cpuid-20200203-makefile.patch [new file with mode: 0644]

index 7e34bf03aaf7be6af4a2dce3ff9f9233dc2167bc..4c592e48ed0e1b887c9f9b235c707c123c9349e0 100644 (file)
@@ -1 +1,2 @@
 DIST cpuid-20180519.src.tar.gz 84784 BLAKE2B 87098145a378081d296f0473f9106e7c5b6654c2bd63d385dc27e293079adf3a527801fa644000ede53228e087e9e9afdf807a3c8d9cc8eb93826f01a5a89e9a SHA512 565738c41777669e750a2ef2e122ed0568de5ac8cc2584fa5047ba66d42eb5c3324b283bda25605e055d85402a4e2d109bc6d033ccd34243caab728465792669
+DIST cpuid-20200203.src.tar.gz 113144 BLAKE2B fea8a51559e77bac779cda096e694992090d5b6e4f6efbee3b67f66727267028da062c317ca045155b668292c5f3f6c2d027a59f74d27f138c8ebb529f8df820 SHA512 ae80275fba522688161d08b58d4df6437bad66853a7fce9591b5ca10ecd649ce712616f46d6c9f47a36ff3a1f09c65a10dc70fb409bc58c5e30ae413cfd92aa0
diff --git a/sys-apps/cpuid/cpuid-20200203.ebuild b/sys-apps/cpuid/cpuid-20200203.ebuild
new file mode 100644 (file)
index 0000000..60a214f
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Linux tool to dump x86 CPUID information about the CPUs"
+HOMEPAGE="http://www.etallen.com/cpuid.html"
+SRC_URI="http://www.etallen.com/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-lang/perl"
+DEPEND="app-arch/gzip"
+
+DOCS=( "ChangeLog" "FUTURE" )
+
+PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
+
+src_prepare() {
+       default
+
+       tc-export CC
+}
+
+src_install() {
+       emake BUILDROOT="${ED}" install
+
+       einstalldocs
+}
diff --git a/sys-apps/cpuid/files/cpuid-20200203-makefile.patch b/sys-apps/cpuid/files/cpuid-20200203-makefile.patch
new file mode 100644 (file)
index 0000000..9cfad5e
--- /dev/null
@@ -0,0 +1,37 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,11 @@
+-CFLAGS+=-g
++CFLAGS+=
+ CPPFLAGS?=
+ LDFLAGS?=
+ ifneq (,$(findstring arch=i386,$(CFLAGS)))
+ CISA=-m32
+ endif
+ CFL=$(CPPFLAGS) $(CFLAGS) $(CISA) -Wall -W -Wshadow -Wcast-align -Wredundant-decls -Wbad-function-cast -Wcast-qual -Wwrite-strings -Waggregate-return -Wstrict-prototypes -Wmissing-prototypes -Wimplicit-fallthrough -Wunused-parameter -D_FILE_OFFSET_BITS=64 -DVERSION=$(VERSION)
+-INSTALL_STRIP=-s
++INSTALL_STRIP=
+ PACKAGE=cpuid
+ VERSION=20200203
+@@ -40,7 +40,7 @@
+ BUILDROOT=
+-default: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
++default: $(PROG) cpuinfo2cpuid
+ $(PROG): cpuid.c Makefile
+       $(CC) $(CFL) $(LDFLAGS) -o $@ cpuid.c
+@@ -56,9 +56,9 @@
+ install: $(PROG) $(PROG).man.gz cpuinfo2cpuid cpuinfo2cpuid.man.gz
+       install -D $(INSTALL_STRIP) -m 755 $(PROG) $(BUILDROOT)/usr/bin/$(PROG)
+-      install -D -m 444 $(PROG).man.gz       $(BUILDROOT)/usr/share/man/man1/$(PROG).1.gz
++      install -D -m 444 $(PROG).man       $(BUILDROOT)/usr/share/man/man1/$(PROG).1
+       install -D -m 755 cpuinfo2cpuid        $(BUILDROOT)/usr/bin/cpuinfo2cpuid
+-      install -D -m 444 cpuinfo2cpuid.man.gz $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1.gz
++      install -D -m 444 cpuinfo2cpuid.man $(BUILDROOT)/usr/share/man/man1/cpuinfo2cpuid.1
+ clean:
+       rm -f $(PROG) $(PROG).i386 $(PROG).x86_64