www-misc/awstats: Security bump to 7.8 release (CVE-2017-1000501).
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Tue, 12 May 2020 11:06:09 +0000 (11:06 +0000)
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Tue, 12 May 2020 11:06:09 +0000 (11:06 +0000)
Bug: https://bugs.gentoo.org/646786
Fixes: https://bugs.gentoo.org/604548
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
www-misc/awstats/Manifest
www-misc/awstats/awstats-7.8.ebuild [new file with mode: 0644]

index 07a746074283672decb35371f671aedbfc56b2f5..9cf3401d74507f53cfd867643bc36d487077dbc3 100644 (file)
@@ -1,3 +1,4 @@
 DIST awstats-7.1_p20121017.tar.gz 1258135 BLAKE2B 0a43154d044346acdf4e71e96b05f9b8914d0df8a3812c6a20edb33a0b9d8b6f0aadc065466f1ee23c0469e41eda9622c380bd35c579b887a6547fd6749e9bd4 SHA512 171ff3118955c8b73c968a23983885d967632d2c6e95a45f71e5f6fea74afe34d869c9cc901e2e739419068babc96385d7d7df1e8ca10074be7388fbe5c51f53
 DIST awstats-7.4.tar.gz 2936102 BLAKE2B 2bc7f9619e4d6b13d3909869d642c347d6b9cddbbb3b49d58494ce108c8fe25d59b27198d5a42f8b81c06fdaf1a2e135c82883ec8604e53c6c5adbac07223b66 SHA512 5bce97c71aabeab35e4ff5e5168531e4955d7c1474322c7b4a47d1d06e06ebd0e74d1def73826498e6253f24aeca99309777617b7a914685c927bb6e1c020e1a
 DIST awstats-7.5.tar.gz 2936644 BLAKE2B 666e4d50e8011315351e1aff538ec56507c5bc8e4fb4890c29aee1f73985b8466f346982a6022ae1689e30d587b21ee0f2038f46783e4f25454dfa6e5fe39771 SHA512 d69a66b5ef94d8a7378ece0453a3617f71ad030d81c45cff926fae1319eacdcdcbe2e68513153cd7444d77cbb950827964b0157ce74c04be76781c071f016a35
+DIST awstats-7.8.tar.gz 2938739 BLAKE2B 57c692aa935a4191d1cc1f3b34dd1a70a40eef880a3672dcd17472fe6bf447dd7b85a7752d94666d6f1a8dbdcc2eac4959a7f6a83a8bd538d0909ffcaedfd385 SHA512 2fd78e8c7eefb5c9ed39d8ee830ee8ad00b622b812ae40a84cb01c4fa653b9ab7822d1592313d7a8c4b8503d04dcba48b1775d33a629f1ac1278d2300eef931d
diff --git a/www-misc/awstats/awstats-7.8.ebuild b/www-misc/awstats/awstats-7.8.ebuild
new file mode 100644 (file)
index 0000000..e3d4103
--- /dev/null
@@ -0,0 +1,111 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils
+
+MY_P=${PN}-${PV%_p*}
+
+DESCRIPTION="AWStats is short for Advanced Web Statistics"
+HOMEPAGE="https://www.awstats.org/"
+SRC_URI="https://www.awstats.org/files/${P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="geoip ipv6"
+
+SLOT="0"
+
+RDEPEND="
+       >=dev-lang/perl-5.6.1
+       dev-perl/URI
+       virtual/perl-Time-Local
+       geoip? (
+               dev-perl/Geo-IP
+       )
+       ipv6? (
+               dev-perl/Net-DNS
+               dev-perl/Net-IP
+       )
+"
+DEPEND=""
+
+src_prepare() {
+       eapply "${FILESDIR}"/${PN}-7.1-gentoo.diff
+
+       # change default installation directory
+       find . -type f -exec sed \
+               -e "s#/usr/local/awstats/wwwroot#/usr/share/awstats/wwwroot#g" \
+               -e '/PossibleLibDir/s:(.*):("/usr/share/awstats/wwwroot/cgi-bin/lib"):' \
+               -i {} + || die "find/sed failed"
+
+       # set default values for directories; use apache log as an example
+       sed \
+               -e "s|^\(LogFile=\).*$|\1\"/var/log/apache2/access_log\"|" \
+               -e "s|^\(SiteDomain=\).*$|\1\"localhost\"|" \
+               -e "s|^\(DirIcons=\).*$|\1\"/awstats/icon\"|" \
+               -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+
+       # enable plugins
+
+       if use ipv6; then
+               sed -e "s|^#\(LoadPlugin=\"ipv6\"\)$|\1|" \
+               -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+       fi
+
+       if use geoip; then
+               sed -e '/LoadPlugin="geoip /aLoadPlugin="geoip GEOIP_STANDARD /usr/share/GeoIP/GeoIP.dat"' \
+               -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+       fi
+
+       find "${S}" '(' -type f -not -name '*.pl' ')' -exec chmod -x {} + || die
+
+       eapply_user
+}
+
+HTML_DOCS="docs/"
+DOCS="README.md"
+
+src_install() {
+       einstalldocs
+
+       newdoc wwwroot/cgi-bin/plugins/example/example.pm example_plugin.pm
+       dodoc -r tools/xslt
+
+       keepdir /var/lib/awstats
+
+       insinto /etc/awstats
+       doins "${S}"/wwwroot/cgi-bin/awstats.model.conf
+
+       # remove extra content that we don't want to install
+       rm -r "${S}"/wwwroot/cgi-bin/awstats.model.conf \
+               "${S}"/wwwroot/classes/src || die
+
+       insinto /usr/share/awstats
+       doins -r wwwroot
+       chmod +x "${D}"/usr/share/awstats/wwwroot/cgi-bin/*.pl
+
+       cd "${S}"/tools
+       dobin awstats_buildstaticpages.pl awstats_exportlib.pl \
+               awstats_updateall.pl
+       newbin logresolvemerge.pl awstats_logresolvemerge.pl
+       newbin maillogconvert.pl awstats_maillogconvert.pl
+       newbin urlaliasbuilder.pl awstats_urlaliasbuilder.pl
+
+       dosym ../share/awstats/wwwroot/cgi-bin/awstats.pl /usr/bin/awstats.pl
+}
+
+pkg_postinst() {
+       elog "The AWStats-Manual is available either inside"
+       elog "the /usr/share/doc/${PF} - folder, or at"
+       elog "https://awstats.sourceforge.net/docs/index.html ."
+       elog
+       elog "Copy the /etc/awstats/awstats.model.conf to"
+       elog "/etc/awstats/awstats.<yourdomain>.conf and edit it."
+       elog ""
+       ewarn "This ebuild does no longer use webapp-config to install"
+       ewarn "instead you should point your configuration to the stable"
+       ewarn "directory tree in the following path:"
+       ewarn "    /usr/share/awstats"
+}