app-emulation/libvirt: update live ebuild, bug #602762
authorMatthias Maier <tamiko@gentoo.org>
Sun, 22 Jan 2017 15:17:42 +0000 (09:17 -0600)
committerMatthias Maier <tamiko@gentoo.org>
Sun, 22 Jan 2017 15:34:25 +0000 (09:34 -0600)
Package-Manager: Portage-2.3.0, Repoman-2.3.1

app-emulation/libvirt/files/libvirt-3.0.0-fix_paths_for_apparmor.patch [new file with mode: 0644]
app-emulation/libvirt/libvirt-2.5.0-r1.ebuild
app-emulation/libvirt/libvirt-9999.ebuild

diff --git a/app-emulation/libvirt/files/libvirt-3.0.0-fix_paths_for_apparmor.patch b/app-emulation/libvirt/files/libvirt-3.0.0-fix_paths_for_apparmor.patch
new file mode 100644 (file)
index 0000000..c9c7eb6
--- /dev/null
@@ -0,0 +1,79 @@
+From baad1483ed0a699509f66abac6708797f370f888 Mon Sep 17 00:00:00 2001
+From: Matthias Maier <tamiko@kyomu.43-1.org>
+Date: Sun, 22 Jan 2017 09:07:57 -0600
+Subject: [PATCH] Update paths to Gentoo layout
+
+---
+ examples/Makefile.am                                                | 4 ++--
+ .../{usr.lib.libvirt.virt-aa-helper => usr.libexec.virt-aa-helper}  | 4 ++--
+ examples/apparmor/usr.sbin.libvirtd                                 | 6 ++++--
+ 3 files changed, 8 insertions(+), 6 deletions(-)
+ rename examples/apparmor/{usr.lib.libvirt.virt-aa-helper => usr.libexec.virt-aa-helper} (90%)
+
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index 2956e14..d81e34b 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -23,7 +23,7 @@ EXTRA_DIST = \
+       apparmor/TEMPLATE.lxc \
+       apparmor/libvirt-qemu \
+       apparmor/libvirt-lxc \
+-      apparmor/usr.lib.libvirt.virt-aa-helper \
++      apparmor/usr.libexec.virt-aa-helper \
+       apparmor/usr.sbin.libvirtd \
+       lxcconvert/virt-lxc-convert \
+       polkit/libvirt-acl.rules \
+@@ -70,7 +70,7 @@ admin_logging_SOURCES = admin/logging.c
+ if WITH_APPARMOR_PROFILES
+ apparmordir = $(sysconfdir)/apparmor.d/
+ apparmor_DATA = \
+-      apparmor/usr.lib.libvirt.virt-aa-helper \
++      apparmor/usr.libexec.virt-aa-helper \
+       apparmor/usr.sbin.libvirtd \
+       $(NULL)
+diff --git a/examples/apparmor/usr.lib.libvirt.virt-aa-helper b/examples/apparmor/usr.libexec.virt-aa-helper
+similarity index 90%
+rename from examples/apparmor/usr.lib.libvirt.virt-aa-helper
+rename to examples/apparmor/usr.libexec.virt-aa-helper
+index 4a8f197..a6072f1 100644
+--- a/examples/apparmor/usr.lib.libvirt.virt-aa-helper
++++ b/examples/apparmor/usr.libexec.virt-aa-helper
+@@ -1,7 +1,7 @@
+ # Last Modified: Mon Apr  5 15:10:27 2010
+ #include <tunables/global>
+-profile virt-aa-helper /usr/{lib,lib64}/libvirt/virt-aa-helper {
++profile virt-aa-helper /usr/libexec/virt-aa-helper {
+   #include <abstractions/base>
+   # needed for searching directories
+@@ -20,7 +20,7 @@ profile virt-aa-helper /usr/{lib,lib64}/libvirt/virt-aa-helper {
+   /sys/devices/ r,
+   /sys/devices/** r,
+-  /usr/{lib,lib64}/libvirt/virt-aa-helper mr,
++  /usr/libexec/virt-aa-helper mr,
+   /{usr/,}sbin/apparmor_parser Ux,
+   /etc/apparmor.d/libvirt/* r,
+diff --git a/examples/apparmor/usr.sbin.libvirtd b/examples/apparmor/usr.sbin.libvirtd
+index 8893e75..f0b471c 100644
+--- a/examples/apparmor/usr.sbin.libvirtd
++++ b/examples/apparmor/usr.sbin.libvirtd
+@@ -59,8 +59,10 @@
+   audit deny /sys/kernel/security/apparmor/.* rwxl,
+   /sys/kernel/security/apparmor/profiles r,
+   /usr/{lib,lib64}/libvirt/* PUxr,
+-  /usr/{lib,lib64}/libvirt/libvirt_parthelper ix,
+-  /usr/{lib,lib64}/libvirt/libvirt_iohelper ix,
++  /usr/libexec/virt-aa-helper PUxr,
++  /usr/libexec/libvirt_lxc PUxr,
++  /usr/libexec/libvirt_parthelper ix,
++  /usr/libexec/libvirt_iohelper ix,
+   /etc/libvirt/hooks/** rmix,
+   /etc/xen/scripts/** rmix,
+-- 
+2.10.2
+
index 1cb69c8471353d0355391d141fe973ab0d09b552..d4fb5455a377f4484f16963114a86350fad18024 100644 (file)
@@ -216,6 +216,8 @@ pkg_setup() {
 src_prepare() {
        touch "${S}/.mailmap"
 
+       default
+
        if [[ ${PV} = *9999* ]]; then
                # git checkouts require bootstrapping to create the configure script.
                # Additionally the submodules must be cloned to the right locations
@@ -227,8 +229,6 @@ src_prepare() {
                ) >.git-module-status
        fi
 
-       default
-
        # Tweak the init script:
        cp "${FILESDIR}/libvirtd.init-r16" "${S}/libvirtd.init" || die
        sed -e "s/USE_FLAG_FIREWALLD/$(usex firewalld 'need firewalld' '')/" \
index 1cb69c8471353d0355391d141fe973ab0d09b552..63d636d875373e8dd785f13d2742acd6698f183a 100644 (file)
@@ -123,7 +123,7 @@ DEPEND="${RDEPEND}
 PATCHES=(
        "${FILESDIR}"/${PN}-1.3.0-do_not_use_sysconf.patch
        "${FILESDIR}"/${PN}-1.2.16-fix_paths_in_libvirt-guests_sh.patch
-       "${FILESDIR}"/${PN}-1.3.1-fix_paths_for_apparmor.patch
+       "${FILESDIR}"/${PN}-3.0.0-fix_paths_for_apparmor.patch
        "${FILESDIR}"/${PN}-1.3.4-glibc-2.23.patch
 )
 
@@ -216,6 +216,8 @@ pkg_setup() {
 src_prepare() {
        touch "${S}/.mailmap"
 
+       default
+
        if [[ ${PV} = *9999* ]]; then
                # git checkouts require bootstrapping to create the configure script.
                # Additionally the submodules must be cloned to the right locations
@@ -227,8 +229,6 @@ src_prepare() {
                ) >.git-module-status
        fi
 
-       default
-
        # Tweak the init script:
        cp "${FILESDIR}/libvirtd.init-r16" "${S}/libvirtd.init" || die
        sed -e "s/USE_FLAG_FIREWALLD/$(usex firewalld 'need firewalld' '')/" \