dev-ml/textutils: bump to 113.24.00
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 19:33:39 +0000 (20:33 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/textutils/Manifest
dev-ml/textutils/textutils-113.24.00.ebuild [new file with mode: 0644]

index 20990baafde0b1643b14039770cfeaf2d0b4c576..c1e596e577fc16b839ea59c77fa0cc129d84348a 100644 (file)
@@ -1 +1,2 @@
 DIST textutils-112.17.00.tar.gz 60953 SHA256 605d9fde66dc2d777721c936aa521e17169c143efaf9ff29619a7f273a7d0052 SHA512 bc1143b3406538bb023ba82d80d8f2609312000b610809e9b37d032cf50689c38b385ce0fb6721ca6eb0d2c47d4f1db65a9569bda9b05c934c7cf61b2530539e WHIRLPOOL 96c352f8236354792da9dfb00adea51816ab62501558ece74d61d489b923e52ffb92780737ae0f5c21d3a67a12e790fdee22155713044de94148989c640ab4e0
+DIST textutils-113.24.00.tar.gz 63937 SHA256 21d5cb65e22bef24647894ce38da4dd2a9f0a3aa1ed16dedafbc28f19e3c8d90 SHA512 96fc0e3cf29780fbab9a12877bdf20b5a8a93bb25ce5b457682b8ab2b38f91da563c307ed6a87dd912735728942086581af7a835ac390ccd370f4105db1e158c WHIRLPOOL edadf77c3db73ce87414c0b57870a44752e859d7c0a0d294c69489246cecf8ff663ef9f9d26b1e4fa00a9477fe545db7fde73e703408669b109a4d380e604c14
diff --git a/dev-ml/textutils/textutils-113.24.00.ebuild b/dev-ml/textutils/textutils-113.24.00.ebuild
new file mode 100644 (file)
index 0000000..06165d7
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Text output utilities"
+HOMEPAGE="https://ocaml.janestreet.com/"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+       >=dev-lang/ocaml-4.02[ocamlopt?]
+       >=dev-ml/core-109.24:=
+       dev-ml/fieldslib:=
+       dev-ml/ppx_assert:=
+       dev-ml/ppx_bench:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_expect:=
+       dev-ml/ppx_inline_test:=
+       dev-ml/ppx_jane:=
+       >=dev-ml/sexplib-113.24:=
+       dev-ml/typerep:=
+       dev-ml/variantslib:=
+"
+DEPEND="${RDEPEND} dev-ml/opam"
+
+src_configure() {
+       emake setup.exe
+       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md
+}