dev-embedded/upslug2: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 10:15:21 +0000 (12:15 +0200)
committerDavid Seifert <soap@gentoo.org>
Sat, 19 Oct 2019 10:15:21 +0000 (12:15 +0200)
Closes: https://bugs.gentoo.org/697360
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
dev-embedded/upslug2/upslug2-11.ebuild

index 9aa13e4e8de1648c91c036a5467e777a26057194..e994216ef5875af17509d17fae26a95bc7bce22e 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 DESCRIPTION="util for flashing NSLU2 machines remotely"
 HOMEPAGE="http://www.nslu2-linux.org/wiki/Main/UpSlug2"
@@ -10,11 +10,12 @@ SRC_URI="mirror://sourceforge/nslu/${P}.tar.gz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~arm x86"
-IUSE=""
+
+src_configure() {
+       econf --sbindir "${EPREFIX}"/usr/bin
+}
 
 src_install() {
-       emake install DESTDIR="${D}" || die
-       mv "${D}"/usr/{sbin,bin} || die
+       default
        fperms 4711 /usr/bin/upslug2
-       dodoc AUTHORS ChangeLog NEWS README*
 }