kde-apps/krdc: Adapt the code to >=kde-frameworks/kbookmarks-5.69
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 19:13:18 +0000 (21:13 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 17 Apr 2020 20:53:07 +0000 (22:53 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
kde-apps/krdc/files/krdc-19.12.3-kf5bookmarks-5.69.patch [new file with mode: 0644]
kde-apps/krdc/krdc-19.12.3-r1.ebuild [new file with mode: 0644]

diff --git a/kde-apps/krdc/files/krdc-19.12.3-kf5bookmarks-5.69.patch b/kde-apps/krdc/files/krdc-19.12.3-kf5bookmarks-5.69.patch
new file mode 100644 (file)
index 0000000..03dc005
--- /dev/null
@@ -0,0 +1,48 @@
+From 70e9d2728a4928dd2aeb170935d966e934315cf4 Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Fri, 17 Apr 2020 15:52:15 +0200
+Subject: Adapt to changes in KBookmarks >= 5.69
+
+Test Plan:
+The Bookmarks menu is still added as expected and the actions still show
+in the configure shortcuts dialog. I couldn't test actually creating a
+bookmark as I have no access to remote servers.
+
+Reviewers: cfeck, uwolfer, murrant
+
+Reviewed By: cfeck
+
+Differential Revision: https://phabricator.kde.org/D28920
+---
+ bookmarkmanager.cpp | 7 +++++++
+ 1 file changed, 7 insertions(+)
+
+diff --git a/bookmarkmanager.cpp b/bookmarkmanager.cpp
+index 47ac779..a34cb2c 100644
+--- a/bookmarkmanager.cpp
++++ b/bookmarkmanager.cpp
+@@ -25,6 +25,7 @@
+ #include "mainwindow.h"
+ #include "krdc_debug.h"
++#include <kbookmarks_version.h>
+ #include <KBookmarks/KBookmarkOwner>
+ #include <KLocalizedString>
+@@ -41,7 +42,13 @@ BookmarkManager::BookmarkManager(KActionCollection *collection, QMenu *menu, Mai
+     m_manager = KBookmarkManager::managerForFile(file, QLatin1String("krdc"));
+     m_manager->setUpdate(true);
++
++#if KBOOKMARKS_VERSION < QT_VERSION_CHECK(5, 69, 0)
+     m_bookmarkMenu = new KBookmarkMenu(m_manager, this, menu, collection);
++#else
++    m_bookmarkMenu = new KBookmarkMenu(m_manager, this, menu);
++    collection->addActions(menu->actions());
++#endif
+     KBookmarkGroup root = m_manager->root();
+     KBookmark bm = root.first();
+-- 
+cgit v1.1
+
diff --git a/kde-apps/krdc/krdc-19.12.3-r1.ebuild b/kde-apps/krdc/krdc-19.12.3-r1.ebuild
new file mode 100644 (file)
index 0000000..b195600
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+KFMIN=5.63.0
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Remote desktop connection (RDP and VNC) client"
+HOMEPAGE="https://kde.org/applications/internet/org.kde.krdc"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+rdp vnc"
+
+# drop kbookmarks subslot operator when KFMIN >= 5.69.0
+#nx? ( >=net-misc/nxcl-0.9-r1 ) disabled upstream, last checked 2016-01-24
+DEPEND="
+       >=kde-frameworks/kbookmarks-${KFMIN}:5=
+       >=kde-frameworks/kcmutils-${KFMIN}:5
+       >=kde-frameworks/kcompletion-${KFMIN}:5
+       >=kde-frameworks/kconfig-${KFMIN}:5
+       >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+       >=kde-frameworks/kcoreaddons-${KFMIN}:5
+       >=kde-frameworks/kdnssd-${KFMIN}:5
+       >=kde-frameworks/ki18n-${KFMIN}:5
+       >=kde-frameworks/kiconthemes-${KFMIN}:5
+       >=kde-frameworks/knotifications-${KFMIN}:5
+       >=kde-frameworks/knotifyconfig-${KFMIN}:5
+       >=kde-frameworks/kservice-${KFMIN}:5
+       >=kde-frameworks/kwallet-${KFMIN}:5
+       >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+       >=kde-frameworks/kwindowsystem-${KFMIN}:5
+       >=kde-frameworks/kxmlgui-${KFMIN}:5
+       >=dev-qt/qtgui-${QTMIN}:5
+       >=dev-qt/qtwidgets-${QTMIN}:5
+       >=dev-qt/qtxml-${QTMIN}:5
+       vnc? ( >=net-libs/libvncserver-0.9 )
+"
+RDEPEND="${DEPEND}
+       rdp? ( >=net-misc/freerdp-1.1.0_beta1[X] )
+"
+
+PATCHES=( "${FILESDIR}/${P}-kf5bookmarks-5.69.patch" )
+
+src_configure() {
+       local mycmakeargs=(
+               $(cmake_use_find_package vnc LibVNCServer)
+       )
+
+       ecm_src_configure
+}