dev-python/astroid-2.3.3-r2: revbump, don't lock wrapt dep
authorPatrick McLean <chutzpah@gentoo.org>
Wed, 11 Mar 2020 02:13:44 +0000 (19:13 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 11 Mar 2020 02:14:41 +0000 (19:14 -0700)
Package-Manager: Portage-2.3.93, Repoman-2.3.20
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/astroid/astroid-2.3.3-r2.ebuild [new file with mode: 0644]

diff --git a/dev-python/astroid/astroid-2.3.3-r2.ebuild b/dev-python/astroid/astroid-2.3.3-r2.ebuild
new file mode 100644 (file)
index 0000000..528031d
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Abstract Syntax Tree for logilab packages"
+HOMEPAGE="https://github.com/PyCQA/astroid https://pypi.org/project/astroid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Version specified in __pkginfo__.py.
+RDEPEND="
+       dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       >=dev-python/wrapt-1.11.2[${PYTHON_USEDEP}]
+       >=dev-python/typed-ast-1.3.0[${PYTHON_USEDEP}]"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               ${RDEPEND}
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/python-dateutil[${PYTHON_USEDEP}]
+       )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-2.3.3-no-pytest-runner.patch"
+)
+
+python_prepare_all() {
+       # Disable failing tests
+
+       # no idea why this test fails
+       sed -i -e "s/test_knownValues_get_builtin_module_part/_&/" \
+               astroid/tests/unittest_modutils.py || die
+
+       sed -r -e 's:"wrapt(~|=)=.+":"wrapt":' \
+               -i astroid/__pkginfo__.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       "${EPYTHON}" -m pytest -v --pyargs astroid/tests \
+               || die "tests failed with ${EPYTHON}"
+}