dev-games/ogre: drop obsolete 1.10.11
authorSven Eden <yamakuzure@gmx.net>
Mon, 6 Aug 2018 06:13:01 +0000 (08:13 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 7 Sep 2018 11:22:50 +0000 (13:22 +0200)
dev-games/ogre/Manifest
dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch [deleted file]
dev-games/ogre/ogre-1.10.11.ebuild [deleted file]

index fa7ffd7cf965c9599e28cc103e90605de99a7243..93a14df137ac61f5d1331b7f4a2ef9bfe01a79cd 100644 (file)
@@ -1,3 +1,2 @@
-DIST ogre-1.10.11.zip 133064317 BLAKE2B 88c64061377d8257853378219fb5906919d251f5b3c500f70bc1c04bc36e3083dc3dac4babb14d983c8b6fbb63ea3eecf698e3a0134f963db058055edd5dc4c4 SHA512 db207aec8330ec9da2a9781c8753411e69e08008995b8b3e127d454dc05aa899c75157718398ca24998644c586e2dd30cc7e9b7d98e045e4575537f5c81a5a54
 DIST ogre-1.10.12.zip 133067192 BLAKE2B 188437153969504b169970d14c39d47c9e666308bf65412018f42ba8ad108876f164733fe2004ea31941ab5db534766c10b871b34ef525522d1120b175530b87 SHA512 63998ea4940d04adfc179a94aa91bb2598692307b429f4c7e5b86a1519c13817035de4c71afc9e4b33fde35e962504373d152de9b9cc8eebbbeb78b2c1942041
 DIST ogre-1.9.0.tar.bz2 128098305 BLAKE2B 6e67a5b60a6606a910e099f1c7ba736eb525f079f3aba5cfb362329b9130059d303fc9df6f7b8611c0ba75e1e207fa018e543e93c9f5ce39a6621e4c72ed4a83 SHA512 b1ea93d80ac0978a7c228460a6714f8d17797450efd5af6765c9fa4402e9060a8ef3a700d2757593a3016fdc32276722c8f4a5d9889a3e2eb424f16162a52bde
diff --git a/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch b/dev-games/ogre/files/ogre-1.10.11-fix_double_precision-88f0d5b.patch
deleted file mode 100644 (file)
index 53d7a09..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# HG changeset patch
-# User niparx <koliap@gmail.com>
-# Date 1515160111 -7200
-# Node ID 88f0d5be23c521e7504e3f6cb2a153428efcf159
-# Parent  bc4fb04c1de686c23c6207eee69ae0ca9fddcb7c
-[OGRE-592] RTShaderSystem compile error when using double precision (#622)
-
-RTShaderSystem: compile error when using double precision
-
-https://ogre3d.atlassian.net/browse/OGRE-592
-
-diff --git a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
---- a/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
-+++ b/Components/RTShaderSystem/src/OgreShaderFFPTexturing.cpp
-@@ -654,8 +654,12 @@
-             curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(alphaValue)), Operand::OPS_IN);
-         }
-         else
--        {               
--            curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4(colourValue.ptr())), Operand::OPS_IN);
-+        {
-+            curFuncInvocation->pushOperand(ParameterFactory::createConstParam(Vector4((Real)colourValue.r,
-+                                                                                      (Real)colourValue.g,
-+                                                                                      (Real)colourValue.b,
-+                                                                                      (Real)colourValue.a)),
-+                                           Operand::OPS_IN);
-         }
-         
-         curFuncInvocation->pushOperand(arg, Operand::OPS_OUT);
diff --git a/dev-games/ogre/ogre-1.10.11.ebuild b/dev-games/ogre/ogre-1.10.11.ebuild
deleted file mode 100644 (file)
index 3094851..0000000
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="Object-oriented Graphics Rendering Engine"
-HOMEPAGE="https://www.ogre3d.org/"
-SRC_URI="https://github.com/OGRECave/${PN}/archive/v${PV}.zip -> ${P}.zip"
-
-LICENSE="MIT public-domain"
-SLOT="0/1.10.0"
-KEYWORDS="~amd64 ~arm ~x86"
-
-IUSE="cg doc double-precision examples +freeimage gl3plus gles2 gles3 ois +opengl profile tools"
-
-REQUIRED_USE="examples? ( ois )
-       gles3? ( gles2 )
-       gl3plus? ( opengl )"
-
-RESTRICT="test" #139905
-
-RDEPEND="
-       dev-libs/boost
-       dev-libs/zziplib
-       media-libs/freetype:2
-       virtual/glu
-       virtual/opengl
-       x11-libs/libX11
-       x11-libs/libXaw
-       x11-libs/libXrandr
-       x11-libs/libXt
-       cg? ( media-gfx/nvidia-cg-toolkit )
-       freeimage? ( media-libs/freeimage )
-       gl3plus? ( >=media-libs/mesa-9.2.5 )
-       gles2? ( >=media-libs/mesa-9.0.0[gles2] )
-       gles3? ( >=media-libs/mesa-10.0.0[gles2] )
-       ois? ( dev-games/ois )
-       tools? ( dev-libs/tinyxml[stl] )"
-DEPEND="${RDEPEND}
-       virtual/pkgconfig
-       x11-base/xorg-proto
-       doc? ( app-doc/doxygen )"
-
-PATCHES=(
-       "${FILESDIR}/${P}-samples.patch"
-       "${FILESDIR}/${P}-resource_path.patch"
-       "${FILESDIR}/${P}-media_path.patch"
-       "${FILESDIR}/${P}-fix_double_precision-88f0d5b.patch"
-)
-
-src_prepare() {
-       sed -i \
-               -e "s:share/OGRE/docs:share/doc/${PF}:" \
-               Docs/CMakeLists.txt || die
-       # Stupid build system hardcodes release names
-       sed -i \
-               -e '/CONFIGURATIONS/s:CONFIGURATIONS Release.*::' \
-               CMake/Utils/OgreConfigTargets.cmake || die
-
-       # make sure we're not using the included tinyxml
-       # Update for 1.10.11: Unfortunately the build system does not
-       #   search for a system wide tinyxml at this moment. However,
-       #   TinyXML is meant to be built into and not linked to a using
-       #   project anyway.
-       # rm -f Tools/XMLConverter/{include,src}/tiny*.*
-
-       # Fix some path issues
-       cmake-utils_src_prepare
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DOGRE_BUILD_COMPONENT_JAVA=NO
-               -DOGRE_BUILD_COMPONENT_PYTHON=NO
-               -DOGRE_BUILD_DEPENDENCIES=NO
-               -DOGRE_BUILD_PLUGIN_CG=$(usex cg)
-               -DOGRE_BUILD_SAMPLES=$(usex examples)
-               -DOGRE_BUILD_TESTS=FALSE
-               -DOGRE_BUILD_TOOLS=$(usex tools)
-               -DOGRE_CONFIG_DOUBLE=$(usex double-precision)
-               -DOGRE_CONFIG_ENABLE_FREEIMAGE=$(usex freeimage)
-               -DOGRE_CONFIG_THREADS=3
-               -DOGRE_CONFIG_THREAD_PROVIDER=std
-               -DOGRE_FULL_RPATH=NO
-               -DOGRE_INSTALL_DOCS=$(usex doc)
-               -DOGRE_INSTALL_SAMPLES=$(usex examples)
-               -DOGRE_INSTALL_SAMPLES_SOURCE=$(usex examples)
-               -DOGRE_NODE_STORAGE_LEGACY=NO
-               -DOGRE_PROFILING=$(usex profile)
-               -DOGRE_RESOURCEMANAGER_STRICT=strict
-               -DOGRE_USE_STD11=YES
-       )
-
-       cmake-utils_src_configure
-}
-
-src_install() {
-       cmake-utils_src_install
-
-       CONFIGDIR=/etc/OGRE
-       SHAREDIR=/usr/share/OGRE
-
-       # plugins and resources are the main configuration
-       insinto "${CONFIGDIR}"
-       doins "${CMAKE_BUILD_DIR}"/bin/plugins.cfg
-       doins "${CMAKE_BUILD_DIR}"/bin/resources.cfg
-       dosym "${CONFIGDIR}"/plugins.cfg "${SHAREDIR}"/plugins.cfg
-       dosym "${CONFIGDIR}"/resources.cfg "${SHAREDIR}"/resources.cfg
-
-       # These are only for the sample browser
-       insinto "${SHAREDIR}"
-       doins "${CMAKE_BUILD_DIR}"/bin/quakemap.cfg
-       doins "${CMAKE_BUILD_DIR}"/bin/samples.cfg
-}