app-crypt/swtpm: Bump to 0.3.1
authorSalah Coronya <salah.coronya@gmail.com>
Tue, 7 Apr 2020 15:13:10 +0000 (10:13 -0500)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 23 Apr 2020 07:41:06 +0000 (10:41 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Salah Coronya <salah.coronya@gmail.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-crypt/swtpm/Manifest
app-crypt/swtpm/swtpm-0.3.1.ebuild [new file with mode: 0644]

index 2a0b8aca57b51c215f1b3e0857410967a9f08970..f874a6630a573d9415bf902f017ef3f44d396fc5 100644 (file)
@@ -1 +1,2 @@
 DIST swtpm-0.3.0.tar.gz 308472 BLAKE2B c6b93303c77cb3de0917b219b7e8e216864a11cd7c584d85409b457bc36db9b0515639ae972f8ef39ba60f52506075a2cc697519bd18da9fdb12031e716c9e6e SHA512 e1e62367966224b3fc6edb80a883c5e3d6a698f437032e0b4b71558ebd7e24e5b92e7d843ee15ca29edd96710bbac51cb435956ac535b10a5f2b2afd65e748a3
+DIST swtpm-0.3.1.tar.gz 308576 BLAKE2B 96c44654b92d453d91594aed6fdd4cb56853973c1215bfb131e750d38a3ed1e64e3283647e54ad9ad84747406f53d7ac4f221fc5b319d7fa80bab758fed04062 SHA512 4b3e58048336ee82a87d17905a7d0dc5fbe13160ebb8f072b91410e782dae7fafc72e572a2f6aa2b1d9f4377074c01afd30505b9e71d92b8d7066365811d3e3f
diff --git a/app-crypt/swtpm/swtpm-0.3.1.ebuild b/app-crypt/swtpm/swtpm-0.3.1.ebuild
new file mode 100644 (file)
index 0000000..20d0ca3
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit autotools python-any-r1
+
+DESCRIPTION="Libtpms-based TPM emulator"
+HOMEPAGE="https://github.com/stefanberger/swtpm"
+SRC_URI="https://github.com/stefanberger/swtpm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="fuse gnutls libressl seccomp test"
+
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+       fuse? (
+               dev-libs/glib:2
+               sys-fs/fuse:0
+             )
+       gnutls? (
+                  dev-libs/libtasn1:=
+                  >=net-libs/gnutls-3.1.0[tools]
+               )
+       !libressl? (
+                dev-libs/openssl:0=
+                dev-libs/libtpms[-libressl]
+                  )
+       libressl? (
+                   dev-libs/libressl:0=
+                   dev-libs/libtpms[libressl]
+                 )
+       seccomp? ( sys-libs/libseccomp )
+"
+
+DEPEND="${COMMON_DEPEND}
+       test? (
+               net-misc/socat
+               ${PYTHON_DEPS}
+             )
+"
+
+RDEPEND="${COMMON_DEPEND}
+       acct-group/tss
+       acct-user/tss
+       app-crypt/tpm-tools
+       app-crypt/trousers
+       dev-tcltk/expect"
+
+src_prepare() {
+       use test || eapply "${FILESDIR}/${PN}-disable-test-dependencies.patch"
+       eapply "${FILESDIR}/${PN}-fix-localca-path.patch"
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+         --with-openssl \
+         --without-selinux \
+         $(use_with fuse cuse) \
+         $(use_with gnutls) \
+         $(use_with seccomp)
+}
+
+src_install() {
+       default
+       fowners tss:tss /var/lib/swtpm-localca
+       keepdir /var/lib/swtpm-localca
+       find "${D}" -name '*.la' -delete || die
+}