dev-python/markdown2: Bump to 2.3.9
authorMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 07:02:55 +0000 (09:02 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 13 May 2020 07:08:15 +0000 (09:08 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/markdown2/Manifest
dev-python/markdown2/markdown2-2.3.9.ebuild [new file with mode: 0644]

index f49f48ecaeeb630d3ad983cca389d8dec58e06c3..697ffefde95d75e09045155517e7987965d4e8e3 100644 (file)
@@ -1,2 +1,3 @@
 DIST markdown2-2.3.0.zip 145194 BLAKE2B ef6e5744b6d9c9c8de20ac2d17ea0fc13453dd6401ab0c8d6d258f6a19aec4e94cfdfef28cbef7ef4b4bf6133a0acb55a1d8a76a41ac621498117c39b1fc1a6e SHA512 48bf8e26b34c48c0c12fc0f110b09d3232ea3394db3325d50639adf5cefb603344ee97b116e09b574f7c7414ab4a8293ddc37ca6706e41baaa14e399fa467d5f
 DIST markdown2-2.3.8.tar.gz 86850 BLAKE2B e227139d4ac368095872b09bcaac78ad49c7ae43b63036563c3b80b2ff6a78c3d302d8a2c56b68a5ba1d01967ab1861f842986316bb6d0a6625cb21b644e46eb SHA512 76abbbb2fa5f6a4cc43f358812079a2561f45ba5c2aed1a1860256440f7c48ca5e766c00c2464b973ef0cbbff9db58bca4398dc15ef8b5d203a6565b226bd7cd
+DIST markdown2-2.3.9.tar.gz 101067 BLAKE2B 4b1ba9e90e2cd370edaff4d61bec9182ca30952351274c4aa508e2e3573a79bac7ab70a1d29d279eb2a94da56a823222a9413b0f3f871f3bd2dfb2ed60621158 SHA512 1be193b27efff9bd084da94cf4121fc91cffda57165333ac644a4ad31b33da62bcda1df0fdb450a02421c0199484de5d6b65131a0afe2dd941c52a3f81bb218d
diff --git a/dev-python/markdown2/markdown2-2.3.9.ebuild b/dev-python/markdown2/markdown2-2.3.9.ebuild
new file mode 100644 (file)
index 0000000..ddae999
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.tar.gz"
+HOMEPAGE="https://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_test() {
+       cd test || die
+       distutils-r1_src_test
+}
+
+python_test() {
+       "${EPYTHON}" -m unittest test_markdown2.py -v ||
+               die "Tests fail with ${EPYTHON}"
+}