dev-go/go-resiliency: convert to use go eclasses
authorWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 19:30:15 +0000 (14:30 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Mon, 10 Aug 2015 19:30:15 +0000 (14:30 -0500)
dev-go/go-resiliency/go-resiliency-1.0.0.ebuild

index 3f06a6bdf2cd6b386b4afc031ab251e53fc4e95e..ac53b2b8be626699f3ba04fd39de116fa1c8b1c5 100644 (file)
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
 else
        KEYWORDS="~amd64"
        SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       inherit golang-vcs-snapshot
 fi
 inherit golang-build
 
@@ -22,37 +23,3 @@ SLOT="0/${PV}"
 IUSE=""
 DEPEND=""
 RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
-       local f
-
-       for f in ${A}
-       do
-               case "${f}" in
-                       *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
-                               local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
-                               debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
-                               # XXX: check whether the directory structure inside is
-                               # fine? i.e. if the tarball has actually a parent dir.
-                               mkdir -p "${destdir}" || die
-                               tar -C "${destdir}" -x --strip-components 1 \
-                                       -f "${DISTDIR}/${f}" || die
-                               ;;
-                       *)
-                               debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
-                               # fall back to the default method
-                               unpack "${f}"
-                               ;;
-               esac
-       done
-}
-fi
-
-src_install() {
-       rm -rf src/${EGO_SRC}/.git* || die
-       golang-build_src_install
-}