games-util/joystick: Bump to version 1.7.0
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 14 Oct 2019 13:53:24 +0000 (15:53 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 14 Oct 2019 13:59:44 +0000 (15:59 +0200)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
games-util/joystick/Manifest
games-util/joystick/joystick-1.7.0.ebuild [new file with mode: 0644]

index 210ac3641d26eae6a8db647b5f82ce99c75ae06c..667ee1757f1b1714c79728db2b3b5e106f4b5440 100644 (file)
@@ -1,2 +1,3 @@
 DIST linuxconsoletools-1.6.0.tar.bz2 50563 BLAKE2B 26f68f4a9a4af5b875bc7efcc70edd80978a560f62c415b4957ee851260a2f6e6227c5a3001fb009777eac7e19d0449a8335486290ae0aaa9467ad8e1e9a89fb SHA512 35ca923cceca729bcbab95dff18682abd0d87a297e70aa8707fbabccde018fef0775a99195af4bf9111ba33210a14c10d1a766f83112cd535930a1ae430c7c75
 DIST linuxconsoletools-1.6.1.tar.bz2 50854 BLAKE2B 0614e72226c575499ae5976011a0fca146a1981e2d355f7554f105b184bdd4f1090bf5374377e89f3881c5476e3c3a362b70f86cfd83440264066ea50a8c6a4b SHA512 b520c0a2d55986204619e3a5a00fb8b1e26453ac6df4f51c8c87495661a68bb6fe5a1947a3e079a53a537bf06d23c73c404a4d7e4d4dd18c0f7f69c1985a77be
+DIST linuxconsoletools-1.7.0.tar.bz2 52960 BLAKE2B 438e69e7aa220ea3fc92a9a72bda081c7877663c451f3101bc30e344a7a0f0f20b1c2f4ecd78c0db501b6442e2cd20e9f288c9c331118e8c666a61c3ac4b6851 SHA512 260667e167281dd6f4de0904c2852a5bf3d9d0fe9d603135d4849c5a6610997306c9b476f64e4015d17a4dc8e4a8d36e96e01b9b63664fc7b493201fe12b4f56
diff --git a/games-util/joystick/joystick-1.7.0.ebuild b/games-util/joystick/joystick-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..a4389f2
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+MY_P="linuxconsoletools-${PV}"
+DESCRIPTION="joystick testing utilities"
+HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
+SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="sdl udev"
+
+DEPEND="sdl? ( media-libs/libsdl2:0[video] )
+       !<x11-libs/tslib-1.0-r2"
+RDEPEND="${DEPEND}
+       udev? ( virtual/udev )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.6.0-build.patch
+)
+
+src_prepare() {
+       default
+
+       export PREFIX=/usr
+       tc-export CC PKG_CONFIG
+       export USE_SDL=$(usex sdl)
+}
+
+src_install() {
+       default
+       if ! use udev ; then
+               rm "${ED}"/usr/bin/jscal-{re,}store || die
+       fi
+}