media-libs/gegl: 0.4.22 version bump
authorSergey Torokhov <torokhov-s-a@yandex.ru>
Mon, 24 Feb 2020 23:23:50 +0000 (02:23 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 5 Mar 2020 12:16:01 +0000 (14:16 +0200)
'pdf' USE-flag now also enables new meson option 'poppler'.

"gegl-0.4.18-cltostring_force_utf8.patch" isn't nessessary anymore
because implemented in upstream.

Closes: https://bugs.gentoo.org/711536

Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
media-libs/gegl/Manifest
media-libs/gegl/gegl-0.4.22.ebuild [new file with mode: 0644]

index 30c6459c6fcacdf08718c6bf317e95d430fabfa6..08184dac4a75239f820a598f56a660fdaacd155b 100644 (file)
@@ -3,3 +3,4 @@ DIST gegl-0.3.34.tar.bz2 6707964 BLAKE2B 4424a2c218067bd0a77d79c2334528da393350d
 DIST gegl-0.4.16.tar.bz2 7304904 BLAKE2B a3f6021ed7b9d8b784b909057fcdc39e73b6b8b811009adae3c4a6805263e9a887e874ad662d8cd5c673ae324fe39e8f0299651139783fd3ece08675b70896fd SHA512 38eacbd53d9993ca99d061bf6f80553a86ff06bf42d1710403ac5f15629ccc9b1f4395ee7700a04cebc954ed7fe8745c5bef85453c9c56d89681dd53a1552b27
 DIST gegl-0.4.18.tar.xz 4812756 BLAKE2B b8e5902b62c3549f57dd0ce52a0a406974bf8664d5b85389b79f7d698bcf2643d19861add3d8a9bd5c99036aba4da97b70884dcaacf2cb89170b995f1d1497a0 SHA512 e79874cd50e9f0c27c7dc9d9b952545c31d0a48e2b158aa54b92c3e933267877222f86ede7256f2528f18985dc85d6eadbcd809f7a3563efc4449ec7634f15fd
 DIST gegl-0.4.20.tar.xz 4826340 BLAKE2B 0d1087ea983d7fbeb7ea1edb572bea97e9b4e01aaabd5225ba07ab5cee3b369f42fe39691209f38d4d2a87d56997d9756449cafdb6288eb0864b49fb13a6a8ef SHA512 140ac1543aa24a23aa685dbd7335f21bcbf3d95c41c1451b2383f6d278842bd9f0c8c980ed27c70c67b2fefe9ba01f2d4bd4b77a1cee38ec1332c12ab3fd718d
+DIST gegl-0.4.22.tar.xz 4826748 BLAKE2B 3b6ddca1dff17d0336614fb02cdf94c7497586f075fa548fef66f9f81f62a8055c58e008b9eed989dd283fa701a07d4e22ee81b85c35a0a55f4a92e51cf6b780 SHA512 3118fb17532bcd5893a77739eaf936f5d1e2020178abc497098d227c25f726679621503ac83e7d14a9883d259247d97b92016174e76a2e6e950be7e26ce251ab
diff --git a/media-libs/gegl/gegl-0.4.22.ebuild b/media-libs/gegl/gegl-0.4.22.ebuild
new file mode 100644 (file)
index 0000000..f06622e
--- /dev/null
@@ -0,0 +1,163 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+# vala and introspection support is broken, bug #468208
+VALA_USE_DEPEND=vapigen
+
+inherit meson gnome2-utils python-any-r1 vala
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gegl.git"
+       SRC_URI=""
+else
+       SRC_URI="http://download.gimp.org/pub/${PN}/${PV:0:3}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A graph based image processing framework"
+HOMEPAGE="http://www.gegl.org/"
+
+LICENSE="|| ( GPL-3+ LGPL-3 )"
+SLOT="0.4"
+
+IUSE="cairo debug ffmpeg introspection lcms lensfun libav openexr pdf raw sdl svg test tiff umfpack vala v4l webp"
+REQUIRED_USE="
+       svg? ( cairo )
+       test? ( introspection )
+       vala? ( introspection )
+"
+
+RESTRICT="!test? ( test )"
+
+# NOTE: Even current libav 11.4 does not have AV_CODEC_CAP_VARIABLE_FRAME_SIZE
+#       so there is no chance to support libav right now (Gentoo bug #567638)
+#       If it returns, please check prior GEGL ebuilds for how libav was integrated.  Thanks!
+RDEPEND="
+       >=dev-libs/glib-2.44:2
+       >=dev-libs/json-glib-1.2.6
+       >=media-libs/babl-0.1.74[introspection?]
+       media-libs/libnsgif
+       >=media-libs/libpng-1.6.0:0=
+       >=sys-libs/zlib-1.2.0
+       virtual/jpeg:0=
+       >=x11-libs/gdk-pixbuf-2.32:2
+       >=x11-libs/pango-1.38.0
+       cairo? ( >=x11-libs/cairo-1.12.2 )
+       ffmpeg? (
+               libav? ( media-video/libav:0= )
+               !libav? ( media-video/ffmpeg:0= )
+       )
+       introspection? ( >=dev-libs/gobject-introspection-1.32:= )
+       lcms? ( >=media-libs/lcms-2.8:2 )
+       lensfun? ( >=media-libs/lensfun-0.2.5 )
+       openexr? ( >=media-libs/openexr-1.6.1:= )
+       pdf? ( >=app-text/poppler-0.71.0[cairo] )
+       raw? ( >=media-libs/libraw-0.15.4:0= )
+       sdl? ( >=media-libs/libsdl-1.2.0 )
+       svg? ( >=gnome-base/librsvg-2.40.6:2 )
+       tiff? ( >=media-libs/tiff-4:0 )
+       umfpack? ( sci-libs/umfpack )
+       v4l? ( >=media-libs/libv4l-1.0.1 )
+       webp? ( >=media-libs/libwebp-0.5.0:= )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+       dev-lang/perl
+       >=dev-util/gtk-doc-am-1
+       >=sys-devel/gettext-0.19.8
+       >=sys-devel/libtool-2.2
+       virtual/pkgconfig
+       test? ( $(python_gen_any_dep '>=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]') )
+       vala? ( $(vala_depend) )
+"
+
+DOCS=( AUTHORS docs/ChangeLog docs/NEWS.txt )
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.4.18-drop-failing-tests.patch
+       "${FILESDIR}"/${PN}-0.4.18-program-suffix.patch
+)
+
+python_check_deps() {
+       has_version -b ">=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+       use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+       default
+
+       # don't require Apple's OpenCL on versions of OSX that don't have it
+       if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -le 9 ]] ; then
+               sed -i -e 's/#ifdef __APPLE__/#if 0/' gegl/opencl/* || die
+       fi
+
+       # commit 7c78497b : tests that use gegl.png are broken on non-amd64
+       sed -e '/clones.xml/d' \
+               -e '/composite-transform.xml/d' \
+               -i tests/compositions/meson.build || die
+
+       # fix skipping mipmap tests due to executable not found
+       for item in "invert-crop.sh" "invert.sh" "rotate-crop.sh" "rotate.sh" "unsharp-crop.sh" "unsharp.sh"; do
+               sed -i "s:/bin/gegl:/bin/gegl-0.4:g" "${S}/tests/mipmap/${item}" || die
+               sed -i "s:/tools/gegl-imgcmp:/tools/gegl-imgcmp-0.4:g" "${S}/tests/mipmap/${item}" || die
+       done
+
+       gnome2_environment_reset
+
+       use vala && vala_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               #  - Disable documentation as the generating is bit automagic
+               #    if anyone wants to work on it just create bug with patch
+               -Ddocs=false
+               -Dexiv2=disabled
+               -Dgdk-pixbuf=enabled
+               -Dgexiv2=disabled
+               #  - There are two checks for dot, one controllable by --with(out)-graphviz
+               #    which toggles HAVE_GRAPHVIZ that is not used anywhere.  Yes.
+               -Dgraphviz=disabled
+               -Djasper=disabled
+               -Dlibjpeg=enabled
+               -Dlibpng=enabled
+               #  - libspiro: not in portage main tree
+               -Dlibspiro=disabled
+               -Dlua=disabled
+               -Dmrg=disabled
+               -Dpango=enabled
+               -Dsdl2=disabled
+               #  - Parameter -Dworkshop=false disables any use of Lua, effectivly
+               -Dworkshop=false
+               $(meson_feature cairo)
+               $(meson_feature cairo pangocairo)
+               $(meson_feature ffmpeg libav)
+               $(meson_feature lcms)
+               $(meson_feature lensfun)
+               $(meson_feature openexr)
+               $(meson_feature pdf poppler)
+               $(meson_feature raw libraw)
+               $(meson_feature sdl sdl1)
+               $(meson_feature svg librsvg)
+               $(meson_feature test pygobject)
+               $(meson_feature tiff libtiff)
+               $(meson_feature umfpack)
+               #  - v4l support does not work with our media-libs/libv4l-0.8.9,
+               #    upstream bug at https://bugzilla.gnome.org/show_bug.cgi?id=654675
+               $(meson_feature v4l libv4l)
+               $(meson_feature v4l libv4l2)
+               $(meson_feature vala vapigen)
+               $(meson_feature webp)
+               $(meson_use introspection)
+       )
+       meson_src_configure
+}