app-emulation/simh: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Mon, 23 Mar 2020 23:40:25 +0000 (23:40 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Mon, 23 Mar 2020 23:57:44 +0000 (23:57 +0000)
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-emulation/simh/Manifest
app-emulation/simh/simh-3.9.0-r1.ebuild [deleted file]

index 881e4b244a14febeec0513b7395435f394fef1bf..6a8605a1d351f28173531fec1bdda68e61f1e24d 100644 (file)
@@ -1,2 +1 @@
 DIST simhv311-0.zip 2790607 BLAKE2B f9399977093f07d7f58067ed40e22f60e43228bbb1e0fdaa6b04408956962d9ea14b6dc57d758b819cee59f3bade9505a6802d42804df49622990402c0f22600 SHA512 e5fb6915c050e7402363cd9c1f99feb00874c3693905067ce901ffa86fc29a0cd2648684f111216b09a3c847f75812e2db2e2f2fa9f9d0db5dc932d53ec832fa
-DIST simhv39-0.zip 3103657 BLAKE2B 3b5fcaa7f1aa24bd5afa78452fb2d5e2822654bcaa3caa478dbdf939770c13f7f1d3f95859674fc02e2cc35a4cfff239bb9ee6a726fb9e31586f639cdf40ca10 SHA512 5e8cbf92e980b7cb40d68ff60a266f70c0bef0eecdc169a8077ae72a6a71fe12a7be5c62bd033ca36727e2cb8f266a5a6f8a5ed6dd509afbf0a9d7b618f1a4f6
diff --git a/app-emulation/simh/simh-3.9.0-r1.ebuild b/app-emulation/simh/simh-3.9.0-r1.ebuild
deleted file mode 100644 (file)
index dcf25c3..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs versionator
-
-MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
-DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
-HOMEPAGE="http://simh.trailing-edge.com/"
-SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="net-libs/libpcap"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-S=${WORKDIR}
-
-src_prepare() {
-       # convert makefile from dos format to unix format
-       edos2unix makefile
-
-       epatch "${FILESDIR}"/${P}-respect-FLAGS.patch \
-               "${FILESDIR}"/${P}-fix-mkdir-race.patch
-
-       # fix linking on Darwin
-       if [[ ${CHOST} == *-darwin* ]] ; then
-               sed -e 's/-lrt//g' \
-                       -i makefile || die
-       fi
-}
-
-src_compile() {
-       export GCC="$(tc-getCC)"
-       export LDFLAGS_O="${LDFLAGS}"
-       export CFLAGS_O="${CFLAGS}"
-
-       local my_makeopts=""
-       if [ "$(gcc-major-version)" -le "4" -a "$(gcc-minor-version)" -lt "6" ] ; then
-               my_makeopts+=" NO_LTO=1"
-       fi
-
-       emake ${my_makeopts}
-}
-
-src_install() {
-       for BINFILE in BIN/* ; do
-               newbin ${BINFILE} "simh-$(basename ${BINFILE})"
-       done
-
-       insinto /usr/share/simh
-       doins VAX/*.bin
-
-       dodoc *.txt */*.txt
-}