x11-libs/libva-intel-driver: Bump to 1.8.0
authorAlexis Ballier <aballier@gentoo.org>
Mon, 3 Apr 2017 07:30:55 +0000 (09:30 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 3 Apr 2017 07:30:55 +0000 (09:30 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

x11-libs/libva-intel-driver/Manifest
x11-libs/libva-intel-driver/libva-intel-driver-1.8.0.ebuild [new file with mode: 0644]
x11-libs/libva-intel-driver/libva-intel-driver-9999.ebuild

index 9df7b88108767715483f3baae9635fe3ab660292..6a5fb44fd26b4534e2ab19b6745476a9651bc48b 100644 (file)
@@ -1 +1,2 @@
 DIST libva-intel-driver-1.7.3.tar.bz2 1547040 SHA256 76ad37d9fd5ae23d8ce6052d50b5e6438a8df9e769b13fe34b771cd453f4f937 SHA512 90567b94e3373287b1b5fe776e291dfd33577bbe5e4ec1bee359c88544c9c17bbae2aac511ff3d704d7b99b19fbc908c9a38ebbd3162e3625c86c416142390e6 WHIRLPOOL a585d1e800a45fe6dc8ec1bb244452ac195173051e15adb2ec33224238cf7e93f686a98c400bf98d73153a3080d37c15e4c09bd9da4882a211374a61df395f66
+DIST libva-intel-driver-1.8.0.tar.gz 2308240 SHA256 45a38641f3ddbd43d9c053bfd9cb809ecb2d5f5227f0e3c1c5a8d51dccf81b35 SHA512 fbf68ad5f7558366dadf6e8d834ed89665e86167676ca72fdca218023f5709b0bdf1b124f11ed3f7c10b60741a2574a8ea7c3e5607a6727d3b9cc2ed44981542 WHIRLPOOL 9907ba61a3ae7fb512a34c20a2e53a8e309b772a3cea6c898e4caec376646c27db80983ebbac1da1ab25da7e7c917e81379871ee91f58889a46c5d083175efee
diff --git a/x11-libs/libva-intel-driver/libva-intel-driver-1.8.0.ebuild b/x11-libs/libva-intel-driver/libva-intel-driver-1.8.0.ebuild
new file mode 100644 (file)
index 0000000..fb9e63e
--- /dev/null
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+SCM=""
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+       SCM=git-r3
+       EGIT_BRANCH=master
+       EGIT_REPO_URI="https://github.com/01org/intel-vaapi-driver"
+fi
+
+AUTOTOOLS_AUTORECONF="yes"
+inherit autotools-multilib ${SCM}
+
+DESCRIPTION="HW video decode support for Intel integrated graphics"
+HOMEPAGE="https://github.com/01org/intel-vaapi-driver"
+if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/01org/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/intel-vaapi-driver-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+if [ "${PV%9999}" = "${PV}" ] ; then
+       KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+else
+       KEYWORDS=""
+fi
+IUSE="+drm wayland X"
+
+RDEPEND=">=x11-libs/libva-1.8.0[X?,wayland?,drm?,${MULTILIB_USEDEP}]
+       >=x11-libs/libdrm-2.4.46[video_cards_intel,${MULTILIB_USEDEP}]
+       wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+AUTOTOOLS_PRUNE_LIBTOOL_FILES="all"
+
+src_prepare() {
+       sed -e 's/intel-gen4asm/\0diSaBlEd/g' -i configure.ac || die
+       autotools-multilib_src_prepare
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               $(use_enable drm)
+               $(use_enable wayland)
+               $(use_enable X x11)
+       )
+       autotools-utils_src_configure
+}
index 9edd9fb616a751db48a33fc3f1e49f83f7cf3505..fb9e63e76501a12302a777107b6d0a0a3a16b737 100644 (file)
@@ -19,6 +19,7 @@ if [ "${PV%9999}" != "${PV}" ] ; then # Live ebuild
        SRC_URI=""
 else
        SRC_URI="https://github.com/01org/intel-vaapi-driver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/intel-vaapi-driver-${PV}"
 fi
 
 LICENSE="MIT"
@@ -30,7 +31,7 @@ else
 fi
 IUSE="+drm wayland X"
 
-RDEPEND=">=x11-libs/libva-1.7.2[X?,wayland?,drm?,${MULTILIB_USEDEP}]
+RDEPEND=">=x11-libs/libva-1.8.0[X?,wayland?,drm?,${MULTILIB_USEDEP}]
        >=x11-libs/libdrm-2.4.46[video_cards_intel,${MULTILIB_USEDEP}]
        wayland? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )"