media-libs/jasper: Bump to v2.0.14
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 5 Feb 2018 10:55:27 +0000 (11:55 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 5 Feb 2018 10:55:42 +0000 (11:55 +0100)
Ebuild changes:
===============
- Add patch to disable tests which will require libjpeg
  when built without jpeg USE flag set.

Closes: https://bugs.gentoo.org/629898
Closes: https://bugs.gentoo.org/642020
Package-Manager: Portage-2.3.21, Repoman-2.3.6

media-libs/jasper/Manifest
media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch [new file with mode: 0644]
media-libs/jasper/jasper-2.0.14.ebuild [new file with mode: 0644]

index 639f6735c7752e3018f4aec031647a24e2cf34ad..012a855f8d31a18a90a54260ee3cd8ce68dc7a63 100644 (file)
@@ -1 +1,2 @@
 DIST jasper-2.0.12.tar.gz 1311323 BLAKE2B bc9922bfc4765ea4630f9a504c9e5a1c0992f78c2ef68cd077ba0c8a36332debd5db9fc5c639accc7eaa0eda64e478c1e615da9f2eaf363446635dd94a253fa0 SHA512 a308983511119d85e6580772f5164c188e2e170500fa4b98c8831aa63aa87cb661b88952b278e390497571f9ebf9286855a8aa946037692309ba5f41cffe265a
+DIST jasper-2.0.14.tar.gz 1311825 BLAKE2B 0cd2feb5a73aaa2da6f1d105fefe98f57c6a5ecf92f6449891f49eca0b5926bc683a03bf933b920cad95883134cf292405f244f10b3bbe7867a41f2dde80337e SHA512 6b270cb1eb55f777f30016f3258e5e2297627e7d086334814c308464f5a4552c23241b0fdbc81ea715a6f4746294657f96c1cb6ceb320629ce57db7e81d84940
diff --git a/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch b/media-libs/jasper/files/jasper-2.0.14-fix-test-suite.patch
new file mode 100644 (file)
index 0000000..9af83c6
--- /dev/null
@@ -0,0 +1,28 @@
+Disable tests which will require LIBJPEG when Jasper was
+built without LIBJPEG.
+
+Bug: https://bugs.gentoo.org/629898
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -393,12 +393,14 @@ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/test/bin/wrapper.in"
+   "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper" @ONLY)
+ if (BASH_PROGRAM)
+-      add_test(run_test_1
+-        "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+-        "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_1")
+-      add_test(run_test_2
+-        "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+-        "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_2")
++      if (JAS_ENABLE_LIBJPEG)
++              add_test(run_test_1
++                "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
++                "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_1")
++              add_test(run_test_2
++                "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
++                "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_2")
++      endif()
+       add_test(run_test_3
+         "${BASH_PROGRAM}" "${CMAKE_CURRENT_BINARY_DIR}/test/bin/wrapper"
+         "${CMAKE_CURRENT_SOURCE_DIR}/test/bin/run_test_3")
diff --git a/media-libs/jasper/jasper-2.0.14.ebuild b/media-libs/jasper/jasper-2.0.14.ebuild
new file mode 100644 (file)
index 0000000..1639b4b
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-multilib
+
+DESCRIPTION="Implementation of the codec specified in the JPEG-2000 Part-1 standard"
+HOMEPAGE="https://www.ece.uvic.ca/~mdadams/jasper/"
+
+if [[ ${PV} == *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/mdadams/jasper.git"
+else
+       inherit vcs-snapshot
+       SRC_URI="https://github.com/mdadams/${PN}/archive/version-${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+fi
+
+# We limit memory usage to 128 MiB by default, specified in bytes
+: ${JASPER_MEM_LIMIT:=134217728}
+
+LICENSE="JasPer2.0"
+SLOT="0/4"
+IUSE="doc jpeg opengl test"
+
+RDEPEND="
+       jpeg? ( >=virtual/jpeg-0-r2:0[${MULTILIB_USEDEP}] )
+       opengl? (
+               >=virtual/opengl-7.0-r1:0[${MULTILIB_USEDEP}]
+               >=media-libs/freeglut-2.8.1:0[${MULTILIB_USEDEP}]
+               virtual/glu[${MULTILIB_USEDEP}]
+               x11-libs/libXi[${MULTILIB_USEDEP}]
+               x11-libs/libXmu[${MULTILIB_USEDEP}]
+       )"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.14-fix-test-suite.patch )
+
+multilib_src_configure() {
+       local mycmakeargs=(
+               -DALLOW_IN_SOURCE_BUILD=OFF
+               -DBASH_PROGRAM="${EPREFIX}"/bin/bash
+               -DJAS_ENABLE_ASAN=OFF
+               -DJAS_ENABLE_LSAN=OFF
+               -DJAS_ENABLE_MSAN=OFF
+               -DJAS_ENABLE_SHARED=ON
+               -DJAS_ENABLE_STRICT=ON
+               -DJAS_ENABLE_USAN=OFF
+               -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+
+               # JPEG
+               -DJAS_ENABLE_LIBJPEG=$(usex jpeg)
+               -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex !jpeg)
+
+               # OpenGL
+               -DJAS_ENABLE_OPENGL=$(usex opengl)
+               -DCMAKE_DISABLE_FIND_PACKAGE_OpenGL=$(usex !opengl)
+
+               # Doxygen
+               -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(multilib_native_usex doc OFF ON)
+
+               #-DJAS_ENABLE_PROGRAMS=$(usex test)
+       )
+       cmake-utils_src_configure
+}