net-misc/chrome-remote-desktop: version bump to 45.0.2454.17
authorMike Frysinger <vapier@gentoo.org>
Sun, 6 Sep 2015 07:36:00 +0000 (03:36 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sun, 6 Sep 2015 07:37:07 +0000 (03:37 -0400)
net-misc/chrome-remote-desktop/Manifest
net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17.ebuild [new file with mode: 0644]

index 84e18da07144539a5ea227bad9f33a76e2286c20..3a73d6f14f10dd38051948ad1404e7b424413dbc 100644 (file)
@@ -4,3 +4,5 @@ DIST chrome-remote-desktop_41.0.2272.41_amd64.deb 14857068 SHA256 3d6ed3c527bf0b
 DIST chrome-remote-desktop_41.0.2272.41_i386.deb 15534358 SHA256 b591a3815366832229902b1d15d9d2cb246651b715c08f58d7d52df1f4d2dad0 SHA512 d9610e93df2e636163935debdeeee25843ca5bd0071330de9c9ce63fda717e6e4d29791822867c37466b80e8136eac4a86678c9d1536300701510f2a8c10658f WHIRLPOOL 94fe2c5eabfb15e4f12d9babac1bb08c406eef21d156051969304411311654ff0d087d44aefbb07b79eb9f3bf93a50ab10ed9f8bc54d0607eee60e5a402b07e7
 DIST chrome-remote-desktop_44.0.2403.44_amd64.deb 15171514 SHA256 ff47c5611447d2b72726aa04d7e4cc78865d488f1390b0a7c5bfd5ebc5139415 SHA512 44bbf90d4fd487d25e1bda8d2fef1aed2d2b6cdda6f18df0055aa341ac9e06b76dc49f742d839d20c37d67a46852807ca03eba56d84f9024b71ceed93c4de135 WHIRLPOOL 8e9f6d55ce13380cacc5fbf17808f95be43988231bd57ddd7cc78829810adbadb23f0ba2ac0474cea44b4c424c983f8806e33f2f0ac1f01f630354934f22a60f
 DIST chrome-remote-desktop_44.0.2403.44_i386.deb 16004938 SHA256 dde48a5cd7ff840857bcb3fad811b9cd1406c800a2332027240f0fb5788d0254 SHA512 5172d73c4bb45835ed3398a7f82f3096241b22f116fb24abf719c9160f234b82c3bf46f0d7b5ce43f1f50c62a39291ea2644876dc4af77a90fb11f8301b585b3 WHIRLPOOL ef3f3326c20f67bff9d1788ed6c70673051fff1ac309644b7edcd3fe2a2dbbeb1f7f17d269187185f4a06f0a154109793f11eeb87387c1229939b88bd2f9322e
+DIST chrome-remote-desktop_45.0.2454.17_amd64.deb 15349384 SHA256 c176730b1d42c1855804836ab7532dce9523710c7f68db11811a2d8b4fc4f2a7 SHA512 139b50d607db138d674fe1b7159ab7ec08a8a574b3114ed21eb5b1f82b6b9b447348ad0b28d3752ec1f54855e95ff439af08c3b1f7b2928efbcec3ca795817da WHIRLPOOL 045ed2dd8c64a1b8be6f87f970e241977ee19de92061c97e231a9ca7bb2e926ec2b80c36ccb09e67bf65b78e87c7b21aaae84d278f89d93eb356d6034a15a73f
+DIST chrome-remote-desktop_45.0.2454.17_i386.deb 16146850 SHA256 c4687db4424f0cd867db6926d3a1d458c19baa77c176064fbb707bf38e8f68f4 SHA512 59441ca3f4a9177e8999bc9953fd7b58aaae9afcc8d55252ff0d3dac965c7aec632bb708a925e56ef1d2351b7dc3415f238ce88a9975d99d86565f78fb19e6b1 WHIRLPOOL 1690447e012af6740c10f8a4c6dceeb75e24219c4101e230da26d7f87bdc14c46079af2f72d1a99bec57a3e8bfc0e3a1955ad5d165338f6426cd85fd7bd0fff7
diff --git a/net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17.ebuild b/net-misc/chrome-remote-desktop/chrome-remote-desktop-45.0.2454.17.ebuild
new file mode 100644 (file)
index 0000000..52f80d8
--- /dev/null
@@ -0,0 +1,106 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Base URL: https://dl.google.com/linux/chrome-remote-desktop/deb/
+# Fetch the Release file:
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/Release
+# Which gives you the Packages file:
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages
+#  https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages
+# And finally gives you the file name:
+#  pool/main/c/chrome-remote-desktop/chrome-remote-desktop_29.0.1547.32_amd64.deb
+#
+# Use curl to find the answer:
+#  curl -q https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-i386/Packages | grep ^Filename
+
+EAPI="4"
+
+inherit unpacker eutils
+
+DESCRIPTION="access remote computers via Chrome!"
+PLUGIN_URL="https://chrome.google.com/remotedesktop"
+HOMEPAGE="https://support.google.com/chrome/answer/1649523 ${PLUGIN_URL}"
+BASE_URI="https://dl.google.com/linux/chrome-remote-desktop/deb/pool/main/c/${PN}/${PN}_${PV}"
+SRC_URI="amd64? ( ${BASE_URI}_amd64.deb )
+       x86? ( ${BASE_URI}_i386.deb )"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+# All the libs this package links against.
+RDEPEND="app-admin/sudo
+       dev-lang/python
+       >=dev-libs/expat-2
+       dev-libs/glib:2
+       dev-libs/nspr
+       dev-libs/nss
+       dev-python/psutil
+       gnome-base/gconf:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       sys-devel/gcc
+       sys-libs/glibc
+       sys-libs/pam
+       x11-libs/cairo
+       x11-libs/gtk+:2
+       x11-libs/libX11
+       x11-libs/libXdamage
+       x11-libs/libXext
+       x11-libs/libXfixes
+       x11-libs/libXi
+       x11-libs/libXrandr
+       x11-libs/libXtst
+       x11-libs/pango"
+# Settings we just need at runtime.
+RDEPEND+="
+       x11-base/xorg-server[xvfb]"
+DEPEND=""
+
+S=${WORKDIR}
+
+QA_PREBUILT="/opt/google/chrome-remote-desktop/*"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-44.0.2403.44-always-sudo.patch #541708
+}
+
+src_install() {
+       insinto /etc
+       doins -r etc/opt
+
+       insinto /opt
+       doins -r opt/google
+       chmod a+rx "${ED}"/opt/google/${PN}/* || die
+
+       dodir /etc/pam.d
+       dosym system-remote-login /etc/pam.d/${PN}
+
+       dodoc usr/share/doc/${PN}/changelog*
+
+       newinitd "${FILESDIR}"/${PN}.rc ${PN}
+       newconfd "${FILESDIR}"/${PN}.conf.d ${PN}
+}
+
+pkg_postinst() {
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog "Two ways to launch the server:"
+               elog "(1) access an existing desktop"
+               elog "    (a) install the Chrome plugin on the server & client:"
+               elog "        ${PLUGIN_URL}"
+               elog "    (b) on the server, run the Chrome plugin & enable remote access"
+               elog "    (c) on the client, connect to the server"
+               elog "(2) headless system"
+               elog "    (a) install the Chrome plugin on the client:"
+               elog "        ${PLUGIN_URL}"
+               elog "    (b) visit https://accounts.google.com/o/oauth2/auth?response_type=code&scope=https://www.googleapis.com/auth/chromoting+https://www.googleapis.com/auth/googletalk+https://www.googleapis.com/auth/userinfo.email&access_type=offline&redirect_uri=https://chromoting-auth.googleplex.com/auth&approval_prompt=force&client_id=440925447803-avn2sj1kc099s0r7v62je5s339mu0am1.apps.googleusercontent.com&hl=en&from_login=1&as=-760f476eeaec11b8&pli=1&authuser=0"
+               elog "    (c) run the command mentioned on the server"
+               elog "    (d) on the client, connect to the server"
+               elog
+               elog "Configuration settings you might want to be aware of:"
+               elog "  ~/.${PN}-session - shell script to start your session"
+               elog "  /etc/init.d/${PN} - script to auto-restart server"
+       fi
+}