dev-python/pyalsaaudio: Include code for running tests
authorMichał Górny <mgorny@gentoo.org>
Wed, 17 May 2017 12:13:48 +0000 (14:13 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 17 May 2017 12:14:54 +0000 (14:14 +0200)
dev-python/pyalsaaudio/pyalsaaudio-0.8.2.ebuild

index 74e394c49f63c94c8e9d12ae4c7d2ad0e827a7a2..5470b7f46c427bfa7817f1b77aae5d4ea451798c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -31,6 +31,10 @@ python_compile() {
        distutils-r1_python_compile
 }
 
+python_test() {
+       "${PYTHON}" test.py -v || die "Tests fail with ${EPYTHON}"
+}
+
 python_install_all() {
        use doc && local HTML_DOCS=( doc/html/. )
        local EXAMPLES=( *test.py )