Version bump and old versions cleanup.
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 28 Dec 2006 16:27:56 +0000 (16:27 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 28 Dec 2006 16:27:56 +0000 (16:27 +0000)
Package-Manager: portage-2.1.2_rc4-r1

net-p2p/rtorrent/ChangeLog
net-p2p/rtorrent/files/digest-rtorrent-0.7.1 [new file with mode: 0644]
net-p2p/rtorrent/rtorrent-0.7.1.ebuild [new file with mode: 0644]

index eedfda8f53330cbd2809ecf79eeb8775791b7886..d2bf6031ca034a93b9ca426dc23c218fe1b0e9c4 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-p2p/rtorrent
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.71 2006/12/21 14:43:41 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.72 2006/12/28 16:27:56 flameeyes Exp $
+
+*rtorrent-0.7.1 (28 Dec 2006)
+
+  28 Dec 2006; Diego Pettenò <flameeyes@gentoo.org> -rtorrent-0.6.0.ebuild,
+  -rtorrent-0.7.0.ebuild, +rtorrent-0.7.1.ebuild:
+  Version bump and old versions cleanup.
 
   21 Dec 2006; Markus Rothe <corsair@gentoo.org> rtorrent-0.6.4.ebuild:
   Stable on ppc64; bug #158007
diff --git a/net-p2p/rtorrent/files/digest-rtorrent-0.7.1 b/net-p2p/rtorrent/files/digest-rtorrent-0.7.1
new file mode 100644 (file)
index 0000000..e320e1e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 98b97730c36828e662a2355cb2b11309 rtorrent-0.7.1.tar.gz 414447
+RMD160 01b42bc520abe7a6cae0b31e9b72dd65d4ae6a90 rtorrent-0.7.1.tar.gz 414447
+SHA256 2079c9f4d54b2cfcca5d41be0760ca0d93c6f0f05e3c1f929f66252fbdadcb8b rtorrent-0.7.1.tar.gz 414447
diff --git a/net-p2p/rtorrent/rtorrent-0.7.1.ebuild b/net-p2p/rtorrent/rtorrent-0.7.1.ebuild
new file mode 100644 (file)
index 0000000..32fec59
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.7.1.ebuild,v 1.1 2006/12/28 16:27:56 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=net-libs/libtorrent-0.11.0
+       >=dev-libs/libsigc++-2.0
+       >=net-misc/curl-7.12
+       sys-libs/ncurses"
+DEPEND="${RDEPEND}
+       sys-devel/bc"
+
+src_compile() {
+       replace-flags -Os -O2
+
+       if [[ $(tc-arch) = "x86" ]]; then
+               filter-flags -fomit-frame-pointer -fforce-addr
+
+               # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+               # it could be safer to fallback to -O1, but with the high use of STL in
+               # rtorrent, that could make it too slow.
+               [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+       fi
+
+       econf \
+               $(use_enable debug) \
+               --disable-dependency-tracking \
+               || die "econf failed"
+
+       emake || die "emake failed"
+}
+
+pkg_postinst() {
+       einfo "rtorrent now supports a configuration file."
+       einfo "A sample configuration file for rtorrent is can be found"
+       einfo "in ${ROOT}usr/share/doc/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc AUTHORS README TODO doc/rtorrent.rc
+}