dev/util-stepman: version bump to 0.10.2.
authorKarol Wrótniak <karol.wrotniak@droidsonroids.pl>
Sun, 19 Aug 2018 15:08:29 +0000 (17:08 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Mon, 20 Aug 2018 09:44:46 +0000 (11:44 +0200)
Closes: https://bugs.gentoo.org/663606
Closes: https://github.com/gentoo/gentoo/pull/9625

dev-util/stepman/Manifest
dev-util/stepman/stepman-0.10.2.ebuild [new file with mode: 0644]

index b47330bf9fb30cb40ab84806ff7e99fcda6642d5..aa6b09efbb718377278728f2670d70ae030b6321 100644 (file)
@@ -1 +1,2 @@
 DIST stepman-0.10.0.tar.gz 3054342 BLAKE2B 8d1d6fc8b4b85c79d535c6162a8b7c5ba15042b6a8334286cdf7ad5d498ee20abecaa1bb9ce9ffe5406891271e23a2e2554bea0b52bbf08df23a2154fdcb4da8 SHA512 1437d5c997e62a9da3beb666a15ac665e18300fad3668ee3acdae30307027bbf16c0d95f649a9a62c6203f3e09f9ec83525a23b3789f09c3707ff1937a7affbe
+DIST stepman-0.10.2.tar.gz 3087278 BLAKE2B 224bc6141678d4155474591d7094956ddd230086315ccff8ec2f91bb2d72761f46daa864086a449fb5d79dc2f7ec6f8935fa62a9a5be41a2f0aad9e3de84ca20 SHA512 6b7f1e17ff14e8a0a69056f6a8fa00043b53d818e61603fc2571a42a73e2c88edae1bb233fb734e1796c581c63f7aaf6e91c425525adbb2e1c3429cdc8dfa1e8
diff --git a/dev-util/stepman/stepman-0.10.2.ebuild b/dev-util/stepman/stepman-0.10.2.ebuild
new file mode 100644 (file)
index 0000000..c91e20c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Step collection manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+       unpack ${A}
+       mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+       mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/stepman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+       GOPATH="${WORKDIR}" go build -v -o bin/stepman || die "Couldn't compile stepman"
+}
+
+src_install() {
+       dobin bin/stepman
+       dodoc README.md
+}