sys-process/uksmd: 2020-05-05 snapshot
authorJoonas Niilola <juippis@gentoo.org>
Mon, 18 May 2020 06:05:20 +0000 (09:05 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 18 May 2020 06:06:04 +0000 (09:06 +0300)
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-process/uksmd/Manifest
sys-process/uksmd/uksmd-0_pre20200505.ebuild [new file with mode: 0644]

index ef1d7d35405082a65f97ef67cd272c24481d9247..2091f9196048b1edebe73994f67a5d8805bf3850 100644 (file)
@@ -1 +1,2 @@
 DIST uksmd-0_pre20200504.tar.bz2 13919 BLAKE2B abda5df86a2592f2e1299f23a94389c7c4af36a37e38e9f618860b5ce0b7fc796eb3b0f248bda7e3522643f5d3a3219fd5d1c66e5a21f32f8bda2a6942f6339b SHA512 9b69b3fea603aab2af27a3542e6b217de31c227581779602ae67d352917e79626530fd6ad769a8a7c147f2883926458757fbca7502b4034550292c7e6e14f2f0
+DIST uksmd-0_pre20200505.tar.bz2 14038 BLAKE2B a87ebd14dd8efd51476af8e8c2d3d6b31290bee3b29bac85a2ca2478a27d7128e82db36de8b055ec1aef2825552131291aa17d1927aee9cefbd05ffd78aac710 SHA512 0a0e41beeadeb9c42dac36be8f9fa25956226961b4d16725f03277bf4cf87f42e984a83af0787eb621d9c35277906df309899a741bb94b134fa3d21b6852ac50
diff --git a/sys-process/uksmd/uksmd-0_pre20200505.ebuild b/sys-process/uksmd/uksmd-0_pre20200505.ebuild
new file mode 100644 (file)
index 0000000..dae1153
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+MY_COMMIT="b6af35cb9a772f643fd1bd703f4d1f6c6c6d3b79"
+MY_P="${PN}-${MY_COMMIT}"
+
+DESCRIPTION="Userspace KSM helper daemon"
+HOMEPAGE="https://gitlab.com/post-factum/uksmd"
+SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/libcap-ng
+       sys-process/procps:="
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~KSM"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=( "${FILESDIR}/uksmd-0_pre20200504-respect-cflags-ldflags.patch" )
+
+src_install() {
+       default
+       einstalldocs
+
+       newinitd "${FILESDIR}/uksmd.init" uksmd
+       systemd_dounit distro/uksmd.service
+}