dev-ros/rospy: Install test nodes since tests of other packages need it.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 13:30:44 +0000 (15:30 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 14:36:25 +0000 (16:36 +0200)
Package-Manager: portage-2.2.21

dev-ros/rospy/rospy-1.11.14.ebuild
dev-ros/rospy/rospy-9999.ebuild

index 1d2ec33e68e5023934b478fe26d40eccab7e32d4..720ae2de005b133f2662f48d3cd1594661715e79 100644 (file)
@@ -23,3 +23,10 @@ RDEPEND="
        dev-python/rospkg[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"
+
+src_install() {
+       ros-catkin_src_install
+       # Other tests need these nodes
+       exeinto /usr/share/${PN}
+       doexe test_nodes/*
+}
index 1d2ec33e68e5023934b478fe26d40eccab7e32d4..720ae2de005b133f2662f48d3cd1594661715e79 100644 (file)
@@ -23,3 +23,10 @@ RDEPEND="
        dev-python/rospkg[${PYTHON_USEDEP}]
 "
 DEPEND="${RDEPEND}"
+
+src_install() {
+       ros-catkin_src_install
+       # Other tests need these nodes
+       exeinto /usr/share/${PN}
+       doexe test_nodes/*
+}