x11-plugins/wmweather: fix build with -fno-common
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:17:12 +0000 (13:17 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 29 Mar 2020 11:35:24 +0000 (13:35 +0200)
Closes: https://bugs.gentoo.org/714802
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch [new file with mode: 0644]
x11-plugins/wmweather/wmweather-2.4.7.ebuild

diff --git a/x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch b/x11-plugins/wmweather/files/wmweather-2.4.7-fno-common.patch
new file mode 100644 (file)
index 0000000..5db5fbc
--- /dev/null
@@ -0,0 +1,23 @@
+diff -Naur wmweather-2.4.7.orig/src/wmgeneral.h wmweather-2.4.7/src/wmgeneral.h
+--- wmweather-2.4.7.orig/src/wmgeneral.h       2019-02-13 20:54:48.000000000 +0100
++++ wmweather-2.4.7/src/wmgeneral.h    2020-03-29 13:14:19.373976239 +0200
+@@ -36,7 +36,7 @@
+  /* Global variable */
+ /*******************/
+-Display               *display;
++extern Display                *display;
+   /***********************/
+  /* Function Prototypes */
+diff -Naur wmweather-2.4.7.orig/src/wmweather.c wmweather-2.4.7/src/wmweather.c
+--- wmweather-2.4.7.orig/src/wmweather.c       2019-02-13 20:54:49.000000000 +0100
++++ wmweather-2.4.7/src/wmweather.c    2020-03-29 13:14:57.254963956 +0200
+@@ -56,6 +56,7 @@
+ static void update(int);
+ static size_t curl_callback(void*, size_t, size_t, void*);
++Display *display;
+ CURL
+       *curl       = NULL;
+ static struct memory
index 2109007a6f6d774843c694542c9198be7af7c764..174e4977f14a0e27430157e4771e19cc5434481d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -27,3 +27,10 @@ DOCS=(
        "${WORKDIR}"/${P}/CHANGES
        "${WORKDIR}"/${P}/README
        )
+
+src_prepare() {
+       default
+
+       pushd "${WORKDIR}"/${P} || die
+       eapply "${FILESDIR}"/${P}-fno-common.patch
+}