sys-apps/iproute2: Revbumps to fix automagic dep on sys-libs/libcap
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 29 Oct 2018 22:18:50 +0000 (23:18 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 29 Oct 2018 22:21:06 +0000 (23:21 +0100)
Closes: https://bugs.gentoo.org/667644
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

sys-apps/iproute2/files/iproute2-4.17.0-configure-nomagic.patch [moved from sys-apps/iproute2/files/iproute2-4.16.0-configure-nomagic.patch with 74% similarity]
sys-apps/iproute2/iproute2-4.17.0-r1.ebuild [moved from sys-apps/iproute2/iproute2-4.17.0.ebuild with 95% similarity]
sys-apps/iproute2/iproute2-4.18.0-r1.ebuild [moved from sys-apps/iproute2/iproute2-4.19.0.ebuild with 95% similarity]
sys-apps/iproute2/iproute2-4.19.0-r1.ebuild [moved from sys-apps/iproute2/iproute2-4.18.0.ebuild with 94% similarity]
sys-apps/iproute2/iproute2-9999.ebuild

similarity index 74%
rename from sys-apps/iproute2/files/iproute2-4.16.0-configure-nomagic.patch
rename to sys-apps/iproute2/files/iproute2-4.17.0-configure-nomagic.patch
index 01a1fe2d812f83e792140c69a6795d49081354b1..30b5db3bc3c12291a33c4416d813088463c1148e 100644 (file)
@@ -9,16 +9,17 @@ are only passed when correctly needed.
 
 Prior Gentoo testcase for reproduction:
 USE=minimal ebuild ... compile.
-- Linking with libelf & libmnl based only on presence.
+- Linking with libelf, libmnl & libcap based only on presence.
 - Links based on libselinux based only on presence.
 
 Closes: https://bugs.gentoo.org/643722
 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
 
 Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
+Added libcap to v4.17.0 by Lars Wendler <polynomial-c@gentoo.org>
 
---- iproute2-4.16.0/bridge/Makefile
-+++ iproute2-4.16.0/bridge/Makefile
+--- iproute2-4.17.0/bridge/Makefile
++++ iproute2-4.17.0/bridge/Makefile
 @@ -2,6 +2,7 @@
  BROBJ = bridge.o fdb.o monitor.o link.o mdb.o vlan.o
  
@@ -27,9 +28,9 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  all: bridge
  
---- iproute2-4.16.0/config.include
-+++ iproute2-4.16.0/config.include
-@@ -0,0 +1,22 @@
+--- iproute2-4.17.0/config.include
++++ iproute2-4.17.0/config.include
+@@ -0,0 +1,26 @@
 +# We can only modify CFLAGS/LDLIBS after all the config options are known.
 +ifeq ($(IP_CONFIG_SETNS),y)
 +      CFLAGS += $(IP_CONFIG_SETNS_CFLAGS)
@@ -46,14 +47,18 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
 +      CFLAGS += $(HAVE_MNL_CFLAGS)
 +      LDLIBS += $(HAVE_MNL_LDLIBS)
 +endif
++ifeq ($(HAVE_CAP),y)
++      CFLAGS += $(HAVE_CAP_CFLAGS)
++      LDLIBS += $(HAVE_CAP_LDLIBS)
++endif
 +
 +# Rules can only be declared after all variables in them are known.
 +%.o: %.c
 +      $(QUIET_CC)$(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c -o $@ $<
 +
 +# vim: ft=make:
---- iproute2-4.16.0/configure
-+++ iproute2-4.16.0/configure
+--- iproute2-4.17.0/configure
++++ iproute2-4.17.0/configure
 @@ -212,7 +212,7 @@
      then
        echo "IP_CONFIG_SETNS:=y" >>$CONFIG
@@ -96,6 +101,17 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
        else
                echo "no"
        fi
+@@ -343,8 +343,8 @@
+               echo "HAVE_CAP:=y" >>$CONFIG
+               echo "yes"
+-              echo 'CFLAGS += -DHAVE_LIBCAP' `${PKG_CONFIG} libcap --cflags` >>$CONFIG
+-              echo 'LDLIBS +=' `${PKG_CONFIG} libcap --libs` >> $CONFIG
++              echo 'HAVE_CAP_CFLAGS += -DHAVE_LIBCAP' `${PKG_CONFIG} libcap --cflags` >>$CONFIG
++              echo 'HAVE_CAP_LDLIBS +=' `${PKG_CONFIG} libcap --libs` >> $CONFIG
+       else
+               echo "no"
+       fi
 @@ -426,7 +426,3 @@
  
  echo -n "libcap support: "
@@ -104,8 +120,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
 -echo >> $CONFIG
 -echo "%.o: %.c" >> $CONFIG
 -echo '        $(QUIET_CC)$(CC) $(CFLAGS) $(EXTRA_CFLAGS) -c -o $@ $<' >> $CONFIG
---- iproute2-4.16.0/devlink/Makefile
-+++ iproute2-4.16.0/devlink/Makefile
+--- iproute2-4.17.0/devlink/Makefile
++++ iproute2-4.17.0/devlink/Makefile
 @@ -1,5 +1,6 @@
  # SPDX-License-Identifier: GPL-2.0
  include ../config.mk
@@ -113,8 +129,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  TARGETS :=
  
---- iproute2-4.16.0/genl/Makefile
-+++ iproute2-4.16.0/genl/Makefile
+--- iproute2-4.17.0/genl/Makefile
++++ iproute2-4.17.0/genl/Makefile
 @@ -2,6 +2,7 @@
  GENLOBJ=genl.o
  
@@ -123,8 +139,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  SHARED_LIBS ?= y
  
  CFLAGS += -fno-strict-aliasing
---- iproute2-4.16.0/ip/Makefile
-+++ iproute2-4.16.0/ip/Makefile
+--- iproute2-4.17.0/ip/Makefile
++++ iproute2-4.17.0/ip/Makefile
 @@ -15,6 +15,7 @@
  RTMONOBJ=rtmon.o
  
@@ -133,8 +149,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
---- iproute2-4.16.0/lib/Makefile
-+++ iproute2-4.16.0/lib/Makefile
+--- iproute2-4.17.0/lib/Makefile
++++ iproute2-4.17.0/lib/Makefile
 @@ -1,5 +1,6 @@
  # SPDX-License-Identifier: GPL-2.0
  include ../config.mk
@@ -142,8 +158,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  CFLAGS += -fPIC
  
---- iproute2-4.16.0/misc/Makefile
-+++ iproute2-4.16.0/misc/Makefile
+--- iproute2-4.17.0/misc/Makefile
++++ iproute2-4.17.0/misc/Makefile
 @@ -5,6 +5,7 @@
  TARGETS=ss nstat ifstat rtacct lnstat
  
@@ -152,8 +168,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  ifeq ($(HAVE_BERKELEY_DB),y)
        TARGETS += arpd
---- iproute2-4.16.0/netem/Makefile
-+++ iproute2-4.16.0/netem/Makefile
+--- iproute2-4.17.0/netem/Makefile
++++ iproute2-4.17.0/netem/Makefile
 @@ -1,5 +1,6 @@
  # SPDX-License-Identifier: GPL-2.0
  include ../config.mk
@@ -161,8 +177,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  DISTGEN = maketable normal pareto paretonormal
  DISTDATA = normal.dist pareto.dist paretonormal.dist experimental.dist
---- iproute2-4.16.0/rdma/Makefile
-+++ iproute2-4.16.0/rdma/Makefile
+--- iproute2-4.17.0/rdma/Makefile
++++ iproute2-4.17.0/rdma/Makefile
 @@ -1,5 +1,6 @@
  # SPDX-License-Identifier: GPL-2.0
  include ../config.mk
@@ -170,8 +186,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  TARGETS :=
  
---- iproute2-4.16.0/tc/Makefile
-+++ iproute2-4.16.0/tc/Makefile
+--- iproute2-4.17.0/tc/Makefile
++++ iproute2-4.17.0/tc/Makefile
 @@ -4,6 +4,7 @@
         emp_ematch.yacc.o emp_ematch.lex.o
  
@@ -180,8 +196,8 @@ Forward-ported from v4.14.1 to v4.16.0 by Lars Wendler <polynomial-c@gentoo.org>
  
  SHARED_LIBS ?= y
  
---- iproute2-4.16.0/tipc/Makefile
-+++ iproute2-4.16.0/tipc/Makefile
+--- iproute2-4.17.0/tipc/Makefile
++++ iproute2-4.17.0/tipc/Makefile
 @@ -1,5 +1,6 @@
  # SPDX-License-Identifier: GPL-2.0
  include ../config.mk
similarity index 95%
rename from sys-apps/iproute2/iproute2-4.17.0.ebuild
rename to sys-apps/iproute2/iproute2-4.17.0-r1.ebuild
index 03a8a55c50adc3e7fc4a0da6f43b13344b6cca95..29261b7f6ae1bc4befdb38d3d197238593be73d7 100644 (file)
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
+IUSE="atm berkdb caps elf +iptables ipv6 minimal selinux"
 
 # We could make libmnl optional, but it's tiny, so eh
 RDEPEND="
        !net-misc/arpd
        !minimal? ( net-libs/libmnl )
+       caps? ( sys-libs/libcap )
        elf? ( virtual/libelf )
        iptables? ( >=net-firewall/iptables-1.4.20:= )
        berkdb? ( sys-libs/db:= )
@@ -43,7 +44,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
-       "${FILESDIR}"/${PN}-4.16.0-configure-nomagic.patch # bug 643722
+       "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
 )
 
 src_prepare() {
@@ -100,6 +101,7 @@ src_configure() {
        # We've locked in recent enough kernel headers #549948
        TC_CONFIG_IPSET := y
        HAVE_BERKELEY_DB := $(usex berkdb y n)
+       HAVE_CAP      := $(usex caps y n)
        HAVE_MNL      := $(usex minimal n y)
        HAVE_ELF      := $(usex elf y n)
        HAVE_SELINUX  := $(usex selinux y n)
similarity index 95%
rename from sys-apps/iproute2/iproute2-4.19.0.ebuild
rename to sys-apps/iproute2/iproute2-4.18.0-r1.ebuild
index e35ecc5e6ec17b01f5ee548f3f97192de65c1d62..fe34c36583b5ad1b3b49b74ccba73e349f86a7a0 100644 (file)
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
+IUSE="atm berkdb caps elf +iptables ipv6 minimal selinux"
 
 # We could make libmnl optional, but it's tiny, so eh
 RDEPEND="
        !net-misc/arpd
        !minimal? ( net-libs/libmnl )
+       caps? ( sys-libs/libcap )
        elf? ( virtual/libelf )
        iptables? ( >=net-firewall/iptables-1.4.20:= )
        berkdb? ( sys-libs/db:= )
@@ -43,7 +44,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
-       "${FILESDIR}"/${PN}-4.16.0-configure-nomagic.patch # bug 643722
+       "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
 )
 
 src_prepare() {
@@ -100,6 +101,7 @@ src_configure() {
        # We've locked in recent enough kernel headers #549948
        TC_CONFIG_IPSET := y
        HAVE_BERKELEY_DB := $(usex berkdb y n)
+       HAVE_CAP      := $(usex caps y n)
        HAVE_MNL      := $(usex minimal n y)
        HAVE_ELF      := $(usex elf y n)
        HAVE_SELINUX  := $(usex selinux y n)
similarity index 94%
rename from sys-apps/iproute2/iproute2-4.18.0.ebuild
rename to sys-apps/iproute2/iproute2-4.19.0-r1.ebuild
index 7d284f1e54461a7671a7d5a989f149fcdece5917..fe34c36583b5ad1b3b49b74ccba73e349f86a7a0 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
+IUSE="atm berkdb caps elf +iptables ipv6 minimal selinux"
 
 # We could make libmnl optional, but it's tiny, so eh
 RDEPEND="
        !net-misc/arpd
        !minimal? ( net-libs/libmnl )
+       caps? ( sys-libs/libcap )
        elf? ( virtual/libelf )
        iptables? ( >=net-firewall/iptables-1.4.20:= )
        berkdb? ( sys-libs/db:= )
@@ -43,7 +44,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
-       "${FILESDIR}"/${PN}-4.16.0-configure-nomagic.patch # bug 643722
+       "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
 )
 
 src_prepare() {
@@ -100,6 +101,7 @@ src_configure() {
        # We've locked in recent enough kernel headers #549948
        TC_CONFIG_IPSET := y
        HAVE_BERKELEY_DB := $(usex berkdb y n)
+       HAVE_CAP      := $(usex caps y n)
        HAVE_MNL      := $(usex minimal n y)
        HAVE_ELF      := $(usex elf y n)
        HAVE_SELINUX  := $(usex selinux y n)
index c70b80f7038235231685cb788f6629697aa67578..f9527624933e673b1c2b63b25d55f76608019bd4 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
 
 LICENSE="GPL-2"
 SLOT="0"
-IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
+IUSE="atm caps berkdb elf +iptables ipv6 minimal selinux"
 
 # We could make libmnl optional, but it's tiny, so eh
 RDEPEND="
        !net-misc/arpd
        !minimal? ( net-libs/libmnl )
+       caps? ( sys-libs/libcap )
        elf? ( virtual/libelf )
        iptables? ( >=net-firewall/iptables-1.4.20:= )
        berkdb? ( sys-libs/db:= )
@@ -43,7 +44,7 @@ DEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PN}-3.1.0-mtu.patch #291907
-       "${FILESDIR}"/${PN}-4.14.1-configure-nomagic.patch # bug 643722
+       "${FILESDIR}"/${PN}-4.17.0-configure-nomagic.patch # bug 643722
 )
 
 src_prepare() {
@@ -101,6 +102,7 @@ src_configure() {
        # We've locked in recent enough kernel headers #549948
        TC_CONFIG_IPSET := y
        HAVE_BERKELEY_DB := $(usex berkdb y n)
+       HAVE_CAP      := $(usex caps y n)
        HAVE_MNL      := $(usex minimal n y)
        HAVE_ELF      := $(usex elf y n)
        HAVE_SELINUX  := $(usex selinux y n)