profiles: Remove last-rited media-video/qgifer
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 27 Feb 2018 09:24:10 +0000 (10:24 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 27 Feb 2018 09:24:47 +0000 (10:24 +0100)
Closes: https://bugs.gentoo.org/644558

media-video/qgifer/Manifest [deleted file]
media-video/qgifer/files/qgifer-0.2.1-desktop.patch [deleted file]
media-video/qgifer/files/qgifer-0.2.1-giflib5.patch [deleted file]
media-video/qgifer/files/qgifer-0.2.1-opencv3.patch [deleted file]
media-video/qgifer/metadata.xml [deleted file]
media-video/qgifer/qgifer-0.2.1-r4.ebuild [deleted file]
media-video/qgifer/qgifer-0.2.1-r5.ebuild [deleted file]
profiles/package.mask

diff --git a/media-video/qgifer/Manifest b/media-video/qgifer/Manifest
deleted file mode 100644 (file)
index ff034db..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST qgifer-0.2.1-source.tar.gz 373441 BLAKE2B 7413626484ce3c10995f2b16799104f0ad942de1211455b47d2780828b2f77c58d8a20fd3f44def8a3710129b626bd4961adc4e186abcfc7e2095e6b7e5a3086 SHA512 ce48e5756cbab283d5894ddb369114e52c9cedc2fe15aed5d22aeeacc822058123d3a2f3c9a6eddf94a1eef992c3ddcad77d6941c76ba0c795c8b44209fac7df
diff --git a/media-video/qgifer/files/qgifer-0.2.1-desktop.patch b/media-video/qgifer/files/qgifer-0.2.1-desktop.patch
deleted file mode 100644 (file)
index 8e02163..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: doc/qgifer.desktop
-===================================================================
---- a/doc/qgifer.desktop       (revision 91)
-+++ b/doc/qgifer.desktop       (working copy)
-@@ -3,7 +3,7 @@
- Name=QGifer
- Icon=/usr/share/icons/qgifer.xpm
- Type=Application
--Categories=Graphics;2DGraphics;RasterGraphics;Video;
-+Categories=Graphics;2DGraphics;RasterGraphics;Video;AudioVideo;
- Comment=A video-based animated GIF creator
- GenericName=A video-based animated GIF creator
- Comment[pl]=Narzędzie do tworzenia animowanych plików GIF
diff --git a/media-video/qgifer/files/qgifer-0.2.1-giflib5.patch b/media-video/qgifer/files/qgifer-0.2.1-giflib5.patch
deleted file mode 100644 (file)
index 9ddfdac..0000000
+++ /dev/null
@@ -1,157 +0,0 @@
-Port qgifer to giflib 5 API.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=536634
-
---- a/src/gifcreator.cpp
-+++ b/src/gifcreator.cpp
-@@ -38,7 +38,7 @@
-                   j--;
-              }
-      for(int i=0;i<cmaps.size();i++)
--        FreeMapObject(cmaps[i]);
-+        GifFreeMapObject(cmaps[i]);
- }
-@@ -52,7 +52,7 @@
-      }
-   
-   
--     GifFileType *GifFile = EGifOpenFileName(filename, FALSE);
-+     GifFileType *GifFile = EGifOpenFileName(filename, 0, NULL);
-   
-      if (!GifFile){
-         PrintGifError();
-@@ -74,7 +74,7 @@
-      {
-         char nsle[12] = "NETSCAPE2.0";
-         char subblock[3];
--        if (EGifPutExtensionFirst(GifFile, APPLICATION_EXT_FUNC_CODE, 11, nsle) == GIF_ERROR) {
-+        if (EGifPutExtension(GifFile, APPLICATION_EXT_FUNC_CODE, 11, nsle) == GIF_ERROR) {
-              PrintGifError();
-              return false;
-         }
-@@ -82,7 +82,7 @@
-         subblock[2] = loop_count % 256;
-         subblock[1] = loop_count / 256;
--        if (EGifPutExtensionLast(GifFile, APPLICATION_EXT_FUNC_CODE, 3, subblock) == GIF_ERROR) {
-+        if (EGifPutExtension(GifFile, APPLICATION_EXT_FUNC_CODE, 3, subblock) == GIF_ERROR) {
-              PrintGifError();
-              return false;
-         }
-@@ -111,7 +111,7 @@
-             
-         if (EGifPutImageDesc(
-                  GifFile,
--                 0, 0, w, h, FALSE, cmaps.size() > ni ? cmaps.at(ni) : cmaps.at(cmaps.size()-1)
-+                 0, 0, w, h, 0, cmaps.size() > ni ? cmaps.at(ni) : cmaps.at(cmaps.size()-1)
-                  ) == GIF_ERROR) {
-              PrintGifError();
-              endProgress();
-@@ -135,7 +135,7 @@
-         return false;
-      }
-    
--     if (EGifCloseFile(GifFile) == GIF_ERROR) {
-+     if (EGifCloseFile(GifFile, NULL) == GIF_ERROR) {
-         PrintGifError();
-         endProgress();
-         return false;
---- a/src/gifcreator.h
-+++ b/src/gifcreator.h
-@@ -31,6 +31,12 @@
- typedef vector<GifByteType> Frame;
- typedef unsigned char Byte;
-+static inline void
-+PrintGifError()
-+{
-+      fprintf(stderr, "\nGIF-LIB error: %s.\n", GifErrorString(GIF_ERROR));
-+}
-+
- class GifCreator
- {
---- a/src/palettewidget.cpp
-+++ b/src/palettewidget.cpp
-@@ -34,7 +34,7 @@
- PaletteWidget::~PaletteWidget()
- {
--     FreeMapObject(palette);
-+     GifFreeMapObject(palette);
- }
- void PaletteWidget::paintEvent(QPaintEvent*)
-@@ -117,7 +117,7 @@
-      if(palette && mindiff > 1)
-      {
-         qDebug() << "deleting old palette, size: " << size << ", colors: " << palette->ColorCount;
--        FreeMapObject(palette);
-+        GifFreeMapObject(palette);
-         qDebug() << "done";
-         palette = NULL;
-      }
-@@ -157,7 +157,7 @@
-      }
-      ColorMapObject* previous = palette;
--     palette = MakeMapObject(size, NULL);
-+     palette = GifMakeMapObject(size, NULL);
-      if (!palette) 
-      {
-         qDebug() << "NULL palette!";
-@@ -165,7 +165,7 @@
-      }
-      
--     if (QuantizeBuffer(fimg.width(), fimg.height(), &size, 
-+     if (GifQuantizeBuffer(fimg.width(), fimg.height(), &size, 
-                       &(r[0]),&(g[0]),&(b[0]), &(output[0]), 
-                       palette->Colors) == GIF_ERROR) 
-      {
-@@ -178,11 +178,11 @@
-      //qDebug() << "difference: " << df;
-      if(previous && df < mindiff)
-      {
--        FreeMapObject(palette);
-+        GifFreeMapObject(palette);
-         palette = previous;
-      }
-      else if(df >= mindiff)
--        FreeMapObject(previous);
-+        GifFreeMapObject(previous);
-      // qDebug() << "palette (" << palette->ColorCount << ") :";
-      // for(int i=0;i<size;i++)
-@@ -230,8 +230,8 @@
- {
-      QStringList rgb = QString(str).split(";", QString::SkipEmptyParts);
-      if(palette)
--        FreeMapObject(palette);
--     palette = MakeMapObject(rgb.size(), NULL);
-+        GifFreeMapObject(palette);
-+     palette = GifMakeMapObject(rgb.size(), NULL);
-      if(!palette)
-         return false;
-      size = rgb.size();
---- a/src/palettewidget.h
-+++ b/src/palettewidget.h
-@@ -30,7 +30,7 @@
-      PaletteWidget(QWidget* parent=0, Qt::WindowFlags f=0);
-      virtual ~PaletteWidget();
-      ColorMapObject* map() {return palette;}
--     ColorMapObject* mapCopy() {return MakeMapObject(palette->ColorCount, palette->Colors);}
-+     ColorMapObject* mapCopy() {return GifMakeMapObject(palette->ColorCount, palette->Colors);}
-      bool fromImage(const QImage& img, int palette_size, float mindiff = 2);
-      void setColumnCount(int cc){cols = cc;}
-      bool toFile(const QString& path);
-@@ -38,7 +38,7 @@
-      QString toString();
-      bool fromString(const QString& str);
-      int getSize() const {return size;}
--     void clear() {if(palette) FreeMapObject(palette); palette = NULL; update();}
-+     void clear() {if(palette) GifFreeMapObject(palette); palette = NULL; update();}
- private:
-      int size;
-      int cols;
diff --git a/media-video/qgifer/files/qgifer-0.2.1-opencv3.patch b/media-video/qgifer/files/qgifer-0.2.1-opencv3.patch
deleted file mode 100644 (file)
index 89c79ff..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur qgifer-0.2.1-source/CMakeLists.txt qgifer-0.2.1-modified/CMakeLists.txt
---- qgifer-0.2.1-source/CMakeLists.txt 2013-06-04 18:33:16.000000000 +0200
-+++ qgifer-0.2.1-modified/CMakeLists.txt       2015-12-19 20:58:13.772808845 +0100
-@@ -35,7 +35,7 @@
-       SET(GIF_INCLUDE_DIR "C:\\Program Files\\GnuWin32\\include")
- ENDIF(WIN32)
--FIND_PACKAGE( OpenCV REQUIRED core highgui imgproc )
-+FIND_PACKAGE( OpenCV REQUIRED core highgui imgproc videoio)
- FIND_PACKAGE(Qt4 REQUIRED)
- FIND_PACKAGE(GIF REQUIRED)
-@@ -148,9 +148,9 @@
- QT4_ADD_RESOURCES(RESOURCES_RCC ${RESOURCES})
- IF(WIN32)
--      SET( OPENCV_LIBS "-lopencv_core244 -lopencv_highgui244 -lopencv_imgproc244" )
-+      SET( OPENCV_LIBS "-lopencv_core244 -lopencv_highgui244 -lopencv_imgproc244 -lopencv_videoio244" )
- ELSE(WIN32)
--      SET( OPENCV_LIBS "-lopencv_core -lopencv_highgui -lopencv_imgproc" )
-+      SET( OPENCV_LIBS "-lopencv_core -lopencv_highgui -lopencv_imgproc -lopencv_videoio" )
- ENDIF(WIN32)
- SET( GIF_LIBS "-lgif" )       
-@@ -207,7 +207,7 @@
- #SET(CPACK_SOURCE_PACKAGE_FILE_NAME "${PACKAGE_NAME}_${QGIFER_VERSION_MAJOR}.${QGIFER_VERSION_MINOR}.${QGIFER_VERSION_PATCH}")
-  
- #set(CPACK_DEBIAN_PACKAGE_SHLIBDEPS ON) #za pierwszym razem, pozniej dodano | dla nowszych opencv
--SET(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6 (>= 2.1.3), libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libgif4 (>= 4.1.4), libopencv-core2.3 | libopencv-core2.4, libopencv-highgui2.3 | libopencv-highgui2.4, libopencv-imgproc2.3 | libopencv-imgproc2.4, libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 4.1.1)")
-+SET(CPACK_DEBIAN_PACKAGE_DEPENDS "libc6 (>= 2.1.3), libc6 (>= 2.3.6-6~), libgcc1 (>= 1:4.1.1), libgif4 (>= 4.1.4), libopencv-core2.3 | libopencv-core2.4 | libopencv-core3.0, libopencv-highgui2.3 | libopencv-highgui2.4 | libopencv-highgui3.0, libopencv-imgproc2.3 | libopencv-imgproc2.4 | libopencv-imgproc3.0, libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.6.1), libstdc++6 (>= 4.1.1)")
-  
- SET(CPACK_DEBIAN_PACKAGE_PRIORITY "optional")
- SET(CPACK_DEBIAN_PACKAGE_SECTION "video")
-diff -Naur qgifer-0.2.1-source/src/frameplayer.h qgifer-0.2.1-modified/src/frameplayer.h
---- qgifer-0.2.1-source/src/frameplayer.h      2013-06-04 18:14:55.000000000 +0200
-+++ qgifer-0.2.1-modified/src/frameplayer.h    2015-12-19 21:01:44.419870869 +0100
-@@ -23,6 +23,7 @@
- #include <opencv2/core/core.hpp>
- #include <opencv2/highgui/highgui.hpp>
- #include <opencv2/imgproc/imgproc.hpp>
-+#include <opencv2/videoio/videoio.hpp>
- #include <QWidget>
- #include <QImage>
- #include <QStatusBar>
diff --git a/media-video/qgifer/metadata.xml b/media-video/qgifer/metadata.xml
deleted file mode 100644 (file)
index ec2e60d..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="person">
-               <email>andrzej.pauli@gmail.com</email>
-               <name>Andrzej Pauli</name>
-       </maintainer>
-       <maintainer type="project">
-               <email>proxy-maint@gentoo.org</email>
-               <name>Proxy Maintainers</name>
-       </maintainer>
-       <longdescription lang="en">
-               QGifer is a tool for extracting part of a video to an animated GIF file.
-       </longdescription>
-       <use>
-               <flag name="imagemagick">Use imagemagick for image operations</flag>
-               <flag name="opencv3">Use media-libs/opencv:0/3.0 for video operations instead media-libs/opencv:0/2.4</flag>
-       </use>
-       <upstream>
-               <remote-id type="sourceforge">qgifer</remote-id>
-       </upstream>
-</pkgmetadata>
diff --git a/media-video/qgifer/qgifer-0.2.1-r4.ebuild b/media-video/qgifer/qgifer-0.2.1-r4.ebuild
deleted file mode 100644 (file)
index 02e746b..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit cmake-utils
-
-DESCRIPTION="A video-based animated GIF creator"
-HOMEPAGE="https://sourceforge.net/projects/qgifer/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug imagemagick opencv3"
-
-RDEPEND="<media-libs/giflib-4.2.3:0
-       dev-qt/qtcore:4
-       dev-qt/qtgui:4
-       imagemagick? ( media-gfx/imagemagick:0 )
-       !opencv3? ( <media-libs/opencv-3.0.0:0[ffmpeg] )
-       opencv3? ( >=media-libs/opencv-3.0.0:0[ffmpeg] )
-       virtual/ffmpeg:0"
-
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}-source"
-
-PATCHES=( "${FILESDIR}/${P}-desktop.patch" )
-
-src_prepare(){
-       use opencv3 && PATCHES+=( "${FILESDIR}/${P}-opencv3.patch" )
-
-       cmake-utils_src_prepare
-
-       # Fix the doc path
-       sed -i -e "s|share/doc/qgifer|share/doc/${PF}|" CMakeLists.txt || die
-}
-
-src_configure() {
-       local mycmakeargs
-
-       use debug && mycmakeargs=( -DRELEASE_MODE=OFF )
-
-       cmake-utils_src_configure
-}
diff --git a/media-video/qgifer/qgifer-0.2.1-r5.ebuild b/media-video/qgifer/qgifer-0.2.1-r5.ebuild
deleted file mode 100644 (file)
index a027d20..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A video-based animated GIF creator"
-HOMEPAGE="https://sourceforge.net/projects/qgifer/"
-SRC_URI="mirror://sourceforge/${PN}/${P}-source.tar.gz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug imagemagick opencv3"
-
-RDEPEND="
-       >=media-libs/giflib-5.1:=
-       dev-qt/qtcore:4
-       dev-qt/qtgui:4
-       virtual/ffmpeg:0
-       imagemagick? ( media-gfx/imagemagick:0 )
-       !opencv3? ( <media-libs/opencv-3.0.0:0=[ffmpeg] )
-       opencv3? ( >=media-libs/opencv-3.0.0:0=[ffmpeg] )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${P}-source"
-
-PATCHES=(
-       "${FILESDIR}/${P}-desktop.patch"
-       # Port to giflib 5 API
-       "${FILESDIR}/${P}-giflib5.patch"
-)
-
-src_prepare(){
-       use opencv3 && PATCHES+=( "${FILESDIR}/${P}-opencv3.patch" )
-       cmake-utils_src_prepare
-
-       # Fix the doc path
-       sed -i -e "s|share/doc/qgifer|share/doc/${PF}|" CMakeLists.txt || die
-}
-
-src_configure() {
-       local mycmakeargs=(
-                $(usex debug '-DRELEASE_MODE=OFF' '')
-       )
-       cmake-utils_src_configure
-}
index a0cbe10a5838649dce34405b9b504bd86465b609..39777e7f94590bc7ea65459ea6349cb9fb7da937 100644 (file)
@@ -207,11 +207,6 @@ media-sound/qtagconvert
 # Masked for removal in 30 days. Bug #644516
 media-sound/qpitch
 
-# Andreas Sturmlechner <asturm@gentoo.org> (28 Jan 2018)
-# Dead upstream, depends on deprecated Qt4.
-# Masked for removal in 30 days. Bug #644558
-media-video/qgifer
-
 # Patrice Clement <monsieurp@gentoo.org> (26 Jan 2018)
 # Has different symbols. Known to cause issues with i3bar/swaybar.
 media-fonts/fontawesome:0/5