sci-mathematics/coq: migrate from dev-tex/xcolor
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 4 Nov 2019 12:14:22 +0000 (15:14 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 4 Nov 2019 12:19:24 +0000 (15:19 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
sci-mathematics/coq/Manifest
sci-mathematics/coq/coq-8.6.1-r1.ebuild [moved from sci-mathematics/coq/coq-8.6.1.ebuild with 96% similarity]
sci-mathematics/coq/coq-8.6.ebuild [deleted file]
sci-mathematics/coq/coq-8.9.1-r1.ebuild [moved from sci-mathematics/coq/coq-8.9.1.ebuild with 97% similarity]

index 758414ac5b918218c22e842126ac8c8967756cda..c5c6ccba31b5c5b7872128aa0940e20d003b657b 100644 (file)
@@ -1,3 +1,2 @@
 DIST coq-8.6.1.tar.gz 5588811 BLAKE2B 1016e54ef9b42a8534add55ab057454fad35b3fe103ba877689489c7d9cf43d76c1fbee123801d91035d353a882120650f94c433d9ee1daa878b8c819609c949 SHA512 814ab76a06ca15f927081428da74add4bc67290199fa011853b9c68a00cdefaf813b10fbac18a434f4504fce8f2173eb544080bf6f50d62caa41bb8724b13083
-DIST coq-8.6.tar.gz 5538848 BLAKE2B 025d6598a5155712662ce20a56804b75c236f1d1dc4ed81e779aaf2916d5cb525acfcbef9b5960fc5b8b44f2e2290c9f7e5c2d6e84726400a9888587ee29cd16 SHA512 9f5f4913fda8cf83683fec9398b42d4567207c3d4b52b4638d5e09a24ed25a43905fb57a9fac1bb9f9d681bd47f3560e1da74e79348b3a3fd93e2e8c686cebae
 DIST coq-8.9.1.tar.gz 6001970 BLAKE2B f65498e2485c59f4f95d2afeac35750ebf85b5af6db7c269a11635f2414df483d4cb159557060c9118de25f4922176f54d2e5c6f12174599371348341cb4d80f SHA512 66344f801b955d1b6daf3ab1d704551070c95cf9032ae74f15fb33f7ec313812b3e05c0ec277a2eb448e3fdfd9721df06d36612e2fb4928b6530d70147f1d983
similarity index 96%
rename from sci-mathematics/coq/coq-8.6.1.ebuild
rename to sci-mathematics/coq/coq-8.6.1-r1.ebuild
index b07f22863ef77da859ae15ef8ecb157a3bebd9a0..2c9f5df9141690fc658da92df27afb805fb6a323 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
                media-libs/netpbm[png,zlib]
                virtual/latex-base
                dev-tex/hevea
-               dev-tex/xcolor
+               dev-texlive/texlive-latexrecommended
                dev-texlive/texlive-pictures
                dev-texlive/texlive-mathscience
                dev-texlive/texlive-latexextra
diff --git a/sci-mathematics/coq/coq-8.6.ebuild b/sci-mathematics/coq/coq-8.6.ebuild
deleted file mode 100644 (file)
index b06ed6d..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils multilib
-
-MY_PV=${PV/_p/pl}
-MY_P=${PN}-${MY_PV}
-
-DESCRIPTION="Proof assistant written in O'Caml"
-HOMEPAGE="http://coq.inria.fr/"
-SRC_URI="http://${PN}.inria.fr/distrib/V${MY_PV}/files/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="gtk debug +ocamlopt doc camlp5"
-
-RDEPEND="
-       >=dev-lang/ocaml-3.11.2:=[ocamlopt?]
-       camlp5? ( >=dev-ml/camlp5-6.02.3:=[ocamlopt?] )
-       !camlp5? ( dev-ml/camlp4:= )
-       gtk? ( >=dev-ml/lablgtk-2.10.1:=[sourceview,ocamlopt?] )"
-DEPEND="${RDEPEND}
-       dev-ml/findlib
-       doc? (
-               media-libs/netpbm[png,zlib]
-               virtual/latex-base
-               dev-tex/hevea
-               dev-tex/xcolor
-               dev-texlive/texlive-pictures
-               dev-texlive/texlive-mathscience
-               dev-texlive/texlive-latexextra
-               )"
-
-S=${WORKDIR}/${MY_P}
-
-src_configure() {
-       ocaml_lib=$(ocamlc -where)
-       local myconf=(
-               -prefix /usr
-               -bindir /usr/bin
-               -libdir /usr/$(get_libdir)/coq
-               -mandir /usr/share/man
-               -emacslib /usr/share/emacs/site-lisp
-               -coqdocdir /usr/$(get_libdir)/coq/coqdoc
-               -docdir /usr/share/doc/${PF}
-               -configdir /etc/xdg/${PN}
-               -lablgtkdir ${ocaml_lib}/lablgtk2
-               )
-
-       use debug && myconf+=( -debug )
-       use doc || myconf+=( -with-doc no )
-
-       if use gtk; then
-               if use ocamlopt; then
-                       myconf+=( -coqide opt )
-               else
-                       myconf+=( -coqide byte )
-               fi
-       else
-               myconf+=( -coqide no )
-       fi
-
-       use ocamlopt || myconf+=( -byte-only )
-
-       if use camlp5; then
-               myconf+=( -usecamlp5 -camlp5dir ${ocaml_lib}/camlp5 )
-       else
-               myconf+=( -usecamlp4 )
-       fi
-
-       export CAML_LD_LIBRARY_PATH="${S}/kernel/byterun/"
-       ./configure ${myconf[@]} || die "configure failed"
-}
-
-src_compile() {
-       emake STRIP="true" -j1 world VERBOSE=1
-}
-
-src_test() {
-       emake STRIP="true" check VERBOSE=1
-}
-
-src_install() {
-       emake STRIP="true" COQINSTALLPREFIX="${D}" install VERBOSE=1
-       dodoc README.md CREDITS CHANGES
-
-       use gtk && make_desktop_entry "coqide" "Coq IDE" "${EPREFIX}/usr/share/coq/coq.png"
-}
similarity index 97%
rename from sci-mathematics/coq/coq-8.9.1.ebuild
rename to sci-mathematics/coq/coq-8.9.1-r1.ebuild
index a7de5198ee4cc7d59a56a4bb582856ae6f2766be..d110241bb5001f7df22078a5cd0a204c19030756 100644 (file)
@@ -30,7 +30,7 @@ DEPEND="${RDEPEND}
                media-libs/netpbm[png,zlib]
                virtual/latex-base
                dev-tex/hevea
-               dev-tex/xcolor
+               dev-texlive/texlive-latexrecommended
                dev-texlive/texlive-pictures
                dev-texlive/texlive-mathscience
                dev-texlive/texlive-latexextra