net-dialup/accel-ppp: version bump, sync live ebuilds
authorSergey Popov <pinkbyte@gentoo.org>
Wed, 21 Mar 2018 12:49:36 +0000 (15:49 +0300)
committerSergey Popov <pinkbyte@gentoo.org>
Wed, 21 Mar 2018 12:51:54 +0000 (15:51 +0300)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

net-dialup/accel-ppp/Manifest
net-dialup/accel-ppp/accel-ppp-1.11.1_p20180320.ebuild [new file with mode: 0644]
net-dialup/accel-ppp/accel-ppp-1.11.9999.ebuild
net-dialup/accel-ppp/accel-ppp-9999.ebuild

index 5a31e3bd01a1e4fe71b449e7171d06bdb8d727cb..8f25dd71aafb67418be18228192b14f1f7160275 100644 (file)
@@ -1,2 +1,3 @@
 DIST accel-ppp-1.11.0.tar.bz2 1594327 BLAKE2B f23d8e4f68837e6394136013ce3e65705990f7cf15822a2939c36d00eae49d33c8b88db56629d78a5092b994256fee9859dbb3547484b8800f7fad8d0866e45f SHA512 907b484e73a4d70757a3991e6f33873aad5f10f6d5180307ee2f3eb0caacc576795d0e9c7666172a00842e6d31563503250f0e8165f6adb2bc88a1270814ea3c
 DIST accel-ppp-1.11.1_p20170508.tar.bz2 1609904 BLAKE2B 5993e25e09e84fa62fde28e6c79b11514eb5e0c365a8cc1a36c4e3e56ac868725b14049e28184188330ac78cb6c128429f2cc89241d871c02e4154c6882a89e2 SHA512 79f928c9d07891957d12443eaf32e96e826d5bebf241dcfcb31a7777fbce2332078bf0c1dd1e1a55cf96154be1fec610f1afd088fc018f54ebd5d265c037c07a
+DIST accel-ppp-1.11.1_p20180320.tar.bz2 1634359 BLAKE2B 97ca709ef3740c2ac1d75f6fba3acbf9229c3cb48f3a55735eaa14b74c2b0af96d637cbb145bc9e98a5b245704806cdc3d8f9d8692809626e0f73d73702c4a0a SHA512 a8a2420332c02087e45bbaab25831ae5d2d370fd56b29db77c267083badc22b90ca4b0ec7335e13250ac8f150002b2a3c343cfba6c2378932778777dc936d914
diff --git a/net-dialup/accel-ppp/accel-ppp-1.11.1_p20180320.ebuild b/net-dialup/accel-ppp/accel-ppp-1.11.1_p20180320.ebuild
new file mode 100644 (file)
index 0000000..c8c6d3c
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils flag-o-matic linux-info linux-mod
+
+DESCRIPTION="High performance PPTP, PPPoE and L2TP server"
+HOMEPAGE="http://accel-ppp.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/snapshots/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc ipoe lua postgres radius shaper snmp valgrind"
+
+RDEPEND="lua? ( dev-lang/lua:0 )
+       postgres? ( dev-db/postgresql:* )
+       snmp? ( net-analyzer/net-snmp )
+       dev-libs/libpcre
+       dev-libs/openssl:0"
+DEPEND="${RDEPEND}
+       valgrind? ( dev-util/valgrind )"
+PDEPEND="net-dialup/ppp-scripts"
+
+DOCS=( README )
+
+CONFIG_CHECK="~L2TP ~PPPOE ~PPTP"
+
+REQUIRED_USE="valgrind? ( debug )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-1.11.1-socklen.patch"
+)
+
+S="${WORKDIR}"
+
+pkg_setup() {
+       if use ipoe; then
+               linux-mod_pkg_setup
+               set_arch_to_kernel
+       else
+               linux-info_pkg_setup
+       fi
+}
+
+src_prepare() {
+       sed -i  -e "/mkdir/d" \
+               -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
+
+       # Do not install kernel modules like that - breaks sandbox!
+       sed -i -e '/modules_install/d' \
+               drivers/ipoe/CMakeLists.txt \
+               drivers/vlan_mon/CMakeLists.txt || die
+
+       # Bug #549918
+       append-ldflags -Wl,-z,lazy
+
+       cmake-utils_src_prepare
+}
+
+src_configure() {
+       local libdir="$(get_libdir)"
+       # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
+       local mycmakeargs=(
+               -DLIB_SUFFIX="${libdir#lib}"
+               -DBUILD_IPOE_DRIVER="$(usex ipoe)"
+               -DBUILD_PPTP_DRIVER=no
+               -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
+               -DCRYPTO=OPENSSL
+               -DLOG_PGSQL="$(usex postgres)"
+               -DLUA="$(usex lua)"
+               -DMEMDEBUG="$(usex debug)"
+               -DNETSNMP="$(usex snmp)"
+               -DRADIUS="$(usex radius)"
+               -DSHAPER="$(usex shaper)"
+               $(use debug && echo "-DVALGRIND=$(usex valgrind)")
+       )
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cmake-utils_src_compile
+}
+
+src_install() {
+       if use ipoe; then
+               local MODULE_NAMES="ipoe(accel-ppp:${BUILD_DIR}/drivers/ipoe/driver) vlan_mon(accel-ppp:${BUILD_DIR}/drivers/vlan_mon/driver)"
+               linux-mod_src_install
+       fi
+
+       cmake-utils_src_install
+
+       use doc && dodoc -r rfc
+
+       if use snmp; then
+               insinto /usr/share/snmp/mibs
+               doins accel-pppd/extra/net-snmp/ACCEL-PPP-MIB.txt
+       fi
+
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}d
+       newconfd "${FILESDIR}"/${PN}.confd ${PN}d
+
+       dodir /var/log/accel-ppp
+}
index f4c53dbb43ea01da5760cd9b9fa24fd26105dd8a..fa1729fe08974468a0fe9437b470abf761f1fffa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -42,7 +42,6 @@ pkg_setup() {
 
 src_prepare() {
        sed -i  -e "/mkdir/d" \
-               -e "/echo/d" \
                -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
 
        # Do not install kernel modules like that - breaks sandbox!
@@ -60,17 +59,18 @@ src_configure() {
        local libdir="$(get_libdir)"
        # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
        local mycmakeargs=(
-               -DLIB_PATH_SUFFIX="${libdir#lib}"
+               -DLIB_SUFFIX="${libdir#lib}"
                -DBUILD_IPOE_DRIVER="$(usex ipoe)"
                -DBUILD_PPTP_DRIVER=no
                -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
                -DCRYPTO=OPENSSL
                -DLOG_PGSQL="$(usex postgres)"
+               -DLUA="$(usex lua)"
                -DMEMDEBUG="$(usex debug)"
                -DNETSNMP="$(usex snmp)"
                -DRADIUS="$(usex radius)"
                -DSHAPER="$(usex shaper)"
-               -DVALGRIND="$(usex valgrind)"
+               $(use debug && echo "-DVALGRIND=$(usex valgrind)")
        )
        cmake-utils_src_configure
 }
index 0630264eef34adf4cb92ddb6fdd8bf6702134d2c..cbb628950c2345ff5374b5f8929aa6185f90f4c9 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -41,7 +41,6 @@ pkg_setup() {
 
 src_prepare() {
        sed -i  -e "/mkdir/d" \
-               -e "/echo/d" \
                -e "s: RENAME accel-ppp.conf.dist::" accel-pppd/CMakeLists.txt || die 'sed on accel-pppd/CMakeLists.txt failed'
 
        # Do not install kernel modules like that - breaks sandbox!
@@ -59,17 +58,18 @@ src_configure() {
        local libdir="$(get_libdir)"
        # There must be also dev-libs/tomcrypt (TOMCRYPT) as crypto alternative to OpenSSL
        local mycmakeargs=(
-               -DLIB_PATH_SUFFIX="${libdir#lib}"
+               -DLIB_SUFFIX="${libdir#lib}"
                -DBUILD_IPOE_DRIVER="$(usex ipoe)"
                -DBUILD_PPTP_DRIVER=no
                -DBUILD_VLAN_MON_DRIVER="$(usex ipoe)"
                -DCRYPTO=OPENSSL
                -DLOG_PGSQL="$(usex postgres)"
+               -DLUA="$(usex lua)"
                -DMEMDEBUG="$(usex debug)"
                -DNETSNMP="$(usex snmp)"
                -DRADIUS="$(usex radius)"
                -DSHAPER="$(usex shaper)"
-               -DVALGRIND="$(usex valgrind)"
+               $(use debug && echo "-DVALGRIND=$(usex valgrind)")
        )
        cmake-utils_src_configure
 }