app-emulation/containerd: 1.3.4 bump
authorWilliam Hubbs <williamh@gentoo.org>
Thu, 16 Apr 2020 22:10:32 +0000 (17:10 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Thu, 16 Apr 2020 22:10:32 +0000 (17:10 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-emulation/containerd/Manifest
app-emulation/containerd/containerd-1.3.4.ebuild [new file with mode: 0644]

index c55dea94df16b08aa31eacfc7be307d7fa351957..50dea9321e920a6109909f5fdece6900006e7c54 100644 (file)
@@ -6,3 +6,4 @@ DIST containerd-1.2.7.tar.gz 4877757 BLAKE2B 6cf98e370547d3ca5158f546e72e3ff5fdc
 DIST containerd-1.3.0.tar.gz 5697153 BLAKE2B c334cfd2aa11dd430c74bc9f3fe6f31d83faf752b9794da26021033bb6af492c48ed1665fc76ddfe5b858f04d45e9b77505f331e3c3da556af2d75e3cca3bb12 SHA512 cff9f0189b9fdc2b5492c92129af284aa8cd099e48de94cafd90aed191e2d20060c96008111b05fe081de0d4fc41d35f8cba5a3dc2d8cc0a5c37f695fd3cedc1
 DIST containerd-1.3.1.tar.gz 5703741 BLAKE2B 6eae3fe9714128e7a5378484115378629baf6c4f7ef4b795e625cc1fbc05323a123c2337c5b203a2c3c3b34486c81f7e5b3ad200c000c961931fc99347ef4513 SHA512 4991286d1a8a221dad24121c5e6cd31a00685d91e652546d0d97745624486450bc05ff4f889f2975c178c4c175fedd7b15f89121a7ce4e6687919aabd04501b4
 DIST containerd-1.3.2.tar.gz 5704320 BLAKE2B 32ea22ff445cc66f4c8db8abdbaaa7fa0c8c620b294bda54f2319045af1925398057ba1a5cb5c265cfc73bcff5b49943013b517ecb3bd05f4504920c4a8d6f29 SHA512 768a19eb0829e196a61ddedaa11b0d6691caf8f9cc590a3e47ac77c1acad62e64b7a55017a1a6cccfcb87785a083d5ce131048b0e39e48c65e6cd5922382fc3c
+DIST containerd-1.3.4.tar.gz 5700890 BLAKE2B 9d5642399eafbf3df25d2bdb6ffeb8e98362e9f2c6cdcd7a64fff12bad40f58fa97451228a607def408cc8a8cfbfce67c47fcfdf86865d8086d0b7aad7595d5a SHA512 b186d5aef3e5a0d35c12dcc3cfa5d48a9602f6278c4650942859a1ab6abd1299d33a1bc623376955a834a2626491196b604591d92a05d39745dfc33ff51ad5aa
diff --git a/app-emulation/containerd/containerd-1.3.4.ebuild b/app-emulation/containerd/containerd-1.3.4.ebuild
new file mode 100644 (file)
index 0000000..4733a84
--- /dev/null
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+EGO_PN="github.com/containerd/${PN}"
+inherit toolchain-funcs
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+
+if [[ ${PV} == *9999 ]]; then
+       inherit golang-vcs
+else
+       MY_PV="${PV/_rc/-rc.}"
+       EGIT_COMMIT="v${MY_PV}"
+       CONTAINERD_COMMIT=814b7956
+       SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+       inherit golang-vcs-snapshot
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="apparmor btrfs +cri hardened +seccomp"
+
+DEPEND="btrfs? ( sys-fs/btrfs-progs )
+       seccomp? ( sys-libs/libseccomp )"
+RDEPEND=">=app-emulation/runc-1.0.0_rc9
+       seccomp? ( sys-libs/libseccomp )"
+
+S=${WORKDIR}/${P}/src/${EGO_PN}
+
+RESTRICT="strip test"
+
+src_prepare() {
+       default
+       if [[ ${PV} != *9999* ]]; then
+               sed -i -e "s/git describe --match.*$/echo ${PV})/"\
+                       -e "s/git rev-parse HEAD.*$/echo $CONTAINERD_COMMIT)/"\
+                       -e "s/-s -w//" \
+                       Makefile || die
+       fi
+}
+
+src_compile() {
+       local options=( $(usex btrfs "" "no_btrfs") $(usex cri "" "no_cri") $(usex seccomp "seccomp" "") $(usex apparmor "apparmor" "") )
+       export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor
+       LDFLAGS=$(usex hardened '-extldflags -fno-PIC' '') BUILDTAGS="${options[@]}" emake
+}
+
+src_install() {
+       newinitd "${FILESDIR}"/${PN}.initd ${PN}
+       keepdir /var/lib/containerd
+       dobin bin/*
+}