Fixed building with seamonkey useflag - bugs #156716 and #155725. Thanks to Jorge...
authorVlastimil Babka <caster@gentoo.org>
Fri, 1 Dec 2006 00:40:33 +0000 (00:40 +0000)
committerVlastimil Babka <caster@gentoo.org>
Fri, 1 Dec 2006 00:40:33 +0000 (00:40 +0000)
Package-Manager: portage-2.1.2_rc2-r3

dev-java/swt/ChangeLog
dev-java/swt/swt-3.2.1.ebuild

index bc6414865b3f0eae6f4d1a02e97ddc4355b33e92..97f84c47e7e00e94c8f8fb6b697422891745f4b5 100644 (file)
@@ -1,6 +1,23 @@
 # ChangeLog for dev-java/swt
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.53 2006/11/20 01:02:33 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/ChangeLog,v 1.54 2006/12/01 00:40:33 caster Exp $
+
+  01 Dec 2006; Vlastimil Babka <caster@gentoo.org>
+  -files/swt-3.2.1-firefox.patch, -files/swt-3.2.1-libswt-xpcomgcc4.patch,
+  -files/swt-3.2.1-remove-stripping.patch,
+  +files/patches-3.2.1/10_all_gcc-4.x-warning-fix.patch,
+  +files/patches-3.2.1/20_all_remove-stripping.patch,
+  +files/patches-3.2.1/30_amd64_libswt-xpcomgcc4.patch,
+  +files/patches-3.2.1/30_x86_libswt-xpcomgcc4.patch,
+  +files/patches-3.2.1/31_amd64_firefox.patch,
+  +files/patches-3.2.1/31_x86_firefox.patch,
+  +files/patches-3.2.1/40_amd64_cairo-signedness.patch,
+  +files/patches-3.2.1/40_x86_cairo-signedness.patch, swt-3.2.1.ebuild:
+  Fixed building with seamonkey useflag - bugs #156716 and #155725. Thanks to
+  Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org> for adjusting the x86
+  patches for amd64, and ron widler <ron@einfach.org> and William Thomson
+  <wltjr@gentoo.org> for testing them. Now using dir-based epatch to apply
+  them.
 
   20 Nov 2006; Vlastimil Babka <caster@gentoo.org> swt-3.2.1.ebuild:
   Apply previous patches only on x86 as a workaround for bug #155725.
index dd48d110db2e58e987d2c680ce5935d55c2fab0a..f423eff2c4310336d2adcef4e4e809531f7adc98 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2.1.ebuild,v 1.3 2006/11/20 01:02:33 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.2.1.ebuild,v 1.4 2006/12/01 00:40:33 caster Exp $
 
 inherit eutils java-pkg-2 java-ant-2
 
@@ -62,24 +62,8 @@ src_unpack() {
        cp "${FILESDIR}"/build.xml ${S}/build.xml || die "Unable to update build.xml"
        mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
 
-       # Patch for GCC 4.x warnings
-       epatch "${FILESDIR}"/${PN}-3.2-gcc-4.x-warning-fix.patch
-
-       # https://bugs.eclipse.org/bugs/show_bug.cgi?id=165097
-       epatch "${FILESDIR}"/${PN}-3.2.1-remove-stripping.patch
-
-       # bug #155725
-       if use x86; then
-               epatch "${FILESDIR}"/${PN}-3.2.1-libswt-xpcomgcc4.patch
-
-               epatch "${FILESDIR}"/${PN}-3.2.1-firefox.patch
-       fi
-
-       if [[ ${ARCH} == "amd64" ]] ; then
-               epatch "${FILESDIR}"/${PN}-3.2-cairo-signedness-x86_64.patch
-       else
-               epatch "${FILESDIR}"/${PN}-3.2-cairo-signedness-x86.patch
-       fi
+       # apply all the patches, including arch-specific
+       EPATCH_SOURCE="${FILESDIR}/patches-${PV}" EPATCH_SUFFIX="patch" epatch
 
        sed -i "s/CFLAGS = -O -Wall/CFLAGS = ${CFLAGS} -Wall/" \
                make_linux.mak \