x11-terms/xterm: Bump to version 351
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Nov 2019 09:18:39 +0000 (10:18 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 18 Nov 2019 09:22:00 +0000 (10:22 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
x11-terms/xterm/Manifest
x11-terms/xterm/xterm-351.ebuild [new file with mode: 0644]

index aee97be30099d8f3b3466fa33acc0d7d8f4f54f5..01fe72ccfd991319fb5a7af943816a665e2b5e64 100644 (file)
@@ -2,3 +2,4 @@ DIST xterm-327.tgz 1240131 BLAKE2B 7f009ec995fa9f8007cd5497d13f1120440df40ef0801
 DIST xterm-337.tgz 1336781 BLAKE2B 6878154cc5d2f8547b8b8ffac0bff7603dce6d58c294b4153e169654fc441f1209c97a6d17bf3f880d0160a42e102ca8fd4a291c2b7d373269290a7bbebeeb8d SHA512 fad31aa971a42cf38d3e3db2edc615b408d92226c305654b9276592c6dee075f31c7f082a3f549284f1685a31d5d9dedbda99c2c308a90bd741958f862806609
 DIST xterm-349.tgz 1381911 BLAKE2B 24486676741f138a5b9e98e5b3e213ddd29d83cfed16072f5a1f825f6fe40f72a121bef8e0dfed0aa4c0a912ec4b1ec83f9c9ab2a24a405d7d8de5f3ad1c2451 SHA512 d350671a262973b6486dd9785f84c1f09b6a5e52898ce38d39ed2b11cd8208c473c63c3504533e7e9004af4e690d9032828a14fe6c5474523cfb8ec4badcbd0f
 DIST xterm-350.tgz 1399138 BLAKE2B 3665f1529d41b518dbd5650f74e2ccfb48969430823c68b396a3db962d6906664bd8bf359103e5b22d902bbe823637a246823c2244dfc1b068d16a89a4e87c99 SHA512 66e6cb37ebedd65c473b04cc31917e509f50652358414787a0a3f0b8f39ae957bf0aefe372576f82a698fccc6c45840cd4e4a2d8ce9f0b1fe5582ed88dae724f
+DIST xterm-351.tgz 1401009 BLAKE2B df32425affce33deb199710be118e90da7b1975882aaf92ff1ad5e976ac18f280cf7d72362d82c0ff9f9530d8da3ba133e345ff9de7f0ac0a2134200c9cc87e6 SHA512 941507be19ad062b39c57288c6e28a17f0ceba090a2d1c3f626f638e5333ca9b4c762fe2fbc42908adf7854b00d9a98cb6eb7481dfa50fd0125459f8ca385c00
diff --git a/x11-terms/xterm/xterm-351.ebuild b/x11-terms/xterm/xterm-351.ebuild
new file mode 100644 (file)
index 0000000..017e04f
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+       x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+       kernel_FreeBSD? ( sys-libs/libutempter )
+       media-libs/fontconfig:1.0
+       >=sys-libs/ncurses-5.7-r7:0=
+       x11-apps/xmessage
+       x11-libs/libICE
+       x11-libs/libX11
+       x11-libs/libXaw
+       x11-libs/libXft
+       x11-libs/libxkbfile
+       x11-libs/libXmu
+       x11-libs/libXrender
+       x11-libs/libXt
+       unicode? ( x11-apps/luit )
+       Xaw3d? ( x11-libs/libXaw3d )
+       xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+       media-fonts/font-misc-misc
+       x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+       DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+       # 454736
+       # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+       # something sane like pkg-config or ncurses5-config and stops guessing libs
+       # Everything gets linked against ncurses anyways, so don't shout
+       append-libs $(pkg-config --libs ncurses)
+
+       local myeconfargs=(
+               --disable-full-tgetent
+               --disable-imake
+               --disable-setgid
+               --disable-setuid
+               --enable-256-color
+               --enable-broken-osc
+               --enable-broken-st
+               --enable-dabbrev
+               --enable-exec-xterm
+               --enable-i18n
+               --enable-load-vt-fonts
+               --enable-logging
+               --enable-screen-dumps
+               --enable-warnings
+               --enable-wide-chars
+               --libdir="${EPREFIX}"/etc
+               --with-app-defaults="${DEFAULTS_DIR}"
+               --with-utempter
+               --with-x
+               $(use_enable openpty)
+               $(use_enable sixel sixel-graphics)
+               $(use_enable toolbar)
+               $(use_enable truetype freetype)
+               $(use_enable unicode luit)
+               $(use_enable unicode mini-luit)
+               $(use_with Xaw3d)
+               $(use_with xinerama)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       docinto html
+       dodoc xterm.log.html
+       domenu *.desktop
+
+       # Fix permissions -- it grabs them from live system, and they can
+       # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+       # respectively (#69510).
+       # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+       fperms 0755 /usr/bin/xterm
+
+       # restore the navy blue
+       sed -i -e 's:blue2$:blue:' "${ED}${DEFAULTS_DIR}"/XTerm-color || die
+}