dev-libs/boost: Build Boost.Fiber only on amd64 and x86
authorDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 14:31:12 +0000 (15:31 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 22 Jan 2017 14:49:41 +0000 (15:49 +0100)
Gentoo-bug: 605538

Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/3595

dev-libs/boost/boost-1.62.0-r1.ebuild
dev-libs/boost/boost-1.63.0.ebuild
dev-libs/boost/metadata.xml

index f0d7ce83e50af8bfcfd5484cb686c2193805a5d3..a1e9c1f9288c4667bec1d30b05522cacb920d410 100644 (file)
@@ -186,6 +186,7 @@ src_configure() {
                        --without-context
                        --without-coroutine
                        --without-coroutine2
+                       --without-fiber
                )
        use threads || OPTIONS+=(
                        --without-thread
index edbbeed6f6e27bdc8550dc772a07f12e2c0634df..9d6f4887a40d8848d249984be9e50bb6bda4e780 100644 (file)
@@ -182,6 +182,7 @@ src_configure() {
                        --without-context
                        --without-coroutine
                        --without-coroutine2
+                       --without-fiber
                )
        use threads || OPTIONS+=(
                        --without-thread
index 82b66b2fbce47cf9d8f74a53f861bb8ad2dd37d0..4f85afb6e3f1e3d02aac555abf041410b47c2d37 100644 (file)
@@ -9,39 +9,14 @@
                <email>office@gentoo.org</email>
                <description>Please CC on stabilisation bugs</description>
        </maintainer>
-
        <use>
-               <flag name="context">
-      Build and install the Boost.Context library and all other 
-      Boost libraries that depend on it
-    </flag>
-               <flag name="tools">
-      Build and install the boost tools (bcp, quickbook, inspect,
-      wave)
-    </flag>
-               <flag name="debug" restrict="&lt;dev-libs/boost-1.50.0-r3">
-      Build and install debug versions of the Boost libraries. These
-      libraries are not used by default, and should not be used unless
-      you're developing against Boost.
-    </flag>
-               <flag name="debug" restrict="&gt;dev-libs/boost-1.52.0-r2">
-      Build and install only the debug version of the Boost
-      libraries. Only enable this flag if you're developing against
-      boost.
-    </flag>
-               <flag name="threads">
-      Build multi-thread-compatible libraries instead of
-      single-threaded only.
-    </flag>
-               <flag name="nls">
-      Build libboost_locale. This library requires compatible C
-      library interfaces, which might not be provided by uClibc or
-      other embedded libraries.
-    </flag>
-               <flag name="doc">
-      Install the full API documentation documentation. This takes
-      over 200MB of extra disk space.
-    </flag>
+               <flag name="context">Build and install the Boost.Context (and Boost.Fiber) library and all other Boost libraries that depend on it</flag>
+               <flag name="tools">Build and install the boost tools (bcp, quickbook, inspect, wave)</flag>
+               <flag name="debug" restrict="&lt;dev-libs/boost-1.50.0-r3">Build and install debug versions of the Boost libraries. These libraries are not used by default, and should not be used unless you're developing against Boost.</flag>
+               <flag name="debug" restrict="&gt;dev-libs/boost-1.52.0-r2">Build and install only the debug version of the Boost libraries. Only enable this flag if you're developing against boost.</flag>
+               <flag name="threads">Build multi-thread-compatible libraries instead of single-threaded only.</flag>
+               <flag name="nls">Build libboost_locale. This library requires compatible C library interfaces, which might not be provided by uClibc or other embedded libraries.</flag>
+               <flag name="doc">Install the full API documentation documentation. This takes over 200MB of extra disk space.</flag>
        </use>
        <upstream>
                <remote-id type="sourceforge">boost</remote-id>