Fix LIVEVCS.stable for -* keywords. This patch is from trunk r3487.
authorZac Medico <zmedico@gentoo.org>
Wed, 21 Jun 2006 02:59:39 +0000 (02:59 -0000)
committerZac Medico <zmedico@gentoo.org>
Wed, 21 Jun 2006 02:59:39 +0000 (02:59 -0000)
svn path=/main/branches/2.1/; revision=3572

bin/repoman

index bf2e570729a7e636b6deeb688d0c86f1edb579b1..1c0f1d72b15da625e7905c6cc32c98baa51cffc7 100755 (executable)
@@ -1018,7 +1018,7 @@ for x in scanlist:
                not be allowed to be marked stable
                """
                if set(["darcs","cvs","subversion","git"]).intersection(myaux["INHERITED"].split()):
-                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~")]
+                       bad_stable_keywords = [keyword for keyword in myaux["KEYWORDS"].split() if not keyword.startswith("~") and not keyword.startswith("-")]
                        if bad_stable_keywords:
                                stats["LIVEVCS.stable"] += 1
                                fails["LIVEVCS.stable"].append(x+"/"+y+".ebuild with stable keywords:%s " % bad_stable_keywords)