dev-python/plyvel: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:54:07 +0000 (12:54 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:59:32 +0000 (12:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/plyvel/Manifest
dev-python/plyvel/plyvel-1.1.0.ebuild [deleted file]

index d22c82269518800053e7cb28329b7422a95ce7cc..b3a5bfdc33cf105cc167870e868a5b0633f985b5 100644 (file)
@@ -1,2 +1 @@
-DIST plyvel-1.1.0.tar.gz 143970 BLAKE2B 980c8117f39c704abaf1733bfabb6816aa84e5e449ed37368038a7d6cd4cbbbf832319bf149ec6ae7cca5074984427df08afc50e033451d3d97ddafd210d91e0 SHA512 4d9b20f7e047d75af14d530519b4360194a18aa423a57ac4596441e47528bbc9f8e3ff763dd91da4c115cb1e4a6f34f01bbd47f4be49be110b2f6e3c7b8bdb3a
 DIST plyvel-1.2.0.tar.gz 145528 BLAKE2B 3a1604b536e462b3eccb7c8294c607828b8f41f3ead65c74fd200d3bb4179765d63f57508cb3bfaee1c4c57ecda7b986afe9416714ae74ed9ad35a9247397c98 SHA512 00b3424e248d1ed17f6443c9862c9f35c94ad76707df5adfe625d7a387620252ff71b3e1f7e903dda1c5cfcd53cb23883c1049e31df541dfe566b8e849c0a96d
diff --git a/dev-python/plyvel/plyvel-1.1.0.ebuild b/dev-python/plyvel/plyvel-1.1.0.ebuild
deleted file mode 100644 (file)
index 7b5f434..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# Tests fail with PyPy: https://github.com/wbolster/plyvel/issues/38
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface to LevelDB"
-HOMEPAGE="https://github.com/wbolster/plyvel"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=">=dev-libs/leveldb-1.20:="
-DEPEND="
-       ${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-       )
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/_build/html || die
-               HTML_DOCS=( doc/_build/html/. )
-       fi
-}
-
-python_test() {
-       # We need to copy the extension to the package folder
-       local ext="$(ls "${BUILD_DIR}/lib/${PN}/"*.so | head -n1 || die)"
-       ln -s "${ext}" "${PN}" || die
-       pytest -vv || die "tests failed with ${EPYTHON}"
-       rm "${PN}/$(basename "${ext}")" || die
-}