sys-devel/gdb: stop installing bfd/opcodes translations #528088
authorMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 17:38:21 +0000 (13:38 -0400)
committerMike Frysinger <vapier@gentoo.org>
Sat, 26 Sep 2015 18:15:06 +0000 (14:15 -0400)
The binutils-libs package will install the canonical files for the
various binutils libraries and that includes translations.  Delete
the copies in gdb until we can figure out how to localize them.

sys-devel/gdb/gdb-7.10-r1.ebuild [moved from sys-devel/gdb/gdb-7.10.ebuild with 96% similarity]
sys-devel/gdb/gdb-9999.ebuild

similarity index 96%
rename from sys-devel/gdb/gdb-7.10.ebuild
rename to sys-devel/gdb/gdb-7.10-r1.ebuild
index 5cd44b4cff8b3d4895caa6bbdaae55da1cc5d98f..ec3031d7d1c2afb7cc2d73334f5a19615537625e 100644 (file)
@@ -170,6 +170,14 @@ src_install() {
        use client && find "${ED}"/usr -name libiberty.a -delete
        cd "${S}"
 
+       # Delete translations that conflict with binutils-libs. #528088
+       # Note: Should figure out how to store these in an internal gdb dir.
+       if use nls ; then
+               find "${ED}" \
+                       -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
+                       -delete
+       fi
+
        # Don't install docs when building a cross-gdb
        if [[ ${CTARGET} != ${CHOST} ]] ; then
                rm -r "${ED}"/usr/share/{doc,info,locale}
index 5cd44b4cff8b3d4895caa6bbdaae55da1cc5d98f..ec3031d7d1c2afb7cc2d73334f5a19615537625e 100644 (file)
@@ -170,6 +170,14 @@ src_install() {
        use client && find "${ED}"/usr -name libiberty.a -delete
        cd "${S}"
 
+       # Delete translations that conflict with binutils-libs. #528088
+       # Note: Should figure out how to store these in an internal gdb dir.
+       if use nls ; then
+               find "${ED}" \
+                       -regextype posix-extended -regex '.*/(bfd|opcodes)[.]g?mo$' \
+                       -delete
+       fi
+
        # Don't install docs when building a cross-gdb
        if [[ ${CTARGET} != ${CHOST} ]] ; then
                rm -r "${ED}"/usr/share/{doc,info,locale}