Bug #212509 - Display a note about the --without-mask option when there
authorZac Medico <zmedico@gentoo.org>
Fri, 28 Mar 2008 12:59:23 +0000 (12:59 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 28 Mar 2008 12:59:23 +0000 (12:59 -0000)
are masked packages. (trunk r9521)

svn path=/main/branches/2.1.2/; revision=9574

bin/repoman

index 18f4d7267284a9f7abeeff06bc9196db8dbe2cf2..f1cb3016eead7b4200c9fbf1f4adbebdb5c06225 100755 (executable)
@@ -1104,6 +1104,7 @@ if isCvs:
        new_ebuilds.update(x for x in mynew if x.endswith(".ebuild"))
        del mycvstree, mynew
 
+have_masked = False
 dofail = 0
 arch_caches={}
 arch_xmatch_caches = {}
@@ -1834,6 +1835,7 @@ for x in scanlist:
                                        ismasked = os.path.join(catdir, y) not in \
                                                portdb.xmatch("list-visible", x)
                                        if ismasked:
+                                               have_masked = True
                                                if "--ignore-masked" in myoptions:
                                                        continue
                                                #we are testing deps for a masked package; give it some lee-way
@@ -1958,6 +1960,10 @@ def grouplist(mylist,seperator="/"):
                        mygroups[xs[0]]+=[seperator.join(xs[1:])]
        return mygroups
 
+if have_masked and not ("--without-mask" in myoptions or "--ignore-masked" in myoptions):
+       print bold("Note: use --without-mask to check " + \
+               "KEYWORDS on dependencies of masked packages")
+
 if mymode!="commit":
        if dofull:
                print bold("Note: type \"repoman full\" for a complete listing.")