Version bump, bug 159908, thanks to Conrad Kostecki <ConiKost at gmx dot de> for...
authorRaúl Porcel <armin76@gentoo.org>
Fri, 13 Apr 2007 11:11:56 +0000 (11:11 +0000)
committerRaúl Porcel <armin76@gentoo.org>
Fri, 13 Apr 2007 11:11:56 +0000 (11:11 +0000)
Package-Manager: portage-2.1.2.3

app-admin/usermin/ChangeLog
app-admin/usermin/files/digest-usermin-1.270 [new file with mode: 0644]
app-admin/usermin/usermin-1.270.ebuild [new file with mode: 0644]

index 476676aa9fa262a66da6dfe5a3aea69502910e55..955ce781871e839bc05411b7717bebb9d13eb5da 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for app-admin/usermin
 # Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.102 2007/01/24 15:07:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.103 2007/04/13 11:11:56 armin76 Exp $
+
+*usermin-1.270 (13 Apr 2007)
+
+  13 Apr 2007; Raúl Porcel <armin76@gentoo.org> +usermin-1.270.ebuild:
+  Version bump, bug 159908, thanks to Conrad Kostecki <ConiKost at gmx dot de>
+  for reporting, and security bug 168878
 
   24 Jan 2007; Marius Mauch <genone@gentoo.org> usermin-1.220.ebuild,
   usermin-1.230.ebuild:
diff --git a/app-admin/usermin/files/digest-usermin-1.270 b/app-admin/usermin/files/digest-usermin-1.270
new file mode 100644 (file)
index 0000000..229b31e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 7b2566786defc5428b8f918f4007a4a8 usermin-1.270.tar.gz 8205679
+RMD160 083fc693096aa70a75360de33e1c162965dda354 usermin-1.270.tar.gz 8205679
+SHA256 0d3c2d09d27418909aa1e4704b60cf5d07e8e7c2fac4c6020530aa5ffe35b1d0 usermin-1.270.tar.gz 8205679
diff --git a/app-admin/usermin/usermin-1.270.ebuild b/app-admin/usermin/usermin-1.270.ebuild
new file mode 100644 (file)
index 0000000..2780b4e
--- /dev/null
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.270.ebuild,v 1.1 2007/04/13 11:11:56 armin76 Exp $
+
+IUSE="ssl"
+
+inherit eutils pam
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="dev-lang/perl"
+
+RDEPEND="${DEPEND}
+        sys-process/lsof
+        ssl? ( dev-perl/Net-SSLeay )"
+
+#       pam? ( dev-perl/Authen-PAM )
+
+
+src_unpack() {
+       unpack ${A}
+
+       cd ${S}
+
+       # Point to the correct mysql location
+       sed -i -e "s:/usr/local/mysql:/usr:g" mysql/config
+
+       epatch ${FILESDIR}/${PN}-1.080-safestop.patch
+       epatch ${FILESDIR}/${PN}-1.150-setup-nocheck.patch
+}
+
+src_install() {
+       # Change /usr/local/bin/perl references
+       find . -type f | xargs sed -i -e 's:^#!.*/usr/local/bin/perl:#!/usr/bin/perl:'
+
+       dodir /usr/libexec/usermin
+       cp -pR * ${D}/usr/libexec/usermin
+
+       newinitd ${FILESDIR}/init.d.usermin usermin
+
+       newpamd ${FILESDIR}/${PN}.pam-include ${PN}
+
+       # Fix ownership
+       chown -R root:0 ${D}
+
+       dodir /etc/usermin
+       dodir /var/log/usermin
+
+       config_dir=${D}/etc/usermin
+       var_dir=${D}/var/log/usermin
+       perl=${ROOT}/usr/bin/perl
+       autoos=1
+       port=20000
+       login=root
+       crypt="XXX"
+       host=`hostname`
+       use ssl && ssl=1 || ssl=0
+       atboot=0
+       nostart=1
+       nochown=1
+       autothird=1
+       nouninstall=1
+       noperlpath=1
+       tempdir="${T}"
+       export config_dir var_dir perl autoos port login crypt host ssl atboot nostart nochown autothird nouninstall noperlpath tempdir
+       ${D}/usr/libexec/usermin/setup.sh > ${T}/usermin-setup.out 2>&1 || die "Failed to create initial usermin configuration."
+
+       # Fixup the config files to use their real locations
+       sed -i -e "s:^pidfile=.*$:pidfile=${ROOT}/var/run/usermin.pid:" ${D}/etc/usermin/miniserv.conf
+       find ${D}/etc/usermin -type f | xargs sed -i -e "s:${D}:${ROOT}:g"
+
+       # Cleanup from the config script
+       rm -rf ${D}/var/log/usermin
+       keepdir /var/log/usermin/
+}
+
+pkg_postinst() {
+       elog "To make usermin start at boot time, run: 'rc-update add usermin default'."
+       elog "Point your web browser to http://localhost:20000 to use usermin."
+}
+
+pkg_prerm() {
+       ${ROOT}/etc/init.d/usermin stop >& /dev/null
+}