dev-python/freezegun: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Wed, 4 Mar 2020 12:28:31 +0000 (13:28 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 4 Mar 2020 12:28:31 +0000 (13:28 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/freezegun/Manifest
dev-python/freezegun/files/freezegun-0.3.10-py37.patch [deleted file]
dev-python/freezegun/freezegun-0.3.10.ebuild [deleted file]
dev-python/freezegun/freezegun-0.3.13.ebuild [deleted file]
dev-python/freezegun/freezegun-0.3.14.ebuild [deleted file]

index 46381f191d1ca881a75a0b3ea850e25172dde11e..6445e30d280cfa66132904ba68331034486ed388 100644 (file)
@@ -1,5 +1,2 @@
-DIST freezegun-0.3.10.tar.gz 20398 BLAKE2B 971f4f3de565878b8a1e4671160f41cc7c558f5c848f5c79dfc48e3f3e3cb71ff9c71090705167d4252edbfee040ef52a7eafd33073011c07337311a7e0ec366 SHA512 64364459dc72484e2124a20a0a84d2b88617efd0578fba687adb51635d578a1e36a00cb119998082610c608e7b6c3589bff5424e38845bad026e85449c8065a5
 DIST freezegun-0.3.12.tar.gz 24346 BLAKE2B 09d7c662a82d7b7fa6ae56c09bff0d73e2b63fba2b492620cd8e68ee06a15129a7e901418d1881e65b440babcfe0d014ad3574ab8dd2c7eab8486b3d868273ac SHA512 f7d98ea84735b24380fa53e1e62622fe91be5a35cb75221ca4cb02418add9b0a4add9b2f691242be75acbc45d4745fef82ffe3c89890dcdffa4405940e527af4
-DIST freezegun-0.3.13.tar.gz 25419 BLAKE2B 8334f921609463bcb18779b61b234bb80406924578ccd43ca1f4a10c65eddf87f399fa7fb285453808988c6f74331345a373cbdcb29f3bd412f3a9e472fce43c SHA512 682f689c475ee574e7a466bfa102b96545cd8b7f095c4b5bdfda496ef667c712248db414d66c9f17fdb1a492c0deeb87a07d8b2a4128d7fdd771f89d5ea8277f
-DIST freezegun-0.3.14.tar.gz 25327 BLAKE2B d96dd84e73e1cd0fdcb8846d97901260aeab80b8ee1d1cc35715073df9693238b8b4e8b8163c6b70daf828f0f7f9e13e202ff99f3325871faca3c4a4331d63cb SHA512 960e63206622bbbc378a64a62c9c849cda1380c63c148588a10347c1bc6414aebffbbbca6c53e734c8651824688c38b47aa71192d94edaac0422caebf4b1cb8c
 DIST freezegun-0.3.15.tar.gz 25530 BLAKE2B 866736cfe556da50f8edba55b0b84c7365e6a1bf32d88e84dfcee6046474b30a9ea15522c3356c5ca30f9a8b79096ba17fdaab240f20e4ef1f91b25ec8262716 SHA512 9f3836f8c9f207d9bccbcaec3f1af977b26aa3699ad5f792d052e105a0de530c6dda1641480c9cd551627186bf0c65d92bf39a6f4a61f458f762d8aa999180ba
diff --git a/dev-python/freezegun/files/freezegun-0.3.10-py37.patch b/dev-python/freezegun/files/freezegun-0.3.10-py37.patch
deleted file mode 100644 (file)
index aa3bd53..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-From 4fdad69659f15a9e62cf4f6c15c9f319276cf9b0 Mon Sep 17 00:00:00 2001
-From: Jonas Obrist <jonas.obrist@hde.co.jp>
-Date: Tue, 6 Mar 2018 12:21:38 +0900
-Subject: [PATCH] add support for Python 3.7 uuid module changes
-
-Python 3.7 removed uuid._uuid_generate_time. It now has
-uuid._load_system_functions and uuid._generate_time_safe.
-_generate_time_safe is set by calling _load_system_functions (subsequent
-calls to that function are no-op). This change detects the missing
-uuid._uuid_generate_time attribute and uses the new attribute/function
-if they're missing.
----
- freezegun/api.py | 14 +++++++++++---
- 1 file changed, 11 insertions(+), 3 deletions(-)
-
-diff --git a/freezegun/api.py b/freezegun/api.py
-index eb09932..a88a392 100644
---- a/freezegun/api.py
-+++ b/freezegun/api.py
-@@ -27,8 +27,14 @@ _real_time_object_ids = set(id(obj) for obj in real_date_objects)
- try:
-     real_uuid_generate_time = uuid._uuid_generate_time
--except (AttributeError, ImportError):
-+    uuid_generate_time_attr = '_uuid_generate_time'
-+except AttributeError:
-+    uuid._load_system_functions()
-+    real_uuid_generate_time = uuid._generate_time_safe
-+    uuid_generate_time_attr = '_generate_time_safe'
-+except ImportError:
-     real_uuid_generate_time = None
-+    uuid_generate_time_attr = None
- try:
-     real_uuid_create = uuid._UuidCreate
-@@ -482,7 +488,8 @@ class _freeze_time(object):
-         time.localtime = fake_localtime
-         time.gmtime = fake_gmtime
-         time.strftime = fake_strftime
--        uuid._uuid_generate_time = None
-+        if uuid_generate_time_attr:
-+            setattr(uuid, uuid_generate_time_attr, None)
-         uuid._UuidCreate = None
-         uuid._last_timestamp = None
-@@ -573,7 +580,8 @@ class _freeze_time(object):
-         time.localtime = time.localtime.previous_localtime_function
-         time.strftime = time.strftime.previous_strftime_function
--        uuid._uuid_generate_time = real_uuid_generate_time
-+        if uuid_generate_time_attr:
-+            setattr(uuid, uuid_generate_time_attr, real_uuid_generate_time)
-         uuid._UuidCreate = real_uuid_create
-         uuid._last_timestamp = None
--- 
-2.18.0
-
diff --git a/dev-python/freezegun/freezegun-0.3.10.ebuild b/dev-python/freezegun/freezegun-0.3.10.ebuild
deleted file mode 100644 (file)
index d4902c6..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Let your Python tests travel through time"
-HOMEPAGE="https://github.com/spulec/freezegun"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               $(python_gen_impl_dep sqlite)
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-
-PATCHES=(
-       "${FILESDIR}"/freezegun-0.3.10-py37.patch
-)
-
-python_test() {
-       nosetests -v || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/freezegun/freezegun-0.3.13.ebuild b/dev-python/freezegun/freezegun-0.3.13.ebuild
deleted file mode 100644 (file)
index c069ad3..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Let your Python tests travel through time"
-HOMEPAGE="https://github.com/spulec/freezegun"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="
-       >dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               $(python_gen_impl_dep sqlite)
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
-       sed -r \
-               -e 's:(python-dateutil)>=2.0:\1:' \
-               -e "s:'(python-dateutil)>=[0-9.]+,.+':'\1':" \
-               -i setup.py
-
-       distutils-r1_python_prepare_all
-}
-
-python_prepare() {
-       # optional and only works with python3
-       if ! python_is_python3; then
-               rm freezegun/_async*.py || die
-       fi
-}
diff --git a/dev-python/freezegun/freezegun-0.3.14.ebuild b/dev-python/freezegun/freezegun-0.3.14.ebuild
deleted file mode 100644 (file)
index c069ad3..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Let your Python tests travel through time"
-HOMEPAGE="https://github.com/spulec/freezegun"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-
-RDEPEND="
-       >dev-python/python-dateutil-2.0[${PYTHON_USEDEP}]
-       dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               $(python_gen_impl_dep sqlite)
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/nose[${PYTHON_USEDEP}]
-       )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
-       sed -r \
-               -e 's:(python-dateutil)>=2.0:\1:' \
-               -e "s:'(python-dateutil)>=[0-9.]+,.+':'\1':" \
-               -i setup.py
-
-       distutils-r1_python_prepare_all
-}
-
-python_prepare() {
-       # optional and only works with python3
-       if ! python_is_python3; then
-               rm freezegun/_async*.py || die
-       fi
-}