media-libs/mesa: Fix slotted LLVM deps to include MULTILIB_USEDEP
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Feb 2017 23:12:33 +0000 (00:12 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Feb 2017 23:15:49 +0000 (00:15 +0100)
Include MULTILIB_USEDEP in all variants of LLVM deps, since it was
mistakenly omitted for slot :4 (and additional := binder). No revbump
since lack of the flags caused build failure, it is quite unlikely for
people to disable them afterwards and it applied only to p.masked
llvm:4.

media-libs/mesa/mesa-17.0.0.ebuild

index ceeb3555a293d1bd7254d0bb8a024ace48336194..c3c5a2c4faa0e3da0c60c6990a018e2715ada974 100644 (file)
@@ -99,14 +99,14 @@ RDEPEND="
                        virtual/libelf:0=[${MULTILIB_USEDEP}]
                        vulkan? (
                                || (
-                                       sys-devel/llvm:4
+                                       sys-devel/llvm:4[${MULTILIB_USEDEP}]
                                        >=sys-devel/llvm-3.9.0:0[${MULTILIB_USEDEP}] ) )
                )
                || (
-                       sys-devel/llvm:4
+                       sys-devel/llvm:4[${MULTILIB_USEDEP}]
                        >=sys-devel/llvm-3.6.0:0[${MULTILIB_USEDEP}]
                )
-               <sys-devel/llvm-5:=
+               <sys-devel/llvm-5:=[${MULTILIB_USEDEP}]
        )
        opencl? (
                                app-eselect/eselect-opencl
@@ -149,11 +149,11 @@ DEPEND="${RDEPEND}
        )
        opencl? (
                || (
-                       sys-devel/llvm:4
+                       sys-devel/llvm:4[${MULTILIB_USEDEP}]
                        >=sys-devel/llvm-3.6.0:0[${MULTILIB_USEDEP}]
                )
                || (
-                       sys-devel/clang:4
+                       sys-devel/clang:4[${MULTILIB_USEDEP}]
                        >=sys-devel/clang-3.6.0:0[${MULTILIB_USEDEP}]
                )
                >=sys-devel/gcc-4.6