dev-db/mysql: disable more tests
authorThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 15:26:26 +0000 (17:26 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Mon, 4 May 2020 16:00:50 +0000 (18:00 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-db/mysql/mysql-5.7.30.ebuild
dev-db/mysql/mysql-8.0.20.ebuild

index 1207ac15ee691483a92aed6687bff887acd87dd6..2c7797e6428f6b38a68a45e4c609775abac76627 100644 (file)
@@ -542,10 +542,16 @@ src_test() {
                gis.spatial_utility_function_distance_sphere \
                gis.spatial_utility_function_simplify \
                gis.spatial_analysis_functions_centroid \
+               main.with_recursive \
        ; do
                _disable_test "$t" "Known rounding error with latest AMD processors"
        done
 
+       if ! hash zip 1>/dev/null 2>&1 ; then
+               # no need to force dep app-arch/zip for one test
+               _disable_test "innodb.partition_upgrade_create" "Requires app-arch/zip"
+       fi
+
        if use numa && use kernel_linux ; then
                # bug 584880
                if ! linux_config_exists || ! linux_chkconfig_present NUMA ; then
index e6d1693f2a1935cddb14a0ee223404105351d025..d532682d0e81caecfc234bfae763c05ae8f1bdb5 100644 (file)
@@ -388,6 +388,7 @@ src_test() {
        disabled_tests+=( "gis.spatial_analysis_functions_distance;5452;Known rounding error with latest AMD processors (PS)" )
        disabled_tests+=( "main.window_std_var;0;Known rounding error with latest AMD processors -- no upstream bug yet" )
        disabled_tests+=( "main.window_std_var_optimized;0;Known rounding error with latest AMD processors -- no upstream bug yet" )
+       disabled_tests+=( "main.with_recursive;0;Known rounding error with latest AMD processors -- no upstream bug yet" )
        disabled_tests+=( "rpl_gtid.rpl_gtid_stm_drop_table;90612;Known test failure" )
        disabled_tests+=( "rpl_gtid.rpl_multi_source_mtr_includes;0;Known failure - no upstream bug yet" )
        disabled_tests+=( "sys_vars.myisam_data_pointer_size_func;87935;Test will fail on slow hardware")
@@ -396,6 +397,11 @@ src_test() {
        disabled_tests+=( "x.message_compressed_payload;0;False positive caused by protobuff-3.11+" )
        disabled_tests+=( "x.message_protobuf_nested;0;False positive caused by protobuff-3.11+" )
 
+       if ! hash zip 1>/dev/null 2>&1 ; then
+               # no need to force dep app-arch/zip for one test
+               disabled_tests+=( "innodb.partition_upgrade_create;0;Requires app-arch/zip" )
+       fi
+
        local test_infos_str test_infos_arr
        for test_infos_str in "${disabled_tests[@]}" ; do
                IFS=';' read -r -a test_infos_arr <<< "${test_infos_str}"