sys-apps/inxi: version bump to 2.3.0_p20160807
authorJonas Stein <news@jonasstein.de>
Mon, 15 Aug 2016 22:03:04 +0000 (00:03 +0200)
committerJonas Stein <news@jonasstein.de>
Wed, 17 Aug 2016 18:50:06 +0000 (20:50 +0200)
sys-apps/inxi/Manifest
sys-apps/inxi/inxi-2.3.0_p20160807.ebuild [new file with mode: 0644]

index e8c0f701c709498174f413e856c8bc8ac393c61d..e43f3232aea697b0ef8e02c366ac0d58dedc0121 100644 (file)
@@ -1,2 +1,3 @@
 DIST inxi-2.2.14.tar.gz 179900 SHA256 c7acc482e860864d69365c2548b2efcfd334432dc053568a4dce37d6699146e5 SHA512 0cc5c1a6d6e3611e3203ca9747477316b6171a8926c33ce4b6f2531fa9c644fa4a7de654e78958efb770fdd0fd1c7ec734bc32e98d9651e3154ab5a2aee58f2d WHIRLPOOL f74ac82c213bc5949da2602d5a38abd061889877ceb6f0e3a2e4988b205d1179e1eac8a42a2402e064773b8ca124cba544e9e37fbb1d1d16b2c4d83e58ce0728
 DIST inxi-2.2.19.tar.gz 181796 SHA256 8611d5c906234b348fc46cd287660b7676a1a5cd85bd38367dad2e0ceb2e92df SHA512 002c33d3cb13269b91732be4f8704b1022d99d46fbb8630bd6f35d8609cbcde22b650da5ff93480a2d1acedfec40b47e8154b757d1a0291eb9d6917009331659 WHIRLPOOL 323b359b0d92959b9504d5a77f6a20194604de98ce8e0bb4f9d5c20610e4787d0247e78e0d93bd01818a906ff421face76704717c4caf1f2313728b66d53aef3
+DIST inxi-2.3.0_p20160807.tar.gz 407468 SHA256 da9bf61c2134291d8f65f5cd270a7026d83ea28f44450c7973e1f5f7aa529313 SHA512 58f91c7b44cfa6a53fba7fdd8300ab5b9bca86a1c558524ad6f26f79123f4e642531543f9d5d04134ca5028323bc9e6db128a15e0c17b41254ff9463db1080f9 WHIRLPOOL eb502482b76a55c2fa7d3c9972fa0b46ee4e12af208073bc2ff4b22d6880868ddd576b1c345905f19fae4ee6469d4dc5fdbdaef0acf4d944e8a390974fa54881
diff --git a/sys-apps/inxi/inxi-2.3.0_p20160807.ebuild b/sys-apps/inxi/inxi-2.3.0_p20160807.ebuild
new file mode 100644 (file)
index 0000000..af46895
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_COMMIT=c2a22b3e2590d896d4b0a8fd298f505cc1d787f5 #because upstream refuses to tag commits with version numbers
+
+DESCRIPTION="Commandline script to print hardware information for irc and administration."
+
+HOMEPAGE="https://github.com/smxi/inxi"
+SRC_URI="https://github.com/smxi/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=app-shells/bash-3.0
+       sys-apps/pciutils
+       "
+
+S="${WORKDIR}/smxi-${PN}-${MY_COMMITID}"
+
+src_install() {
+       dobin ${PN}
+       doman ${PN}.1.gz
+}
+
+pkg_postinst() {
+       einfo "To view a short or full system information."
+       einfo "inxi -b for short information."
+       einfo "inxi -F for full information."
+       einfo "inxi provides seven verbose levels -v1 to -v7."
+       einfo "inxi -h for help."
+}