games-board/natch: remove deprecated games eclass
authorAustin English <wizardedit@gentoo.org>
Thu, 4 Aug 2016 18:38:19 +0000 (13:38 -0500)
committerAustin English <wizardedit@gentoo.org>
Fri, 5 Aug 2016 00:22:42 +0000 (19:22 -0500)
Also update to EAPI 6

Gentoo-Bug: https://bugs.gentoo.org/574082

Package-Manager: portage-2.3.0

games-board/natch/files/natch-2.4-format.patch
games-board/natch/natch-2.4-r1.ebuild [new file with mode: 0644]

index cc2b3207c3b00ac5e703be3153ab20be611a7384..38e2b7939b4e1ca7b646345c1eb6ccc2a9687b2d 100644 (file)
@@ -1,5 +1,5 @@
---- src/pcpjtool.c.old 2014-10-17 08:38:21.547119790 +0200
-+++ src/pcpjtool.c     2014-10-17 08:42:04.949035648 +0200
+--- a/src/pcpjtool.c   2014-10-17 08:38:21.547119790 +0200
++++ b/src/pcpjtool.c   2014-10-17 08:42:04.949035648 +0200
 @@ -45,7 +45,7 @@
      int                       nb_libre = 0;
      const char*               separation_line = "+---+---+---+---+---+---+---+---+\n";
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
new file mode 100644 (file)
index 0000000..239bac1
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="Natch-${PV}"
+DESCRIPTION="A program to solve chess proof games"
+HOMEPAGE="http://natch.free.fr/Natch.html"
+SRC_URI="http://natch.free.fr/Natch/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+       "${FILESDIR}"/${P}-format.patch
+)
+
+src_install() {
+       newbin src/Natch natch
+       dodoc AUTHORS ChangeLog NEWS README THANKS example.txt
+}