Version bump to release 20150810a.
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Mon, 24 Aug 2015 02:42:19 +0000 (02:42 +0000)
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Mon, 24 Aug 2015 02:42:19 +0000 (02:42 +0000)
Update htaccess files so they support both apache 2.2 and 2.4.

Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
www-apps/dokuwiki/Manifest
www-apps/dokuwiki/dokuwiki-20150810a.ebuild [new file with mode: 0644]
www-apps/dokuwiki/files/htaccess [new file with mode: 0644]
www-apps/dokuwiki/files/htaccess-dist [new file with mode: 0644]

index d482c6ed1ce32373eb20f9625b70186d8ead989a..4c03b1a10ad07800a5f9ee84c0836a5139dc1032 100644 (file)
@@ -1,3 +1,4 @@
 DIST dokuwiki-2014-05-05e.tgz 3218289 SHA256 015b5e76427b97e584f195bab6652beaa80796f12f4a547ba9b6bc4e50387282 SHA512 b306be2378aed7119c9005fc9d0c8af4d89317eac19d633a992c6e37d9fb23e22493f25854e1803c892951ec995adf2a7689e04001666318614dd78813d0ffa4 WHIRLPOOL cb4823e7110fe83eea7d61fbf2937455b44a27805b849bc475ae5c9f74a4de353be283ebd8f2cf95a94df8ea395a2a34b9f2442e763a64c730401aee67347aa9
 DIST dokuwiki-2014-09-29d.tgz 3283317 SHA256 6fc6794e13c8e3fe07f5e02bd09cc3a167486a676e9822fa17aab0a45b094794 SHA512 426c41c5d7c6484cc6d5757dbe8e0ac50bf1088406c5c58d975f19fde5f6cb0a0dafb5a27c9901335b1d65a34578f46ffabbd44eed4f5bbd59d6c3fed1c769e3 WHIRLPOOL 59ea72ab973dfc5119056bfccbd5adae9a2ac45b13dbe5971325ca6e1bc4db2e8213aac1d5aab8d699b43b0602dd4b635841e7279e9535c63ed3d80cc85b1007
 DIST dokuwiki-2015-08-10.tgz 3399960 SHA256 bdede4c71e95c1bd6a8daaa65e2ccfa8ef7372022504b9358f175df964f0a399 SHA512 745edc9ff60d2d145936693a4c66cecc4059c88c6a6fdfcce28cac0f74896f43c9156a11469902be34f278e2138c61a2ee5a8547994bd9163816c25429d8eb1b WHIRLPOOL 74b443432c9b30e4fcfe034a2898cec41ba2142775fe4ee1ae60def332aa572e04f8691914a329975a31d116fdb5e12af3b24d2552c7098ac20cc82c7d960603
+DIST dokuwiki-2015-08-10a.tgz 3406922 SHA256 98f0868c0cf9fc6664b57f89149fa537b73222bcc010247771e4afc08c8199fd SHA512 61108e7dbfa0ce6a142d9a77fbffbfc29cd0ed38ecd52558ab4043703a62d570c230d57822eeb6da2a9e34f6cbf72ac25416e7f97c55b5deae121f34393a9850 WHIRLPOOL 7d4a59669220b8b6abd632a4f074c2643c703d8c7f0c59293536f9f620af92e6a25e896fb48e084dd576456fc8399df53331606628288b97508b2950a3323a77
diff --git a/www-apps/dokuwiki/dokuwiki-20150810a.ebuild b/www-apps/dokuwiki/dokuwiki-20150810a.ebuild
new file mode 100644 (file)
index 0000000..2060b51
--- /dev/null
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+# upstream uses dashes in the datestamp
+MY_BASE_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PV="${MY_BASE_PV}${PV:8:1}"
+
+DESCRIPTION="DokuWiki is a simple to use Wiki aimed at a small company's documentation needs."
+HOMEPAGE="http://wiki.splitbrain.org/wiki:dokuwiki"
+SRC_URI="http://download.dokuwiki.org/src/${PN}/${PN}-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gd"
+
+DEPEND=""
+RDEPEND="
+       >=dev-lang/php-5.3[xml]
+       virtual/httpd-php:*
+       gd? ( ||
+               (
+                       dev-lang/php[gd]
+                       media-gfx/imagemagick
+               )
+       )
+"
+
+need_httpd_cgi
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+       # create initial changes file
+       touch data/changes.log
+}
+
+src_install() {
+       webapp_src_preinst
+
+       dodoc README
+       rm -f README COPYING
+
+       docinto scripts
+       dodoc bin/*
+       rm -rf bin
+
+       insinto "${MY_HTDOCSDIR}"
+       doins -r .
+
+       # Copy custom .htaccess that works with both apache 2.2 and 2.4
+       for dir in "conf" "data" "inc" "inc/lang"; do
+               insinto "${MY_HTDOCSDIR}/${dir}"
+               newins "${FILESDIR}/htaccess" ".htaccess"
+       done
+
+       # Use custom .htaccess.dist that works with both apache 2.2 and 2.4
+       insinto "${MY_HTDOCSDIR}/"
+       newins "${FILESDIR}/htaccess-dist" ".htaccess.dist"
+
+       for x in $(find data/ -not -name '.htaccess'); do
+               webapp_serverowned "${MY_HTDOCSDIR}"/${x}
+       done
+
+       webapp_configfile "${MY_HTDOCSDIR}"/.htaccess.dist
+       webapp_configfile "${MY_HTDOCSDIR}"/conf
+
+       for x in $(find conf/ -not -name 'msg'); do
+               webapp_configfile "${MY_HTDOCSDIR}"/${x}
+       done
+
+       webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+       webapp_src_install
+}
diff --git a/www-apps/dokuwiki/files/htaccess b/www-apps/dokuwiki/files/htaccess
new file mode 100644 (file)
index 0000000..18532a2
--- /dev/null
@@ -0,0 +1,10 @@
+# Apache 2.4
+<IfModule mod_authz_core.c>
+    Require all denied
+</IfModule>
+
+# Apache 2.2
+<IfModule !mod_authz_core.c>
+    Order Allow,Deny
+    Deny from all
+</IfModule>
diff --git a/www-apps/dokuwiki/files/htaccess-dist b/www-apps/dokuwiki/files/htaccess-dist
new file mode 100644 (file)
index 0000000..dc8cace
--- /dev/null
@@ -0,0 +1,43 @@
+## Enable this to restrict editing to logged in users only
+
+## You should disable Indexes and MultiViews either here or in the
+## global config. Symlinks maybe needed for URL rewriting.
+#Options -Indexes -MultiViews +FollowSymLinks
+
+## make sure nobody gets the htaccess, README, COPYING or VERSION files
+<Files ~ "^([\._]ht|README$|VERSION$|COPYING$)">
+       # Apache 2.4
+       <IfModule mod_authz_core.c>
+               Require all denied
+       </IfModule>
+
+       # Apache 2.2
+       <IfModule !mod_authz_core.c>
+               Order Allow,Deny
+       Deny from all
+       </IfModule>
+</Files>
+
+## Uncomment these rules if you want to have nice URLs using
+## $conf['userewrite'] = 1 - not needed for rewrite mode 2
+#RewriteEngine on
+#
+#RewriteRule ^_media/(.*)              lib/exe/fetch.php?media=$1  [QSA,L]
+#RewriteRule ^_detail/(.*)             lib/exe/detail.php?media=$1  [QSA,L]
+#RewriteRule ^_export/([^/]+)/(.*)     doku.php?do=export_$1&id=$2  [QSA,L]
+#RewriteRule ^$                        doku.php  [L]
+#RewriteCond %{REQUEST_FILENAME}       !-f
+#RewriteCond %{REQUEST_FILENAME}       !-d
+#RewriteRule (.*)                      doku.php?id=$1  [QSA,L]
+#RewriteRule ^index.php$               doku.php
+#
+## Not all installations will require the following line.  If you do,
+## change "/dokuwiki" to the path to your dokuwiki directory relative
+## to your document root.
+#RewriteBase /dokuwiki
+#
+## If you enable DokuWikis XML-RPC interface, you should consider to
+## restrict access to it over HTTPS only! Uncomment the following two
+## rules if your server setup allows HTTPS.
+#RewriteCond %{HTTPS} !=on
+#RewriteRule ^lib/exe/xmlrpc.php$      https://%{SERVER_NAME}%{REQUEST_URI} [L,R=301]